(Bug) "Scan with webroot" on right click menu stops working at random times!

Userlevel 1
I think I have come across another "bug" concerning the "Scan with webroot" on right click menu.
I don't know what causes it but at random times on all my computers running Webroot Secure Anywhere Essentials 2012 Version the "Scan with webroot" on right menu stops working. What happens is I right click on a file or folder and and click on "Scan with webroot" and then nothing happens. I get no pop up box from  Secure Anywhere showing its scanning.
And when this bug happens the only way I seem to be able to get  "Scan with webroot" working again I have to shut down Secure Anywhere Essentials and restart it. Once I do that "Scan with webroot" works like normal again until the random bug happens again.
But like I said I have no idea what makeit happen in the first place.
But there must be a bug somewhere in the software that neess to be fixed.
Anyone else here every have this happen?

Best answer by JimM 17 December 2012, 23:37

View original

42 replies

Userlevel 7
I'm checking into this for you.  It's possible that this issue might be fixed already in a version that is still in testing due to a fix related to a similar issue.  I'm checking in with our lead developer to see whether or not he thinks that is the case.  It might take a little bit of time to hear back from him, but when I do I'll update this thread.
So far, I haven't been able to reproduce this issue yet on my test box.  Considering the complexitiy of the issue at hand and the probable necessity of logs, this merits opening a support ticket.
-edit for new info-
It looks like the only way we'll know for sure one way or the other whether or not this issue is ultimately indirectly fixed by the fix to the similar recycle-bin context menu issue is to wait until that fix gets at least to a beta release stage.  Then we can test it out on your computer and see if it fixes both problems or just one of them.  I'll be in touch once it hits beta.
Userlevel 1
Thanks for the info Jim :D
Userlevel 7
Was this issue resolved for you in  I know we had a lengthy discussion about the recycle bin specifically in the other related thread, but I wanted to touch base with you and see if this other part of the issue was also resolved or not.
Thanks 🙂
Userlevel 1
Unfortunately no the issue still remians.,
I don't know what is causing it but at random times the "Scan with webroot" from right clocik menu just quits working.
I am going to open up a ticket for this now.
Userlevel 7
Please do open one up, and be sure to give specific information on what you are trying to scan and such.  Also, the below information may help.
For security reasons, the context menu Scan does not use unbounded DDE, but rather does have a limiton it.  So trying to scan a large number of files by selecting them all and right-clicking then Scan with Webroot will only scan the subset that fit first.  Also, scanning a file deep in a directory structure may cut off, so if the file is, for example, in something like:
C:MyFilesLots of StuffPicturesDigital CamerasThe Old KodakDownloadsAutomaticReally OldPictures of the ParkKims shots2006-12-01-12:22:23Originals
Well, in that case Windows Explorer may have a problem.
Also, as a minor note, there is a delay between when you click "Scan with Webroot" and when it actually starts to scan.  And by delay, I mean on this test machine, it took Explorer about 22 seconds to actually tell Webroot to start the scan.  That's a long time to sit and wait and stare at the computer. 🙂
Userlevel 1
When this bug happens even if I try and scan 1 little.jpg on my desktop "Scan with webroot" does not work.
Userlevel 1
All 3 of my computers are having this issue at  random times :(
Am I realy the only one here who has experienced this problem?
I opened up a ticket and hopfully it will be fixed :)
I have had this issue since first I switched form Avast to Webroot Secure Anywhere Essentials 2012.
Userlevel 7
The fact that you may, indeed, be the only one experiencing this problem is why I felt that the ticket would be the best approach.  The closest I have been able to see to what you describe is that on an XP VM that has a system uptime of 23 days and is running on one CPU takes quite some time (About 20 second on average) to actually perform the scan on occasion.  This means that if I Right-Click and Scan with Webroot, it looks like it does nothing at all.  Then if I right-click on another file and want to scan it, only one scan of the two apparently happens.  But if I sit and wait instead, it scans finally.  We're looking into this already now.  But what you are describing is different, so looking at the details will help.
Userlevel 1
The issue you are talking about does sound very simular to my issue. Its not exactly the same but its very close I would say :)
I just uploaded another log file this time from my laptrop computer. However currently at this time the "Scan with Webroot" is working nice and fast on it and thats only because I restarted the laptop early this morning. But at any given time I can almost guarantee the "Scan with Webroot" wil break again.
As of this moment only 1 of my 3 computers "Scan with Webroot" is not working. And I am guessing that because that computer has not been restarted in a while. The other 2 are working and thats because they were both restarted this morning. 
Any info you guys need I will be happy to share to get this fixed 🙂
Userlevel 7
Did you get the ticket sent in?  That's the best way to continue on the issue.  That goes to support and they can get full analysis logs.  If they don't spot anything obvious (to us) in those logs, the situation gets escalated to an Escalation Engineer (my prior position) and advanced investigation is their specialty.
From my point of view, what I've noticed by doing a trace on my end is that Explorer itself is not triggering the call until very late.  I wonder if that is being later (Like, oh, say, an hour plus. : ) for you.
Userlevel 1
@ wrote:
Did you get the ticket sent in?  That's the best way to continue on the issue.  That goes to support and they can get full analysis logs.  If they don't spot anything obvious (to us) in those logs, the situation gets escalated to an Escalation Engineer (my prior position) and advanced investigation is their specialty.
From my point of view, what I've noticed by doing a trace on my end is that Explorer itself is not triggering the call until very late.  I wonder if that is being later (Like, oh, say, an hour plus. : ) for you.
Yes I sent the ticket in.
Yep I guess it could be an hour later or more maybe a lot more lol.
Userlevel 7
I believe this issue has been fixed in Can you please confirm if the problem is resolved on your particular computer once you receive the update?
Userlevel 1
@ wrote:
I believe this issue has been fixed in Can you please confirm if the problem is resolved on your particular computer once you receive the update?

I have been running build for around 24 hours and so far everytime I have clicked on "Scan with Webroot" it has worked nice and fast everytime! It has not stopped working yet :)
Of course like I said its only been around 24 hours since installing build
But its looking good and I think its safe to say the issue is indeed now fixed with build!
Thanks for fixing it guys! :)
I will report back to you if it breaks again. 
Userlevel 1
Bad News! :(
I just went on my computer and all of a sudden every time I use the "Scan with Webroot" it works however it takes like 10 Seconds to show the scanning window. Where normally it is instantly!
So while build seems to have greatly improved the issue it did not completely fixed it yet.
With build the "Scan with Webroot" has not stopped working yet and its been over 48 hours but now the scanning windows takes 10 seconds to open. When I first installed build the scanning windows would appear instantly And did so for about at least the first 48 horus since installing it. But all of a sudden as of now the scanning windows takes 10 seconds to appear. But I guess the good news is with build at least the "Scan with Webroot" still works even though its slow unlike with the last and early builds where it would just stop working altogether.
I have just uploaded a log file if you want to take a look at it 🙂
Userlevel 1
Update!The "Scan with webroot" just stopped working completely again! :(So it is not fixed at all 😞
Userlevel 7
I feel sorry for your troubles.
I went through this thread and doubt that WSA is not the culprit even if it can looks like. It sounds me as any other process blocks the right click scan. What is strange though is that you did experience no problems for certain period (I think you mentioned 48 hours or so). Therefore I guess that there might be another application (mostly security) which is letting the right click scan to work until that application labels WSA's right click scan process as malicious. Then the scan is malfunctioning as you described.
However that's all just my guessing and I highly recommend you to re-open the support ticket.
Sorry if I misled you.
Thanks & regards,
Userlevel 7
I think the best bet in this case is to get a ticket opened in the system and get it up to an Escalation Engineer who can remote onto the system for you when it's occurring and gather procmon data to pinpoint the source of the issue. 
The biggest problem in fixing this is that this is the only known case of it out of millions of customers, so it's a pretty small needle and a pretty big haystack.  Without very precise data of what is occurring, there's little way to diagnose it.
Since you already have a ticket in, I'll go nudge the EE's and see what's up.
Userlevel 1
Bill Alcorn a Escalation Engineer contacted me by e mail and will be setting up a time hopefully today where he will remote access my computer and try and see whats going on with this issue 🙂.
This issue is so stange I restarted my computer this morning and of course the "Scan with webroot" starting working again. So I go away from the computer for maybe 1 hour or so to eat breakfast. then go on a different computer and try running "Scan with webroot" from that computer and of course "Scan with webroot" is not working but I knew that already because that computer was not restarted. So then I go back on the other computer where "Scan with webroot" was working before I had breakfast and now "Scan with webroot" is not working again.
So what in the world could have happend in the hour or so that I was away from the computer?
The only thing I did besides eating breakfast 🙂 lol was I tried to run "Scan with webroot" from another computer and like I said that was not working either but I already knew that from the night before as I had not restarted it yet to fix it.
Is there any possibility that when I used  "Scan with webroot" on one of my computers to scan files on a networked computer could be what is breaking "Scan with webroot"?
It looks like this issue is going to be a hard one to fix. 
Userlevel 1
Hello everyone,
Just wanted to update you on this issue.
Its still not fixed as of build
It does seem to happen less often with this latest build but its not 100% completely fixed I am sorry to say.
Looks like this will be a very hard bug to track down and fix. 😞
Userlevel 7
It is still being investigated.  The main problem is that it's always related to the service crashing (shutting down unexpectedly) and restarting, but on a properly-working machine, it's not easy to get the service to do this.  There is no special utility to make it do so, for example.
Userlevel 1
I just uploaded new logs as "Scan with Webroot" stopped working again 😞
Userlevel 7
Which confirms the issue.

The service crashes, and Windows Explorer doesn't communicate with the correct named pipe thereafter.
8/26/2012 15:59    The WRSVC service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 10000 milliseconds: Restart the service.
Since the computer was rebooted four days ago, it hasn't been restarted since the service crash.
This is a two-part concern. 
The first part is that it's very difficult to track this bug down internally because there are no easy ways to get the service to crash in order to reproduce the bug. 
The second, and more concerning concern, is why the service is crashing so often on your system.    Though I wonder if it may be related to using quick user swapping.  I'll have to recommend that as a test avenue.
Reviewing the logs, the whole system is giving me a general feeling of "not doing well".  Some services have not shut down when they should.  Both WSA service and Windows Defender service have crashed frequently.  The event log system is even having random issues properly formatting messages (primarily on NNTP alerts in the system events, but a lot of them in the app events).  The real downside though is that there is nothing definitive really that I've found yet.  It could be completely normal for the specifics on this computer, or it could be problems caused by way too many things.
We can look into the reconnection on service crash, but it's definitely a good idea to try to determine why the service is crashing so often for you.  If you are already in touch with an escalation engineer in the main support system, let them know I said this.  They should be able to assist you with locating the dumps or creating them if all else fails.
Userlevel 1
I will pass this info a long to Bill.
Userlevel 1
I may just have just figured out at least one of the causes of making "Scan with Webroot" stop working.

I came on the computer this morning  and the first thing I noticed was "Scan with Webroot" was working again. And that's because it was automatically upgraded to the latest version Then I upgraded one of my programs called Weather Wather Live and noticed right after this update "Scan with Webroot" stopped working again.

I guess it could just have been just a coincidence but I do use and update often Weather Watcher live on all my computers. Also this computer has 2 user accounts on it and I also switched users right before installing Weather Watcher Live. So perhaps
switching users could also be the cause of breaking "Scan with Webroot"?
I reported this to tech support also.
Userlevel 7
The user accounts may be related, but if you know how to check your System Event Logs, check to see if the WRSA service stopped working between when Scan worked and when it didn't work.
When the service stops working and the user-space agent keeps working, it gets disconnected and causes the issue.  We've already replicated that.  We're trying to determine why your service crashes so often.