can't activate software

  • 19 September 2016
  • 6 replies

I purchased webroot on Amazon Prime and it won't install. I had a best buy trial version that expired yesterday on my computer which I removed using the removal software

Best answer by TripleHelix 7 September 2020, 18:59

View original

6 replies

Hi Frfr,
Welcome to the Webroot Community.
Please try the following, and be sure to download the correct version (Regular or Best Buy version)
Please follow the steps closely!
  • Make sure you have a copy of your 20 Character Alphanumeric Keycode! Example: SA69-AAAA-A783-DE78-XXXX
  • Be sure you add your Keycode to your Online Console: Webroot SecureAnywhere Online Console
  • KEEP the computer online for Uninstall and Reinstall to make sure it works correctly
  • Download a Copy Here (or if you have Best Buy Subscription for PC click HERE) Let us know if it is the Mac version you need.
  • Uninstall WSA and Reboot
  • Install with the new installer, enter your Keycode and DO NOT import any settings if offered by the installer as you can set it up as you like once it's done
  • Let it finish it's install scan
  • Reboot once again
Please let us know if that resolves your issue?
The purchased software is registered but when I try to use the old best buy version wants me to renew the best buy version
my computer is PC
Hi Frfr,
If you uninstalled the Best Buy version first, before installing the new version, then I would suggest that you submit a trouble ticket so Webroot can get this staightened out. This is a free service with your paid subscription. In the ticket please provide both the old and new keycodes. You are still protected for 30 days after expiration, regardless.
If you didn't uninstall the Best Buy version first then you must uninstall all versions of Webroot and try a clean install, using the directions provided earlier.
Hope this info helps,

I had Webroot internet complete installed on my windows 10 computer. It was expiring so I purchased a copy of webroot internet plus. I tried to uninstall WEBROOT complete, downloaded and did a fresh install. Now I can’t uninstall or reinstall. I tried to uninstall from the command prompt and in safe mode but is unsuccessful. Any suggestions will help.

Userlevel 7
Badge +63

Hello @BMAN 


There was no need to uninstall and all you needed to do was use the new Keycode and Activate then it would scan and become ISP.




But with that being said now you have a problem and Support is the only one that can help you and they are very busy. So Submit a Support Ticket and they will help you but have some patience!


Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue, it should be 24 to 48 hours but could take a little longer because of COVID 19 and the labour day long weekend.