Deleting Webroot installed by Best Buy

  • 17 December 2014
  • 5 replies

I installed Webroot on my laptop via the key code purchased through best buy.  The subscription was expiring in Dec, 2014, so in Nov 2014 I purchased a renewal via the Webroot website.  I've found out that you must remove the old Best Buy (Geek Squad) version before you can install the Webroot Online update version.  PROBLEM..... my maintenance contract with Geek Squad is expired so they won't remove the Best Buy version unless I pay them for it. Their version of Webroot is locked onto my computer and will not uninstall.  I can't install what I purchased until I get rid of the old one....... How can I do that without paying Geek Squad to do it.?

5 replies

Userlevel 7
Hi RDavis49
Welcome to the Community Forums.
Now, I have to confess to never having heard of this circumstance before, and I suspect that this is a job for one of our gurus in this area @ , and whilst waiting for him to pick up the tag, can you advise as how you know that the current is locked and what message you are getting when trying to uninstall?
Regards, Baldrick
Userlevel 7
Hello there, 
There is no lock on the Best Buy version, it unintalls just like the standard versions.  The ONLY "lock" would be the same possible lock on any other version of WSA: Enabling Access Control to require that the user MUST be logged into the computer as as Administrator AND/OR having a password set within WSA that is required to do any changes to the software settings. (If there was such a password, you would have been provided it at some point, but we can still work around it.)  
I am sorry that they will not help in removing it, but there is no special lock on it to prevent you from removing it yourself.
You can try any of the following, but make sure you are logged into the computer as an Admin user:
1) Go to Control Panel, Programs, Webroot and remove it as you normally would any other software.   You can also try to boot in to Safe Mode and then try it.
2) Log into your Console, select the PC, and send a Deactivate command.
3) You can the steps outlined HERE.  Again, you can try this from Safe Mode as well.
If none of these works, please submit a Trouble Ticket to have Webroot Support assist you.
Let us know how you do 🙂
Same thing happened to me! GeekSquad says it's not won't uninstall...shows up in my win10 apps, but it won't uninstall, can't find it in programs to uninstall. An application file and .exe files have been placed on my computer...pop up everyday, causes slow downs, restarts, my printer to not connect...I don't want it, I have other antivirus/antimalware software that is much better... This is more than infuriating!  GeekSquad says they don't have any tie to WRSA...WRSA should be aware that this happens to people who pay for a service contract and it expires and the pc owner does not renew. They (GS) will not accept responsibility.  I've tried every way possible through every forum...I have days and LOTS of hours into attempting to remove this p.o.s from my pc. I've even tried my RevoUninstallerPro deletes the hanging hidden files...then they return as soon as I restart! Again, I've followed every step that every person has suggested. GeekSquad online chat guy wanted remote access of my computer! Yeah right, like I'm going to allow them access!?  What a scam - this should be illegal the way they place this on a person's pc.
Hello GSH,
Please have a look at this KB Article, which has alternative ways for uninstalling Webroot.
If that fails then please submit a trouble ticket and let support look into this for you.
Thanks, BD
Of course I am writing in jest as I don't care to much for the GS either. I'm surprised they didn't tell you to take a hammer to your computer and then stop by the nearest BB store and buy another one.