My Webroot password manager has stopped working in Firefox Mozilla.

  • 23 August 2015
  • 8 replies

My Webroot password manager has stopped working in Firefox Mozilla.  Mozilla recently upgraded which maybe causing a conflict?  I have turned off the password manager in Firefox, and I log into Webroot, but Webroot does not fill in the blanks on an of my websites.

8 replies

Userlevel 7
Hello there!
Yes.. as you noticed, the upgrade in Firefox is indeed responsible.  We have seen quite a lot of posts about this since mid day Friday.  Webroot is aware of the issue, and they are working on it, but of course it is the weekend.  
I have seen a wide variety of suggestions, some of which seem to work, for some people, but really nothing is working for everyone.  Obviously once Webroot and Mozilla have had a chance to work things out it will be resolved.
Until then.. chances are that the Password Manager just will not work in Firefox, but it does still work just fine in IE and Chrome.  
Userlevel 7
Hi Cindybaran
I am afraid that there are known issues related to the WSA extension & its use with the Mozilla browser. These are recent and Webroot Support is aware/is looking into resolving them as soon as is possible.  For more information the thread with most of it in can be found here.
Until the issue has been resolved by Webroot and Mozilla, keep in mind that both IE and Chrome browsers are still using the browser extensions for both the Web Filter and Password Manager without problem.
You can try to use the Toolbarfix tool as one option...please see this previous thread in which it is described as to where to get it from and how to use it.  This has worked for some user but not all.
But we have also heard some reports that a clean install of Webroot, instead of the toolbarfix, may help resolve the issue. To do that please follow the steps below carefully
  • Make sure you have a copy of your Keycode to hand!
  • KEEP the computer online for Uninstall and Reinstall to make sure it works correctly
  • Download a Copy Here (Best Buy Subscription PC users click HERE)
  • Uninstall WSA and Reboot
  • Install with the new installer, enter your Keycode and don't import any settings if asked to as you can set it up as you like once it's done
  • Let it finish it's install scan
  • Reboot once again
If this does not help resolve the problem, you will probably want to Submit a Support Ticket and get assistance from Webroot Support.  There is on charge for this for WSA user with an active subscription.
Hope that helps?
Regards, Baldrick
Userlevel 5
You state, "Firefox is indeed responsible."    Firefox is not created in a vacum, there are Beta releases, and they have developer editionis.     Webroot should not have been caught off guard by this.  That said I don't want to rant without giving my work around:
My work around has been to remove the extention from Firefox, close my browsers, and run the stand-alone extention install/remove addon program.   Restart Firefox and allow the 'new" extention to run.   This works until I shutdown my computer.  I shoud point out, in my case the extention still shows up in the tool bar, but if I click on, it takes me to the Webroot login page.   Frankly my first though was my system was compermised, and it was a phishing attack.
Thus, I was caught off guard when all of a sudden my password manager did not work.  For Webroot has been silent.   I depend on it greatly.    I am started to re-think that stratigy, or atleast, rethink the Lastpass/Webroot implimintation of this function.   Not long ago, we had the Lastpass breach, and one again Webroot was behind the curve and silent in letting their users know that they were not  effected by the compermised data.  (given that Webroot's password manager and Lastpass's is so clossely intergrated.)
It all comes down to me wondering if picking Webroot as one of the peotection methods of my person data is the best choice.
Userlevel 7
Hi luckygecko
All that you say may or may not be true...that is not for me to comment on.  And how Webroot & Mozilla interact is again not really something that any of us can or should comment on.
Having said that I would say that if you are thinking that WSA might not be for you just because of the extension issue then I would humbly suggest that you have not understood what WSA is about or how it provide top notch protection.
The extention issue, whilst unfortunate in the extreme, does not in any way affect the core protection that WSA provides its users...99% of the proetction is still in place and functioning very well and for the 1% WSA has multiple layers of 'shield's that will pick up anything that might get through due to the extensions not being in operation.
IMHO the extention issue is a mild irritation that will no doubt be fixed soon, no more than that.
Just my two pennies worth, for what they are worth.
Regards, Baldrick
Userlevel 5
Mozilla development does not happen in a vaccum.    Nor, did Windows 10 development.     My issue is not one of simply, as you put it, the "1%" of WSA that is not working, but my issue is the lack of transpancery and trust in my protection software vendor. They have shown a pattern of not keeping their customer based informed of issues in what I consider the most critical software on my system.
 I am not trying to be insulting here, for I have seen your posts, and they give good advice, but where is Webroot?  Why did they not let me know part of their product broke?  They leavei it up to some 'fan boy' (and please, I am not trying to be insulting, just relaying my view), to provide cheerleading and support for this issue. 
That said, one again, I also don't want to post simply feelings without giveing troubleshooting steps that I have also done on this issue.
I was also haveing the missing 'shell' context issue were I could no longer see the "scann with Webroot" selection when I would right click on a file in finder.   So, since I was going to uninstall/reinstall Webroot, I removed the password extention from Firefox.  
After shutting down Webroot, I did the uninstall, and reboot. 
I reinstalled Webroot, let it run the first scan.   Started Friefox, and while it has added the filtering extention, it did not add the password one.   Thus, once again, I ran the toolbarfix program to get it back.   (I should note, searching the forums for tools like that is a pain.  I did find it before I found your post, as I found the WRShellFix tool---which did not work)
So, to sum up, you might call the password manager as 1% of fuction of Webroot, but it is a part of the software package that pushed me in the direction of Webroot, and for me, and I am guessing other customers, a very visiable part that I use everyday.   The rest of Webroot does it thing in the background which is okay for protection software.  But as a company, I would like to see Webroot more visiable in keeping my confidence that my data is safe.
Userlevel 7
As has been stated previously Webroot is working on the issue and I suspect that it is deep in conversation with Mozilla.  The issue only recently occurred and therefore we need to be patient and await updates which I am sure, based on previous experience of the Webroot Development Team & Support Team, will be forthcoming as and when appropriate.
Your reasons for purchasing WSA are your own and are to be respected...what I was attempting to point out was that in terms of overall protection the issue does not really affect the protection afforded by WSA.  As to your data being safe...well it is, as it is stored securely by Webroot in the Webroot Cloud. It is not held on your local machine.
I hope that clarifies?
Regards, Baldrick
Thank you Bladrick.  It worked!
Userlevel 7
Hi cyndybaran
Gald to hear that it did for you...but please don't thank me just yet as we have also had reports of this working and then the next day, at boot up, there being a reoccurrence of the issue. :(
I would carry out a couple of reboots and then if all is till OK then check again tomorrow and if you are still OK then let us know. ;)
Regards, Baldrick