Proxy Issue

I have an issue mainly with Firefox but occasionally IE and Chrome as well.  It just started up int the past 2 or so weeks.
The computer will boot up, and after waiting for it to fully load, I'll attempt to connect to the internet but it either will run really slowly or won't connect at all, stating that the proxy won't allow it.  I'll go into the browser and change the settings to "no proxy" and it will work better, but the next time I boot up, it starts all over.  I contacted Mozilla, and they had me do a bunch of stuff, including uninstalling and reinstalling, and changing a preferences file so that it was forced to build a new one, yet every day, it's back to either slow running or not being able to get on until I tweak the settings.  Finally it was suggested it was my computer and eithe a web security software issue or malware.
I've run the software a number of times and no viruses or malware is located.  I ran ccleaner to clean out cookies, cache, etc, and nothing (I did not run the registry cleaner - I don't know now to fix any of that and don't mess with it).
Any thoughts?  I've been running Webroot for about a month.  OS is Windows 7.  Not running any other security software in tandem.  I switched to Webroot after PCTools got bought out by Symantec.  Did a thorough uninstall of that program first.
I use a home network - a router with 3 laptops, a tablet, and 2 streaming video tv boxes (one laptop acts as my server and is rarely used - the 2 other laptops get the heaviest use).  Internet comes in via cable modem (and it's been suggested I replace the modem due to service issues - dropped connection, etc).  Router is a Belkin.  Modem is a Motorolla.
Please keep in mind I'm not deeply computer savvy - I don't like to fool with the registry or advanced files.

Best answer by JimM 4 July 2013, 04:46

View original

17 replies

Userlevel 7
Badge +56
Hello funky-rat and Welcome to the Webroot Community Forums.
Have you tried to setup the Proxy settings within WSA? Have a look Here:
Thanks.  No, I had not done that, and will do so when I have access to the laptop later.
In the meantime, a stupid question:  how do I know if I need a proxy or not?
Userlevel 7
Badge +56
@ wrote:
Thanks.  No, I had not done that, and will do so when I have access to the laptop later.
In the meantime, a stupid question:  how do I know if I need a proxy or not?
Are you using a Proxy for a specific reason as it sounds to be a home network? "To keep machines behind it anonymous, mainly for security."
I  didn't think I was, but I read something about VPN and I know my router is capable of that (but I'm not sure if I'm using it or not).
I know it sounds silly but I have a degree in computer science, but I got it in 1994.  The college only had intranet when I graduated.  This new stuff is all Greek to me.  😠
Userlevel 7
Badge +56
Are you hosting a Website or P2P on the server do you really need a server as you can use your Router to use a home network?
No.  Perhaps server is the wrong term.  It's the computer that the internet and router are plugged into.  I rarely even turn it on.
I do have two Roku boxes but I doubt that means anything other than sometimes my computer shows the Roku as a separate internet connection available.
Userlevel 7
Badge +56
Maybe someone else can help you that knows more about these types of Networks. But do try the settings within WSA unless otherwise directed by another helper.
Will do, and I think I'll let this rest until a few hours from now when I can sit down in front of the laptop.  And I'll try your first suggestion first.
Thanks!  :catvery-happy:
Userlevel 7
The proxy settings in WSA are to be used when there is already a proxy in place on the computer.  It sounds like funky-rat doesn't know why this proxy is there at all.  Getting to the root of that mystery would require some digging.

If you will please run this log gathering tool and reply back when its complete, I will try to see what I can determine for you.  Default settings are fine.
It's not going to be WSA causing the issue.  I can already tell you that much because WSA will not ever force a browser to use a proxy.  But maybe I can figure out what's causing it for you anyway.
Excellent.  WSA didn't turn up any viruses or malware so this is why I was puzzled.
I'll be able to sit down in front of the laptop this evening.  I'll report back when I get that done.
Thanks so much for all your help.
Userlevel 7
Sure thing! We're coming up on a long weekend unfortunately, so it might be next week before I can take a look at those, just to set reasonable expectations. At least we know it's not Webroot causing the issue. 🙂
Ok.  Hoping to be home around 5pm EST and will try to get that done right away.  I can continue to uncheck that box in the meantime - been doing it for two weeks or so.  :D
Ok.  I did the log and it said it uploaded.
Userlevel 7
Well, the proxy address it's pointing at is just a local port. When malware does it, in every case I've seen myself it's been an external address. It doesn't look like malware to me, but you have a couple of legitimate looking programs I've never seen before that may be trying to auto-proxy for you.

I tracked down a similar issue for you that was reported here:

The fix in that case involved a registry edit, so do it at your own risk if you want to try it.

In any case, it's not Webroot causing it and it doesn't look like malware.
Ok.  There was no shortage of people complaining at Mozilla, so I'm going to call it a Firefox issue for now, unless it may have something to do with Dropbox.  I downloaded that so I could send my dad pictures and vice versa.  That's the only other thing I can think of that I downloaded right before this started happening.  It loads on startup.  I can disable that, but I'm not fooling with the registry.
Thanks for all your help!  As long as it's not a virus or malware, I can deal.  It's more of a nuisance than anything else.  😃
OMG!  I read that full link that you sent me.  The registry edit didn't work, but they noticed after having the person run an ICP test log (or something similar) that the proxy was being used by a legit program - e-rewards notifier.  I downloaded that last month.  E-rewards is a website I use to cards and stuff like that and they put out a notifier to let you know that you have a new opportunity to earn rewards.  And honestly, I've complained to E-rewrds that it doesn't work right.
The person on that link uninstalled it and problem went away.
I'm off to uninstall it now.  It's buggy anyway.
Thanks so much!!!  :catlol:
Userlevel 7
Sure thing!  I'm glad we could be of assistance!