Webroot shows RENEW NOW message at startup even though account display shows 360 days left.

  • 18 June 2017
  • 3 replies

Userlevel 1
Badge +5
My webroot products are purchased through Best Buy. I bought another PC from them last year. They sold me another webroot even though I had a license for three PCs and was using only 2. When the new webroot was close to expiration the usual RENEW NOW box started appearing. I had Best Buy switch that PC to the license for three. All is well, The new PC webroot si showing 360+ days left and is protecting my PC. The problem is that the RENEW NOW message keeps appearing at startup. I have seen messages, going back over a year, on the web complaining obout this RENEW message not going away. I am pretty good at following fix instructions and, also, I am not in the mood to let Best Buy remote into my PC. Please provide me with a fix for this.
Bob Miller

Best answer by bobruggles 20 June 2017, 18:48

View original

3 replies

Userlevel 7
Greetings @.
Please uninstall and reinstall Webroot to resolve this issue.
(Make sure to remember to write down your keycode before you uninstall by pressing "My Account" at the bottom right)
Once the uninstall has completed successfully, please reboot your Computer.
Now, re-download Webroot and activate it with your keycode.
Go ahead and restart your Computer one time to make sure the message is no longer appearing.

Please let us know if you have any questions or issues! :cathappy:
Userlevel 1
Badge +5
Thanks! I accidentally deviated from your procedure but it all worked anyway. Here is what I did. During the Uninstall I was asked to state the reason I was uninstalling. I said I was following your direction. The uninstall took place then I noticed that tere was a button to press to re-install. Without thinking I clicked it (duh). In a flash the download took place. I rebooted the pc.
As it woke up the OS asked for permission to allow Webroot to make changes to the PC and I said Yes. After the boot completed I noticed that Webroot was alive and well. I rebooted again to make sore the message box would not appear. It did not appear. So - the best part was that I did not even have to re-enter the Key! Very slick.
Thanks again!!!
Bob Miller
Userlevel 7
Hey, as long as it works that's all that matters! Thanks for letting us know what worked for you, Bob :manlol: