WSA blocks update of Adobe Reader

  • 11 April 2012
  • 8 replies

Userlevel 7
Yesterday Adobe have issued a regular quarterly update to its Reader application (10.1.3). I couldn't get successfully through the update process. The update was always aborted saying that some files cannot be accessed or something like this. I tried it repeatedly but always ended with cannot write to some files prompt. In the last attempt I tried to shut down WSA and ... the update process went successfully. So my conclusion is that some of the shields of WSA was blocking the update process.
Just to let you know in case anyone encounter the same troubles with Adobe Reader update.
P.S. I should add that all my settings (including heuristics) are default except Protected websites which are both (HTTP and HTTPS) set to maximum.

Best answer by Kit 11 April 2012, 22:25

View original

8 replies

Userlevel 7
Badge +56
Hi Pegas,
I had no issues on Win 7 x64 just to let you know!
Userlevel 7
Hi Pegas,
I also had no issues on Win XP (2 computers) and Win 7 (1 computer).
Userlevel 7
I get a feeling that either this was a transient issue, or was not actually WSA but a coincidental solution. Transient would be, for example, if you were one of the Super-Lucky Very First people doing the update and the "Popularity" heuristics in the agent caught the files and preemptively dealt with them. Coincidental would be if, for example, CCleaner was cleaning on shutdown or startup and deleting the temp files the installer wanted to do an early file replacement with, then when you shut down Webroot, you also didn't start up an app that held the files locked so it didn't need to do a replacement.
Userlevel 7
Hello Kit!
It might be really a coincidence. Anyway glad everything's fine.
Thanks & regards,
Userlevel 7
Important question is whether everything's working okay for you. If all is well, then we're good to go.

Your attention to the detail was good, and ensuring that Adobe Reader is up to date is even better. Don't forget, Microsoft Patches for the month were also released this week, so be sure to update Windows itself!
Userlevel 7
Hi Kit!
I have to disclose my secret  ;) ... I am a fanatic in having all my installed applications up-to-date regardless they are for security, fun or anything else.
BTW, unfortunatelly I have learnt today that Microsoft abandoned the full support of Vista system passing now to only basic support which will last till end of April 2017. So probably we can count with less amount of patches etc., they will be targeting only the basic issues. But that's another story ...
Have a great week. 
Can somebody please help me regarding Webroot blocking Adobe Reader?? I cannot open any PDF files anymore and I have tried uninstalling Adobe Reader but now when I try to re-install it,, I get the following message (with backward slashes) and cannot proceed.....
Error 1321. The Installer has insufficient privileges to modify the file C:Program Files (x86)CommonFiles/Adobe/Acrobat/ActiveX/AcroPDFImpl.dll.
I am ready to ask for a refund as Webroot is installed in both my home and office PCs and BOTH computers are now affected and PDFs are no longer opening.
Userlevel 7
Badge +62
Hello FrustratedUser2
Welcome to the Webroot Community,
I am not having any issues opening up PDF files with Adobe Reader. Would you go here to install Adobe Reader and please make sure you uncheck ANY add ons for they are PUAs