Right click scan option is missing

  • 15 April 2015
  • 5 replies

Userlevel 1
Badge +1
One of our computers has lost the ability to right-click on a file/folder and scan it. This option is no longer in the right-click menu options. It was there originally when the software was installed on the computer. It just vanished?!
The scan settings policy enables right-click scanning in Windows explorer. And opening up the endpoint software settings does show this option as ticked. 
This is only happening on 1 of our computers. All the others are fine. 
The Win7 PC has been rebooted plenty of times, but has not fixed it.
I have even tried uninstalled the software, and reinstalled, but this right-click scan option is still missing.
Has anyone else seen this? And if so, how did you over-come it?
It's not the end of the world, as we can still initiate a custom scan in the endpoint software itself. It's just annoying. 

Best answer by JohnnyS 15 April 2015, 17:20

View original

5 replies

Userlevel 7
Badge +56
Sounds like you have everything setup correctly - if that machine is in the same policy as the others that have the ability to right-click scan, then it should to.  Let me ping one of our support folks to see what else he suggests.
Userlevel 5
I have found a issue with re-installing on a machine with our WRData directory present which causes this issue. I have made development aware and they are investigating. There are ways to fix it in the meantime though.

Fist I have developed a program that will attempt to repair this. Please download and run the following:

If after running this it says its replaced it, try and see if the context menu options show (a reboot should NOT be required). If it says it has disabled the context menu run the program again to try to replace it. If this still fails then it is definitely the WRData directory getting in the way. You will need to do the following:

1. Uninstall Webroot
2. Reboot the machine
3. Navigate to %programdata% and check to see if WRData has been deleted, if its still there please delete it.
4. Re-install Webroot
Userlevel 1
Badge +1
I'm really impressed with webroot's support. That's 2 queries I've had this week been dealt with within 24 hours. Much appreciated.  :D
I'm afraid the WRShellFix.exe program failed to bring back the right-click Scan with webroot option. The program did complete sucessfully and said it had replaced the context menu, but there was no webroot option there.
I followed your instructions, and after uninstalling the application I manually deleted the WRData directory which was still listed in the C:ProgramData folder. Once webroot was installed again, I now have the right-click Scan with Webroot option back again. 
Hopefully, I'll never need to do this again, but now that I know it's the WRData directory getitng in the way, it should be an easy fix now.
Many thanks,
I have recently noticed some of our endpoints are missing the right click scan.  I tested this program on one of them and while it ran successfully, it did not restore the right click menu.  As some of the endpoints with the issue are servers, I am looking for and hoping for an alternate solution that doesn't involve rebooting.
Badge +1
This problem just popped up for one of our users today. I looked at the web portal and saw that the computer had somehow ended up in the "deactivated endpoints" list. I assumed that was the reason, so I moved it back to the "all endpoints" list, and after an hour the user rebooted his PC, and the right-click scan option is still not there.
My computer had the right-click scan option, so I downloaded the wrshellfix.exe posted above and ran it on my PC, and now MY right-click scan option is missing!

is there a more current solution to this problem? If I need to do an uninstall, reboot, manually edit the %programdata% I will, but I'd hope for a less intrusive solution.