System Cleaner

  • 12 June 2014
  • 5 replies

This is currently one of the functions in the policy settings of Webroot.  However, I have found out the hard way that several of the settings (IE cache, Chrome cache, and microsoft office recent document history) are not available to manage as part of the policy settings.  Turning off the central management of the system cleaner does not rectify the situation -- the settings are left in place.  The only way to change them that I've found is to set the machines in question to unmanaged policy, make the necessary changes, and switch it back to it's normal policy.  I've confirmed this is a bug with support, and they let me know it's went to development but no eta on a fix.  
Has anyone else run into this?  If so, what did you do to resolve the problem?  I spent some time combing the registry and looking for settings elsewhere to see if I could find where Webroot stores the settings for the policies, but I couldn't find what I was after.  I did see quite a few settings out there for other things though.  Support says the policies govern what Webroot shows in the window, but if it's set to unmanaged, it has to be pulling it from a local copy somehow.  
I'm just trying to avoid having to do this by hand on the large number of computers I will likely have to adjust.

Best answer by TWTGroup 10 July 2014, 03:32

View original

5 replies

Userlevel 7
Badge +56
Let me check with some folks here and get back to you.
Userlevel 7
Badge +56
So I've confirmed that dev knows about the issue, and there is a change request created for it.  No details on ETA unfortunately.  I haven't found any other workaround besides going to unmanaged, but I'll keep digging and see if there is anything that doesn't require you going to every workstation.
Userlevel 7
Badge +56
Ok I have confirmation that there isn't any other workaround, such as registry keys to alter.  Unfortunately the only workaround is what you've mentioned already.  I'll let you know if I hear any more about the ticket to get this fixed.
Userlevel 3
Badge +8
Just ran in to this exact same issue - and was advised the issue is once system cleaner runs it loads all the locally installed applications recent items lists into system cleaner itself. It does this as each system is different so Adobe, Office, etc get added to the list and turned on by default - even if you then turn off system cleaner it leaves these "variable" recent items lists checked. When system cleaner runs, even with all the settings disabled these "machine specific" recent lists get wiped.
Only solution is to manually open the interface on "each" individual machine and uncheck all the items under advanced >  system cleaner. This is what I was told today by support - with no mention of it being under scrutiny for development.
Why can't it just be one setting that either checks the items for cleaning or unchecks them all, not just specific common ones - from the management console.
This will burn up several hours of my time fixing as we have some very annoyed clients.
Oddly enough we just started with WR, and by default a new policy to not touch document history was used and tested. In our office on Win8 and Office 2013 the documents are not removed. However, deploying this to a client has resulted in documents disappearing mostly Win7 / Office 2010. So maybe there is something there. On my local desktop with the same policy Office Document history is checked for removal and I cannot uncheck it (makes sense) , even if I run system cleaner manually on the desktop when its done and 700mb are 'cleaned up' I still have my Recent list on Word 2013.
Has anyone tried just leaving it enabled but disabling it from running on any day? Mine was set for Mon/Thu and today (Fri) I recieved several complaints about it happening. I just took off Mon/Fri and left it enabled. Hoping it wont ever auto-run as a temporary fix instead of trying to go by hand onto a hundred desktops, and one might assume this is set per user even so even worse ..