WSA 2014 install behavior change

  • 11 October 2013
  • 2 replies

Userlevel 7
Badge +6
If you install WSA via a script with the EXE renamed to your keycode, the install is no longer silent. The scan window will appear.
The /silent switch doesn't seem to work, but I haven't looked at the documentation yet.

2 replies

Userlevel 4
Hi explanoit
What results did you get, what OS did you test on, and what installer version did you use?
I tested on XP SP3 and 7, /silent worked for me but installed with no keycode, which is expected as I didnt enter the key= parameter.
When I renamed with the keycode it installed.
The only prompts I got were for UAC and in XP's "do you really want to run an .exe"
I havent tested these on the consumer product in a while, have the results changed?
Userlevel 7
Badge +6
Here's the command I've tried, run in an elevated batch file run by a local admin domain user on Windows 7SP1 x64 fully patched with no previous Webroot installation.
start "" /b /wait "%Remote%WebrootWebrootAVWebrootAV_8.0.4.17<key>.exe" /silent
start "" /b /wait "%Remote%WebrootWebrootAVWebrootAV_8.0.4.17<key>.exe" /key="<key>" /silent
I'll try it with the EXE not named to the key, see if that works. The first command installed silently on the 2013 series WSA.