Can't install Webroot

  • 12 October 2017
  • 10 replies

Userlevel 1
We've received a new 2017 Macbook (no touchbar) with Sierra installed. For some reason we can't get Webroot installed on it. 
At first when we run the .dmg, it would open, activate and before it would run the automatic scan, it shuts down. No icon in the taskbar at the top is showing. Can't open the program itself. Only the service is running in the Activity panel. We can only remove the incomplete installation via Safe mode. 
Tried to drag and drop the app into the Application folder and start the app, but that also doesn't work. 
Enabled the Root user and tried to install it, but that gave us the same scenario as above. 
Latest version of Webroot has been downloaded. 

Best answer by fktrysix 13 October 2017, 09:47

View original

10 replies

Userlevel 5
Hmmm. I think this might be an issue for apple support ( free for 1 year) or possibly webroot support. Have you used webroot before?
I am running it webroot on a 2013 Macbook with Sierra.  BTW, IMO one shouldn't ever use root user to install anything on any computer except in emergencies. Mac tends to put stuff in lots of places and it is easy to miss something key.
What link did you use to download the installation program?
Userlevel 1
Yeah, we have Webroot running on 100+ devices (windows/mac). Few weeks ago a colleague installed Webroot also on a new model (with touchbar) and that was succesful.

When I drag and dropped the app into the Applications folder, it said something about not having permissions (even though I'm admin). So that's why I quickly tried root user.

I've downloaded Webroot via the my.webrootanywhere portal and via this link
Userlevel 5
Two machines, experienced user, the complaint is not enough permissions.
Possible that there is a difference involved with touchbar software permissions, but unlikey IMO. Apple would likely know this.
I would now attempt to find out the difference in wheel, groups, and admin on the two machines.  Perhaps the complaint is telling you the truth that you are not a member of the admin group. My Webroot software is installed with admin, but most things are wheel. I do not fully trust anything not wheel since that was one major change a few years back.
Sorry I can't offer more help.
Userlevel 7
Badge +62
Hello @,
Welcome to the Webroot Community Forum,
To add to @ good advice. May I suggest that you open a Support Ticket which is free of charge. Webroot Support will have you up and running in no time.
 Contact Us/Webroot
Or call:
Mon - Fri 7:00 AM to 7:00 PM (MST)
Tel: https://tel:+18666124268
Userlevel 1
Hi @

I opened a support ticket yesterday and they replied with this;

Policies are now in place for Mac devices. I am guessing the policy they are in is hiding the user interface. You can set them to an unmanaged mode and then use the following terminal command to get that change applied to the endpoints.
sudo /usr/local/bin/WSDaemon -poll

After running the sudo command, I could drag and drop the Webroot app in the Applications folder and the app itself would start. Also the icon was visible in the taskbar.

Issue is now resolved.
Userlevel 7
Badge +62
Hello @,
This is wonderful to know that Support has resolved this issue for you. I find this information very valuable and will help others. ;)
Thank you so much for letting us know! 
I hope your problem is solve , if not then please use these following step

Instructions to Install Webroot Antivirus:

Steps have been mentioned below for the new customers and it should be followed step by step:
Step 1: Users may click on the “Download Now” link available as Webroot for product version.

Step 2: After this make a double click on Webroot SecureAnywhere app and the installer will open.

Step 3: Now users need to drag and drop the Webroot SecureAnywhere icon into the Applications folder.
Step 4: The next step will be to open the Applications folder.

Step 5: After opening “Applications folder”, double-click the Webroot SecureAnywhere icon to begin activation.
Step 6: Enter key code in the first process of activation and click the “Activate” button. Maybe system prompt asks to allow SecureAnywhere to make changes to your system.

Step 7: At last enter Apple system password and click OK to confirm the activation.
If followed the above accurately and not able to install the antivirus or facing any issue. If you need to get help, you can contact Webroot Customer Support.
Support Number: 1-866-612-4227 M-F 7am?6pm MT
CD in place and cant install   Isnt there a key to push to install
How do I install my webroot secure/anywhere Item # 667208584635    
Description  667208584635 WISE DTC 2006
I just got it by snail mail
Userlevel 7
Badge +35
You could try running First Aid in Disk Utility, reboot, install and see if that works but it may not. I would suggest that you as our tech support team can take a closer look and work directly with you to get this up and running. Thanks!