HELP! WSA still shows up as installed after uninstalling on my Mac

  • 6 March 2020
  • 1 reply


I need help in fully uninstalling WSA from my desktop MAC. When I first uninstalled WSA, I trashed the app BEFORE shutting it down. This wasn’t my fault. When I first tried to uninstall, I was lead by the WSA help menu to a MAC page for instructions to uninstall all apps which is dragging to the trash. When I tried to install Trend Micro it would not install stating I “need to uninstall WSA first”.

I then reinstalled WSA and shut it down first before dragging to trash. I restarted the computer and again Trend Micro stated: “need to uninstall WSA before installing Trend Micro”

I then cleaned my computer and removed WSA app with Omni Remover app which is to fully remove all remnants of WSA app. I restarted my Mac. 

There is no sign of WSA on my computer but Trend Micro states “need to uninstall WSA before installing Trend Micro.” 

Can anyone help me with this? I need to get my computer protected with Trend Micro which I paid for already in Geek Squad from Best Buy.

thanks, Kash49

This topic has been closed for comments

1 reply

Userlevel 7
Badge +20

@kash49 ,

Sounds like there may be some registry files leftover that is leaving a trace of WSA on your computer. Please reach out to our support team so they can dig through your computer and find out where these registry files are.