Mac Install Problem

  • 6 September 2020
  • 5 replies

I have Webroot installed on two PCs and now want to add it to an old Mac running El Capitan OS.  I have coverage for three devices so should not be a problem and I have read here and elsewhere that you can install on Macs and PCs with the same key code.  After downloading the installer, I get to the second screen (after language choice) where I am to add my key code but the entry box will not accept any characters at all - believe me as I tried every key on the keyboard.  The display flashed in response to each keystroke but nothing is entered into the box.  Thoughts?


Best answer by Ssherjj 8 September 2020, 01:16

View original

5 replies

Userlevel 7
Badge +63

Hello @mcmizzle 


Yes that does sound odd so please Submit a Support Ticket and they will sort it out.


Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue, it should be 24 to 48 hours but could take a little longer because of COVID 19 and the labour day long weekend.



Thanks for the response but some clarification please TripleHelix.  Since entering the question I have continued my quest and have some reason to believe that Webroot won’t work on a Mac running El Capitan (only most recent OS and three most recent previous versions according to system requirements link I found).   The computer is over ten years old and I don’t believe I can upgrade to a newer OS.  I will enter a support ticket but am interested in any further information you might have. 

Userlevel 7

Hello @mcmizzle One of our members ran WSA on El Capitan because she had an old Mac. I ran it also when El Capitan came out and didn’t have any problems but as Apple released new versions of the Mac OS Webroot had some bugs to iron out with the older versions. I’ll ping @Ssherjj  for her input on this.

Userlevel 7
Badge +62

Hello @mcmizzle ,

Welcome to the Webroot Community,

Have you checked System Preferences\Security & Privacy? But make sure you change it back to Mac App Store and identified developers or check Mac App Store whichever you had as default.

Have you tried installing Webroot for a Mac like this below?

To install the Mac software:


  1. Click here to download the SecureAnywhere installer to your Mac.
  2. Make sure you have a copy of your 20 Character Alphanumeric Keycode! Example: SA69-AAAA-A783-DE78-XXXX
  3. Be sure you add your Keycode to your Online Console: Webroot SecureAnywhere Online Console
  4. To install Webroot from Best Buy Geek Squad click here
  5. Double-click wsamac.dmg to open the installer.
  6. Drag the Webroot SecureAnywhere icon into the Applications folder.
  7. In the first activation window, enter your keycode and click Activate.
  8. If prompted, confirm the installation by entering your Apple system password and click OK.
  9. Let Webroot complete the scan.

Now I have/had been running Webroot on my 2007 iMac since 2013. Webroot ran flawlessly until around about a year ago or so. I am not sure why Webroot will not take your keycode. So Webroot Support might be your only option.

@mcmizzle The last Webroot  version on my El Capitan was

Good Luck,



Userlevel 7
Badge +62

@mcmizzle ,

Please read this post as I think i missed informed you that El Capitan wasn't getting any definition updates. I'll have to check on that to be positive. Sorry about that. As far as we know the older Mac OSs are vulnerable to attacks but Webroot is still protecting your computer.. I sincerely apologize about that. Information below:

Although, Webroot will continue to provide protection against malware, you are still at the risk of the OS deficiencies that remain open with older versions of these OS. I would like to take this opportunity to urge everyone that is still using old OS versions to update to newer Mac OS versions as soon as possible to avoid attacks due to possible unpatched vulnerabilities.

We have work scheduled to address problems on the older OS versions soon after. I will notify as usual when we have the Beta ready for testing. 


I'm going to  found out if the Webroot Definitions are updated daily or not on my Mac El Capitan.