problems on mac

  • 9 December 2012
  • 20 replies

Webroot was working fine up until today. 
I logged on today to see "The file: '/Applications/Webroot/MainUIStrings.bin' could not be found. Please verify and reinstall."
I've tried to reinstall with no such luck, everytime I try and set it in Applications it says that I already have one in there. I've tried repeatedly to uninstall the one already in there and everytime it says it is in use. I've made sure everything is closed and the pop up will still pop up. I'm just trying to uninstall it completely to reinstall so it will work right. It will not even open anymore and there is no icon at the top. What can I do?

Thank you!

Best answer by fdonato21 17 December 2012, 15:45

View original

20 replies

I have this problem as well.
Userlevel 7
Could both of you please open support cases?  I discussed your issues with Support, and there is consensus that it would be best handled through that system.  Remote sessions would likely help in these cases, and Community is not equipped for that.  If there ends up being a common resolution to this kind of issue that can be posted as an answer, we'll follow up with it in this thread.  Until then, Mac uninstallation issues would be best fielded via the support system.  Thank you 🙂
Was this resolved?  I have the same issue..  I opened up a case and they gave me the uninstall instructions but they do not work.  I cant uninstall because I cant quit the program because it does not show up in the menu bar.  I tried to kill the webroot service with Activity monitor and it keeps popping back up.
Userlevel 7
I do not see any resolutions for either case that could be communicated here as workarounds. However, I know from a prior case that there is a way of dealing with this type of situation. The bad news is, it's a pretty lengthy process. However, the good news is, it's something support can do for you. All you need to do is let one of our agents onto your system to work through it for you. So the best thing to do is still putting in a support case to set up a remote session.
They left notes on the LogMeIn chat screen but it ...
They left notes on the LogMeIn chat screen but it froze and closed down when I tried to copy them the next morning after they fixed it. Sorry.
Webroot Support (Dec 13, 2012 0:20)RE:I tried that multiple times and it did not work. I...Hello, 

I am glad the issue is fixed, did they give you any notes on what they did or did they give you any contact information so you can ask them what they did? 

Webroot Support Team
Your Message (Dec 12, 2012 23:26)I tried that multiple times and it did not work. I...I tried that multiple times and it did not work. I was unable to uninstall it because i was unable to stop the process, even in Activity Monitor. Geeksquad (bestbuy) had to remotely resolve the issue and it took them about 5 hours (10pm-3am), so it was not that simple. But I do not know exactly how they fixed it.
Webroot Support (Dec 11, 2012 22:01)RE:MainUIStrings.binHello, 

Thank you for contacting Webroot. To resolve this issue we will want to reinstall the software. 

To uninstall and reinstall Webroot SecureAnywhere, follow the instructions below. 

** Part 1: Uninstall Webroot ** 

1. Shut down SecureAnywhere by clicking the Webroot icon (green W) in the menu bar and selecting Shut Down SecureAnywhere. 

2. If prompted, confirm that you want to shut down SecureAnywhere. 

3. Open the Finder by clicking the Finder icon in the dock. 

4. Open the Applications directory. 

5. Click and drag the Webroot SecureAnywhere program icon into the Trash in the dock. 

6. A confirming window appears. Click Uninstall. 

7. Webroot SecureAnywhere is now uninstalled. There is no need to restart your computer. 

** Part 2: Reinstall Webroot ** 

1. Click here to download the SecureAnywhere installer to your Mac. 

2. Double-click wsamac.dmg to open the installer. 

3. Drag the Webroot SecureAnywhere icon into the Applications folder. 

4. Open the Applications folder by double-clicking the folder icon. 

5. In the Applications folder, double-click the Webroot SecureAnywhere icon to begin activation. 

6. In the first activation window, enter your keycode and click Activate. 

Your keycode is: << ** I N S E R T K E Y C O D E H E R E **>> 

After you enter the keycode, a system prompt asks if you want to allow SecureAnywhere to make changes to your system. 

7. If prompted, confirm the installation by entering your Apple system password and click OK. 

8. The next screen describes SecureAnywhere's Safari extension. Click the Install Safari Extension button, and confirm any prompts that appear. 

9. In the Safari dialog, click Install. 

10. When the Activation Successful screen opens, click Scan Now. Please allow this scan to complete. It will only take a few minutes to run. 

11. In the Scan Complete window, click Close. The main window opens. 

You can verify at any time that SecureAnywhere is running by looking for the Webroot icon (green W) in your menu bar. 

Please let us know if you require further assistance. 

Thank you, 

The Webroot Support Team 
Your Message (Dec 11, 2012 2:09)MainUIStrings.binI get a popup error message that says: The file: '/Applications/Webroot/MainUIStrings.bin' could not be found. Please verify and reinstall. This continues to popup intermittently.
Userlevel 7
Hey macrod85,
It looks like you updated your support ticket stating that Best Buy and the Geek Squad were able to remotely resolve the issue for you. Please update your Support Ticket as the technician suggested if you experience any other issues.
Seems like the issue might be fixed.  I renamed the WSDaemon file under /usr/local/bin using sudo access via the termina.  I then opened up activity monitor and killed the system process WSDaemon.  I did not force kill it.. just normal seemed to work.  When I did that, the Webroot SecureAnywhere "My Processes" process died as well.  I then went into the "Show Contents" of the Webroot SecureAnyware app under the applications folder, and I noticed that the MainUIStrings.bin file was  no longer zero bytes.  It had the size of the MainUIStrings_EN.bin file and was updated as of when I killed the WSDaemon service.  I did have to rename the WSDaemon executable under /usr/local bin first, otherwise that too would just keep starting up.  We'll see how it goes.  During this process I did get prompted to re-activate and enter my serial number.  I just cancelled that out.  I rebooted an checked things out and they appear to be working.
Befor you try any of this.. you may want to check with support first.
This is kind of ridiculous that the WSDaemon issue is an obvious problem of Webroot (search the web and other message boards). A smart company would either fix the problem so it does not occur after an uninstall or post the steps to remove it. Opening another support ticket for yet another incident is unacceptable.
Userlevel 7
Hello MrBuzzBoxx, welcome to the Community.
The previous replies to this thread, dated 2012, indicate this issue appeared to be resolved.  Have you been in recent contact with Webroot Support regarding this yourself?  If not, you probably should file a Trouble Ticket at this time.  
Please note, a vast majority of the posts/links doing the search you request are from 1 or more years ago, and they appear to be marked as fixed, as is the case in this thread.
Sometimes things do reappear, often due to changes of the OS, that would be quite normal.
I would suggest you submit a Troubke Ticket as that is the nest route to take in getting this sort of issue fixed.
This is pathetic. We installed Webroot Secure Anywhere on three client macs, and had run out of licenses. This was causing a loop of Webroot not installing and popping up over all applications. No reason for why it wouldn't install which I can only assume is that the licenses were maxed. 
I couldn't close the program, delete the program, anything. I wrestled with the computers for over an hour until I searched and found this thread, force killed WSDaemon and Webroot several times until I had enough time to delete the icon without it popping back up.
Needless to say, Webroot will no longer be our Mac provider if they aren't fixing an issue that has been persisting for several years. I have no interest in helping them fix it either.
Userlevel 7
Hi gzrecoil
I can very much understand your frustration so let's see if our most Excellent Community Manager @ can find out some up to date information as to what is going on re.the issue.
Many thanks in advance for any info you can bring to the proceedings, Maestro...:D
Regards, Baldrick
Userlevel 7
Badge +56
Let me see what I can find out.
Userlevel 7
Hi Nic
As always many thanks for picking up this per usual :D
Regards, Baldrick
Userlevel 7
Badge +56
I checked and we don't have any other records of this issue.  Can you please contact support so they can troubleshoot and document this one?
Hey Webroot,
I purchased your product and downloaded it on two of my PC's with no issues. I applied it to a Mac laptop, and it totally crashed it. Took the laptop to Best Buy where both items had been purchased. Geek Squad went on about how it was the 'hard drive', which seems to be what they always say.
After being told it would cost over $100(laptop is less than a year old and still under warranty) to restore and preserve all the data, they agreed to fix it.
They fixed it and said it was your products fault and blamed the version of Apple on the Mac. Ironically, it was the version Best Buy originally put on it.
In turn, they refunded the money for the fix.
But here's the deal.
I only was allowed 2 downloads.
You want to refund me 1/3 of the original $50 I spent on your faulty product? I can assure you I will never use your product again.
Userlevel 7
Badge +56
Ouch, that sounds like a not fun experience.
What version of OS X were you on?  If the laptop is under a year old then it should be a supported version.
I can get you a replacement keycode for the Mac so that you'll be able to get the download and install it again.  And if you run into any issues with the installation, I can get our support to help you out.  Would that work?
Userlevel 7
Badge +62
Hello KCWildman,
Welcome to the Community Forum,
I had the same issue last year with my Mac and Best Buy replaced my HD...I had WSA on this 2007 Mac and so it was believable for them to say it was my HD. I've since upgraded in January of last year to WSAC. My Mac is running flawlessly with Webroot installed. But I returned the BB webroot version and purchased from Webroot and the Support Team is and was there for me when BB gave up.
Just my 02. worth.
Kind Regards,
"The file: '/Applications/Webroot/MainUIStrings.bin' could not be found. Please verify and reinstall." conflict is very disturbing.
Looks like the problem is still on going...what kind of a company can't solve this kind of a stupid issue !
When I read the support pages, it is first mentioned in 2012 !
As I understand the solution is using terminal and sudo...but I dont have any idea how to do it. I think there are lots of dummy mac users like me...
Can anyone explain how to get rid of from inoperative webroot from my computer ? Forever....
Userlevel 7
Hello boculdek, Welcome to the Webroot Community Forum. :D
Sorry to see that you are having problems with WSA. Please submit a Support Ticket or Contact Support by Phone. Webroot will probably want to gather your logs to sort the problem. I will also ping our Community Manager, ? so he is aware of this issue again.
Thank you,
Userlevel 7
Badge +56
If you contact support they'll be able to fix the issue and/or get it resolved for you. Sorry for the frustration!