Webroot logo only on iMac

  • 5 September 2020
  • 9 replies

Userlevel 1
  • Fresh Face
  • 3 replies

Webroot has not worked on my iMac since November of 2019.  When I click on the logo nothing happens.  It’s as though the logo is loaded but the program is not.  I’ve tried downloading the program again, but nothing changes.



Best answer by TripleHelix 6 September 2020, 17:59

View original

9 replies

Userlevel 7
Badge +63

Hello @BAH 


Can you tell us which Mac OS you are running?


macOS 10.12 (Sierra®)

macOS 10.13 (High Sierra®)

macOS 10.14 (Mojave®)

macOS 10.15 (Catalina®)

For more information click here.



Userlevel 1

Yes.  Mac OS 10.15

Userlevel 7
Badge +63

Hi @BAH 


Try this and don’t be concerned about Big Sur:


Also here is the Direct download for v9.1.3.103 in case you need it and it’s only for Catalina and above only:


Let us know how it’s goes and here’s more info:



Userlevel 1

Thanks TripleHelix, but this doesn’t work.  A 1.8mb file appears in downloads.  I click on it and the Webroot appears on my desktop.  I click on it and my iMac asks if I want to open it.  I click on “open”, and nothing happens.  It’s as if the logo for the app. loaded, but there are no files to install.



Userlevel 7
Badge +63

Hello @BAH 


This link will download the correct version v9.1.3.103 :


And as you can see it’s larger!



Userlevel 1

That did it!  Thanks so much.



Userlevel 7
Badge +63

Great to hear!


Have a great long weekend!

Hello- How long is the new version install supposed to take? I used the dmg in the App Support lib as the email instructions advised and waited ten mins on the “Authorizing Installation” screen with the progress bar at 10% and then canceled. I downloaded the dmg from link in thread above and I’m at the same place- 10% after 15 mins. The progress bar is static. Seems hung to me. Please advise. I’m on OS 10.15.4.

Userlevel 7


See this post: