Android 4.2 - Multiple Users

  • 14 November 2012
  • 7 replies

Hi Guys,
On upgrading to Android 4.2 and installing a second user.
I had to reinstall webroot on the new account - Fairly straight forward
The icon at the top of the screen on the second account is not green however, it is grey stating that "password protection is disabled" - There does not appear an option to rectify this.

7 replies

Userlevel 7
It sounds like you didn't activate device administrator for Webroot when you reinstalled.  Although Webroot will allow you to install it without activating device administrator, you need device administrator enabled in order for Webroot to prompt you for a password before the app is uninstalled.
If you open the Webroot app on your device, you'll see a Warning prompt and a "Fix This Now" button.  Tap "Fix This Now," and it will take you to a screen that explains the problem.  You can either "Ignore" (which we don't recommend) or choose to "Fix This Now" again on that screen.  It will ask you for your password.  Enter your password, and you'll see a screen that explains Lost Device Protection.  Tap Next.  Then tap Activate, and you're all set.
Device administrators was enabled

No "Fix this now button" - It just says that you are protected in the app

The notification centre still says you may be at risk

Could this be an issue with webroot being installed twice in 4.2? - 4.2 creates a secondary level user without access to any of the data from the "owner" so I installed the app on the second account. Would webroot be able to secure the secondary account despite being in a seperate sand box away from the "owners" account (with webroot already installed)


Userlevel 7
Ah, I see what you mean by "second user" now. I thought you meant you made a second user in your Webroot online console.

You raise an interesting question, and it's the first time it's been asked. I'll poke one of our devs to take a look at look at this.

In the meantime, can you check on the device administrator setting? Webroot, if told to "ignore," will stop bothering you about this setting and turn green, so it wouldn't show up where I mentioned before. Instead, (and I'm using a 2.3 device for this path / my apologies if your version of Android displays this just a bit differently) go into Settings on your Android, go to Location & Security Settings, and choose Select Device Administrators. Is a Webroot app checked in that list? You'll want to be checking on this from within the secondary account.
Userlevel 7
We tried reproducing the issue on a Nexus tablet running 4.2, and it didn't reproduce as described. What we found was that the device admin setting is unique to each profile. It can be on in one and off in another. You will be prompted to turn it on in each profile independently.

So I suspect you might be seeing the message you're referencing in one account, but you're checking on device admin settings in the other account. Please make sure device admin is on in the account in which you're seeing the issue occur.

A screenshot of the problem would be helpful in this case if it turns out device admin is already on in the account in which you see the issue occur.
Ive checked both accounts both of the device admins are active (ive turned on and off the admin on the secondary user)
Below are images from the secondary user account



Those images arent exactly great
The first one says "you may be at risk - pwrd protection disabled"
The second one says "You are protected no issues detected application is configured for optimal security"
The third one shows that the device admin is active


Userlevel 7
My apologies it's taking so long to get a solid answer to your question in the topic. The issue reproduces on a 4.2 tablet in-house and needs to be looked at by development. That process has been slower going than usual lately in the mobile world with a couple of big things that came up. This issue appears to be cosmetic and does not involve reduced functionality, so functional concerns had to be considered first. Once we have more news I'll update this thread again.