Android telling me antivirus is not installed.

  • 25 July 2018
  • 5 replies

Lately whenever I run device maintenance my Samsung tablet / Android keeps telling me that antivirus is not installed...  I click on fix and it keeps telling me that I need to enable McAfee. I have Webroot running and that's what I prefer to use.  How do I stop device maintenance from popping this up. It should also be known that my tablet is running a bit slowly and takes a few seconds to respond's annoying.

5 replies

Userlevel 7
Badge +54
Welcome to the Community @ and sorry for the delay.
It sounds tto me like McAfee needs to be uninstalled but I do not use an Android phone so I will ping @ for you, she may be able to help you.
Userlevel 7
Badge +62
Hello @,
Yes welcome to the Webroot Community Forum,
I have a Samsung Galaxy Note 8. So I'm guessing your tablet might be similiar?
  1. Go to Settings.
  2. Tap Apps or Applications , depending on your device.
  3. Tap Installed Applications/Manage Applications.
  4. Select McAfee Mobile Security.
  5. Tap Options, and then select Uninstall or Remove.
Try that and see if Device Maintenance behaves and click "Optimize Now" if you have this settings.
 Also check the Device Security while you are there.
Hope this helps?
Thank you @ for the ping!:D
On this tablet, it is settings, then apps.   McAfee is not installed.  I even tried showing system apps.  The message prompts me to install McAfee.   I have included screenshots.
I am using android 7.0  From December 1, 2017.
What else is annoying.  I repetatively get messages that webroot needs to be fixed... Waring, you may be at risk... and FIX THIS NOW... and the Agreement keeps changing like once a week.   It also prompts me to install another app that wont work on my tablet.

Userlevel 7
Badge +62
Hello Wraiththe,
My Samsung Note 8 received an update of June 2018. Have you gone to Settings/System updates and checked for any system updates?
Also can you look in Settings/Other Security Settings and check Device Administrator and see who has rights to Device Admin Apps? See if McAfee is listed there. If it is deselect it. You should see Webroot listed as active.
My phone carrier is Verizon and I am not sure if that has anything to do with the difference of your Device Maintenance because I only have Battery/Storage/ Performance & Memory listed.

I think if you can sort out this McAfee issue Webroot would function correctly. Otherwise you can uninstall/reinstall Webroot and see if that resolves the Webroot issue that you are having.
Hope I helped out some?
I have an S8 and it tells me the same thing just ignore it based of what's been said here you need to install it separately to keep Samsung device maintence happy it's likely Samsung has a deal McAfee to sell the product after all its only a recommendation to enhance security but using Webroot is a much better alternative even if device maintenance complains its complains to me all the time about Cpu usage for webroo