Definition Update Failed

Webroot failed to update its threat definition. This likely means your device doesn't currently have internet access. You can continue your scan with the current definition set or cancel. Error: OutOfMemoryError processing def update. Continue or Cancel.

Also, DEFINITION UPDATE FAILED. Network error attempting to access the Webroot servers. Please ensure your device is connected to the Internet.

Also, Webroot Secure Anywhere Mobile Premier (process com.webroot.securing full) has stopped unexpectedly. Please try again.


Is somebody know what to do??? The HELP recommended to post on FORUM to get E-mail from MODERATOR to send collected system data from phone for tech support. Or may be it would be solved by itself??? For example, via updates?? But how come, the updates fail to be installed?

Best answer by MikeR 5 August 2013, 18:34

View original

169 replies

Userlevel 7
Hey USaferWthDelusn,
I am interested in collecting logs from your mobile device and I will be sending you a private message with the instructions. Have you tried switching your connection type from 3G/4G to wifi or vice versa when updating the definitions?
Even if this sovles the definition issues, I think it would be helpful for me to take a look at the logs due to the OutOfMemoryError and the processes that are stopping unexpectedly.
I'm interesting if will be any different answers for the problem - or will not? if YES, how soon it will be?
Userlevel 7
The logs you had sent did not reflect the errors reported. They were probably gathered too far after the issue occured. When collecting logs, it is important to gather them immediately after recreating the issue and after you receive the errors. I will be sending you another set of instructions on how to reset the definitions via Private Message.
If that does not solve the issue, you will need to send another set of logs immediately after recreating the issue.
Collecting Mobile Logs:
1.  First, replicate the issue you have been experiencing.  Be sure to do this immediately prior to carrying out the rest of these steps.
2.  Open the Webroot SecureAnywhere Mobile application.
3.  From the main screen of the Webroot app, tap the Android Menu button.
4.  Tap General Settings.
5.  Tap Support Options.
6.  Tap Collect and mail logs.
7.  Mail these logs to the email address that I send you in a Private Message
I'm also having this issue "definition update failed" where do I send the logs to?
Userlevel 7
Hi Jimbo,
Mike's out of the office today, so please send the logs to me. I'm going to provide you with the email address to send them to via private message.
Also, the original question asked  by Mike about whether this happens over both cell data and wifi connections is still relevant.  Please try on the other if you've only tried on one.  It should work on both, but if not, we'd still like to know.
How I resolved my error:
I was also getting the same message.  I was using the link provided in the notification on my phone.  I then (after a couple of weeks) decided to try using the link to the app on my phone and going in that way to download the definitions, I received a much better error that the was not enough space (or memory, I don't remember that exact error), I had about 30M free.  (whole nother story about all the pre-loaded crap that I can't move to the card nor delete and I don't want to root my phone to clean that out, I don't have a lot of internal memory left).  Anyway, I deleted a lot of what I could (deleted the FB app, cleared the cache on the Internet app (don't do data you'll lose bookmarks, etc), those were BIG and did others, if you have games move them to your card) freed up about 20M more, bounced my phone and then was able to get the definition updates.
Userlevel 7
Very interesting!
I was working with Jimbo via private message after receiving the logs, and I meant to check back in here with the results once we knew what the solution was.  However, after I sent a list of suggestions, I never heard back to know which one ultimately helped him out.
Here were my suggestions:
1. It could be a corrupt definitions file.
Uninstalling and reinstalling the app would clear the definitions.  So we can try that.
2. It could be an issue with the network connection.
Does this happen over ONLY your data plan or ONLY wifi to a router?  Please try the other connectivity method and let us know if it works or not.  It should work over both, so if it's only working over one and not the other, we need to know so we can look into fixing that for you.
3. It could literally be an issue in which the phone is out of memory.  You could try killing some unneeded services.  Anything that you see running at the top left side of the phone that is always on is using memory, so try closing some of that stuff and updating the definitions again.
Number three in my list of suggestions comports well with your own solution.  I don't think it's the storage space you freed up that made the difference (our definitions files are tiny / less than 5K), but rather that in uninstalling a bunch of stuff that was probably running in the background, it freed up resources so the update process itself could take place.
Thanks for posting the solution that worked for you!  🙂
HI there, thanks for the info, it was a lack of phone memory. Cheers Jim
From the last update of the program, I'm not able to update the definitions of WSA Mobile.
When I try to update, the program tell me that I don't have internet acces, which is not true, because I have both WiFi and 3G.
After that I get an error: "OutOfMemoryError processing def update". I check the memory of my phone (HTC Wildfire S) and I have 25Mb free, so I think is not a problem of the phone.
Is there a problem of last update of the program?
Userlevel 7
Hi Marius,
Long time, no see!  Welcome back!
The same question was recently asked here, and three suggestions were provided.  It looks like one of them worked for the people who have run into this problem so far.  I bet one of those suggestions will help you.  Please take a look.  🙂
Userlevel 7
Hey marius,
I have merged your post with the Definition Update Failed thread. As Jim mentioned, your question about definition update failures was answered here for other users and it is a great place for you to look for your solution as well!
Sorry for not seing the other post.
I try your suggestions but nothing happened.
First I reinstall the app, but continue to tell me that I'm not connected at internet. I try to update in both cases: with my data plan and with my home WiFi. In the same time the internet browsers works fine, so it's not a problem of connection.
Second: I uninstall few apps and after that I clean and optimize the memory and restart the phone. Now I have 33Mb free memori but the answer is:  "OutOfMemoryError processing def update".
I don't think is a memory problem because before the last week update of the app I have only 12Mb memory free and no problems with the definitions updating.
Any suggestions?
Userlevel 7
Hey marius,
We will be able to investigate further after collecting logs. You will need to download a specific app (free) for this. Please follow the instructions below for gathering the logs and then I will send you a Private Message of where to send them.
1.  Open the Google Play store and search for an app called "CatLog". 
2.  Locate and download the free app CatLog - Logcat reader.
3.  After downloading the CatLog app, open it.
4.  Tap the Android Menu button, then tap Record.  The app will begin recording logs from your device.  
5.  Tap the Home button (do not use Back) to return to the main screen.  This ensures that the recording will continue.  
6.  Recreate the issue you have reported. 
** Note: This step is very important, as CatLog will record logs from the device as the issue occurs.  Without this step, the necessary data for troubleshooting your issue will not be logged.
7.  After recreating the issue, open the CatLog app again.
8.  Tap the Android Menu button, then tap Stop Recording.  A "Log Saved" notification appears.
9.  Tap the Android menu button again, then tap Send. 
10. Choose As Attachment and select Email or Gmail.
11. Email the logs to the address I have send you in a Private Message
Please let me know when you have done this!
It is the phone memory problem, but it is the remote code which build the problems - I cleared up memory, I reinstalled the Webroot, I flashed the the definitions, and then after their automatic update the net day it showed the same "OutOFMemory/full" error. One time it cannot access the Internet for Webroot servers and another time it worked nice. Something in the system program developings got wrong working.
 Today my phone began make the clock instead of me as like as the billion-dollars NASA tractor to which the radio-waves may rich only after the 15 minutes. The program developer made the screw. It is the Internet outlaw. Some apps may allowed to reach your phone. if you reset the software for the manufacturers prompt, game may be lost, for example, because its encryption may be reset. Then the game server network administrator may ask you to pay them for fixings.
A month ago I erased  everything frommy phone but it have the low memory. And the webroot server refused to run updates. Probably, because it needed the confidentiality, but my mother in foreign counrty now - in Russia, then the Internet develppings engineer want have no problems, but the CIA people control the Network. Then, the Webroot may just disconnected the software form server;
  The  chat moderator Mike recommended me to reset the webroot in the help menu, where to slide the letter "S" anfd when it opens the advanced menu just clear up memory. Look at. it does not help.
Hey MikeR,

I send the log.

Userlevel 7
Hi marius,
Thanks for sending those! (Mike is out of the office until Sunday). We're going to take a look at the logs and update you with our findings. In the meantime, could you also provide the make and model of your mobile device along with the version of Android you are running? These will help us better pinpoint the issue and will be useful when analyzing your logs!
Hi Yegor'

I have an HTC WidfireS A510e running Android 2.3.5

Userlevel 7
Great! Thanks marius!
We'll continue with the log analysis and one of us will report back to you with the findings as soon as we know more.
If you did all mentioned ways and the problem not solved yet,
Because when you install a new application, wallpaper, theme etc.or your antivirus finds any infection,it needs restart to perform some changes is necessary or complete the task.
I had the same problem and rebooting solved it.Why don t you try this?!
Userlevel 3
I just wanted to drop in and let you all know we are looking at ways to improve memory management in the future.  In the next release which is currently slated to come out in a week or so we will be releasing some improvements in memory usage around definition updates.  
The reason this was working and is now causing issues is that our definition files grow over time as we find more viruses out there.  This has outpaced the memory in phones over time so we require a larger chunk of memory now than we have in the past.  Some of you with older phones or that have a lot of applications running that take up memory will begin to see this issue.
As others suggested in here general healthy cleanups of your phone is your best bet to not run into this issue in the meantime.  Things like uninstalling apps that you don't use anymore that may be running background services.  Periodically rebooting your phone will help clean up other apps that may be consuming memory that.  Remember that just because you don't see it doesn't mean it isn't running.  Use the App Inspector that is included in our pay products or the built in Android Apps list and look under "Running" to determine what is actively using memory that you may not want.  
I could go into a long rant about Java, Linux and memory utilization but I think that is best left for another day.  For now, know we are hard at work on better solutions in future releases and we will keep you posted as those become available or if there are any other work arounds.
Thank you,
Helo Roloc,
I've tried everything but still not work.
Even I give a "format factory" to the phone. After I install Webroot Mobile as first and only program, I receive the same message as before: "Out of memory..."
In that case I think that the program became useless
Userlevel 3
As I mentioned we are hard at work on a fix for older phones or ones with very little memory.  Remember just because you did a wipe does not mean that no other programs are running, the Android opperating system takes up a good chunk of memory itself as well as any other applications that get shipped with a phone which depending on the carrior you use could be substantial. 
As an example my sister has a phone much like yours that out of the box has only 1% memory free.  
In other words, I understand your frustration and we are working on it.  When we get a solution that works for everyone from slow phones to fast we will let you know!
My Adroid phone tells me I need to update Webroot, but then tells me there is no internet connection, but there is, as I can access websites and emails. I have to re-boot the phone several times to get automatic definition updates.
Userlevel 3
I to am getting this
Userlevel 7
Please refer to this post on Definition Updates and an update by one of our developers on why there are currently definition issues.
Definition Update Failed
 Combined post with the Definition Update Failed topic