Definition Update Failed

Show first post

169 replies

Userlevel 7
I sincerely apologize for this DavidP.
I really do appreciate your feedback and letting us know about the system requirements messaging.
Userlevel 7
Webroot remains my security of choice for my computer, and once I upgrade my phone the first thing I will be doing is to install the Andriod App... 
My comments were meant mainly as constructive, I remain a faithful user 🙂
I've managed to re-install webroot secure anywhere. I get a warning that "current scan out of date." On trying scan I get the following:
Definitions Update Failed
Webfailed to update its threat definitions. This likely means your device doesn’t currently have internet access…..
Error: OutOfMemoryError processing def update.
My phone memory is 185MB (avail 44.5MB), so whats the next step?
Userlevel 7
Please open Webroot, tap the menu button, and go to About. What is the version number listed there?

Also, how is your device connected to the internet (data or wifi)? What is the version of the Android OS in use on your device?

As Roloc mentioned earlier, the phone memory you're speaking of is "memory" in the sense of storage space - not memory in the sense of what would be known as RAM on a PC. It's entirely possible it actually is running out of RAM-type memory. I recall that on your device, we had previously temporarily resolved the issue by killing unneeded services. That's most likely what's still happening in your particular case.
Good though Secure anywhere was when it worked, I'm afraid I gave up waiting and have switched to another product. Sorry but the other product works with no hassle
Userlevel 7
The OutOf MemoryError is sadly back :(
A week or so I have not had this problem after update to However I have noticed today the orange exclamation mark and have been prompted to fix it. The warning originated from the Out of date scan. So I run a scan which ended up prematurely giving the well known error. I opted then to continue a scan with the current definition set. Afterwards I tried to update manually and always received the error popup.
Having WSA Complete on HTC Desire S with android 2.3.5.
Userlevel 3
I am looking into it Pegas.  There may be some things we can do now without pushing a new update that can lower the chunks of memory we are using. 
Overall though the update didn't lower our memory "footprint" it just changed how we loaded it so we didn't get as big of chunks at a time.  We still have more work to do to lower it as a whole but keep our performance high as well as our detections high.
The balancing act continues unfortunatly. 
I'll get back to you. 
My Secure Anywhere renewal expires in 16 days. I'd rather keep webroot but I'm not going to renew if the product doesnt work.
Provided RAM levels, other: 53mb in 4, avail 49+90mb in 1 3 days ago but no feedback - still getting:
- Definitions Update Failed
Webfailed to update its threat definitions. This likely means your device doesn’t currently have internet access…..
Error: OutOfMemoryError processing def update.
Anything left for me/webroot to do?
Userlevel 7
Roloc is working on tweaking the definition chunks. I understand some progress has been made on further refining the amount of memory used during the definitions update. It shouldn't take long for those changes to go into effect. I'll let you know as soon as I find out for sure when the next definition set is available that includes that change.
Userlevel 3
The new definitions have been released which should have smaller chunks.  Let us know if that fixed it for all or some of you.
Userlevel 7
Tried to force a new update manually but to no avail. Stuck with 377 and with the OOM error.
Userlevel 7
@ wrote:
Tried to force a new update manually but to no avail. Stuck with 377 and with the OOM error.
All of a sudden I've got definition set #380. Also checking updates manually gives no OOM error. Though it's strange that 13 hours before the problem was still there. Anyhow I am glad it works now. However I will keep eyes on this issue and if it breaks again I will revert here to report.
I have DROID SPH-M910 Samsung Interceipt provided by Virgin Mobile. It is very old fashioned for droids - it is of two years old. I bought it and I did not saw it had the 160 Megs of memory instead of 256 Meg. I called for Samsung but they knew nothing. Then I continue to use my phone. It was not too bad till I got Zenonia 2 and played for first year, then I had a little couple months in Moscow. When I turned back my phone got updates and it screwed it. When I played with Zenonia 4 game it may rise the memory use till 120 -139 Megs, but after I quit the game it got down and if i clean memory in my "Task Manager" it would allow me have 87 Megs after RAM Level 1 and Level 2 "Clear memory" button pushed.  I couldn't fix my phone for a few months. I wrote tech support here or in another chats or forums. Nobody could help me. After the hurricane began this week I used my phone to make pictures, but on Tuesday-Wednesday night I got disconnected service and very slow phone. I used to fix it after I got home on Thirsday. I pulled out my memory SD card, and I did to reset phone till manufacturer defolt pushed three buttons at the same time. That let me get into boot menu and erase the partitiona and then - reset till manufacturer defoult.
  I saw that the phone had the same root developings but after I had a few hours tech support conversation with my Virgin Mobile provider to Activate Service. After they allow me to get connected, I began to reinstall all updates I had - I mean the apps - the connection to Apps store, the Antivirus software, the barcode scanner and the authenticator. Eventually I found that my phone began work better, but after I got the new version of the GooglePlay I got impoossibility to see my apps in my phone. Then I came into Settings and open the Apps Management - I cleared the memory of that app. Then I found that I can use to update some of my apps. I did not install any after that, but the next day I found the little bit more updates came into my phone. It installed the "Downloads", "My Account", and something else automatically. I found that the phone began use more memory - sometimes its goes to 120 Megs RAM memory but if I use to clear it on Level 1 and level 2 it low to 120 or to 100 Megs. I made a look into Webroot IPs and I found the ports and IPs connected to phone.Mostly it is the system self encryption process which takes too much memory, and that process is the ROOT. Somebody provide too much security for the phone which cannot carry too much so it slow the phone speed and performance. Before Webroot I had TrendMicro. The old Trend did not have that feature to be able see the IPs and Processes. Then somebody provide with too much scannings to make people through the WEBROOT, which with WHOIS allow you to find who control your phone or to find the open ports. As a FACT, during the Sandy Hurricane I checked how my computer was connected to the Internet on the Hotel Internet access point. I found that it goes to router in Texas, then in California, then to Massachusets, and then it got New York City. I just did NETSTAT check for all and checked the IP hopes on the way to reach server for New York Adobe. So...
  The bad news are those that the program developers should stop develop too much encryption and kind of viruses of that encryption. The Encryption-decryption alows down the phone but as soon as somebody reach your root, the reason for the encryption will be lost. 
 And you know how does it work now???? The scan begins, then it show the message that it was cancelled, then it got fixed then it shows another tim the alert that You are not safe, then it fixed, thennnnn......... That isnot bad made software, that is the ROOT.
 That is the same MIKE, or JIMM, or JIMBO just play with their java, I think....
still no updates on google play...?
Userlevel 3
Jumbo, it wasn't an update t our application just our definitions. So if google play is saying you are at the latest then do a manual definition refresh and see if that fixes it.
Roloc, How do I do do a manual definition refresh?
Userlevel 3
Its under

Security -> antivirus -> schedule -> force definition updates now
just forced update and got:
- Definitions Update Failed
Both on wifi and phone data.
RAM: avail 35mb+65mb in 13
Am I kidding myself in hoping this will get fixed? It's starting to feel that way...
Userlevel 7
In a follow-up I am pleased to confirm that WSA has auto updated to definition set 381 today. So it looks the OOM error has gone for good.
NOT working for me...nothings changed, given I paid for this someone might actually get back to me to tell me if I'm wasting my time. I'm getting very annoyed with webroot!!
Userlevel 7
Well, jimbo is right, the OOM error reoccurred today :(
It is really strange as yesterday everything worked. However today when I manually checked for updates the OOM error came back.
It needs to be tweaked and polished definitely because now it is completely unreliable!
Hey, Webroot techies come on ;)
Userlevel 7
The story continues ...
Today I have noticed WSA needs attention (the orange exclamation). The problem was in outdated AV definition. So I opted to Fix the issue which turned in the following error.
"Network error attempting to access the Webroot servers. Please ensure your device is connected to the Internet."
You can be for 100% sure I am always connected! The error is a fake.
If I force the update manually I am getting the OOM error and icing on the cake is information that Threat Definitions have never been updated. It's a joke, isn't it?
Well, you are really trying my patience ...
Userlevel 7
We're sorry to hear that this issue appears to still be affecting some users, and mobile development is looking into what else can be done to reduce Webroot's memory usage on Androids.  The definitions re-chunking appears to have solved about 80% to 90% of the bug reports we were seeing communicated back to us from the Webroot apps themselves.  However, there will still be some cases in which devices run out of memory.
Roloc and the rest of the mobile team are working very hard to continue trying to find other ways to lower the size of the definitions footprint.  However, at this time, the total size of the definitions in terms of memory usage is about 5MB (which is actually very low already).
While the mobile team is still working hard to try to fix this issue for as many more people as possible, there will always be cases in which older phones with low memory and a lot of running services start running out of available memory.
This is similar to how you can't install the latest games on a 486 PC with 100MB of RAM.  You might have trouble installing a new game on a new computer as well, if, for instance, you're running 20 other programs at the same time.  As technology grows and improves, older platforms become dated, and as with any computer technology, you have to be mindful that memory is a limited resource.

On both Jimbo's and Pegas's devices, we see that this problem is not a constant.  Jimbo's was previously resolvable before by killing some unneeded services that were running in the background.  Now the issue is back, which would indicate to me more memory is in use again, meaning more apps that are always on are running.  On Pegas's, the problem does not sound consistent, which would again indicate differing amounts of resources free at different times.
I want to stress that there is continued work taking place to try to reduce our memory footprint even more, but this is not an issue that will ultimately ever be solvable for every last mobile device user due to the same reasons people with PC's will run into RAM issues when running out of RAM on a PC.  And whereas on a PC, you can fail-over into virtual memory (which is incredibly slow but at least works), when you run out of regular memory, you don't have virtual memory on an Android device.  Hopefully, we can break down the memory usage a bit more, but it may take some time.
Userlevel 7
Thx Jim for the explanation. While I highly rate the technical level and depth of your post I cannot help myself but it sounds like an advocacy of Webroot's inability to solve this problem properly. I had tested many AV solutions for Android and NEVER had such trouble. Moreover HTC Desire S easily fulfills the system requirements for WSA, please see below. There is no mention about RAM limitations.

If WSA is having RAM limitations Webroot should honestly declare this within the system requirements. Potentional users shouldn't be misled.
OK it's up to Webroot, now how I overcame the OOM error. I terminated WSA in Applications Manager and restarted WSA. After that I initiated the overdue scan during which WSA downloaded the latest definition set and finished it successfully. Problem solved. Having green protected status now.
So it leads me to think that WSA is a one of the biggest RAM eater. I am using a specialized tool to free up RAM but it turned out to be of less help until I terminated and restarted WSA.
Jim M I hear what you are saying however I've got avail: 72mb + 85mb...?Surely thats more than enough.
I've deleted all updates, stop google maps plus any other apps I'm confident aren't critical. Nothing but Java and Touch Input is running (plus webroot) . One thing is certain, Webroot worked on my phone for 9-10 months with many more number of apps running. But now it doesnt work. So whats changed? The phone is the same, fewer apps are being used.
Could I have a virus?
After 2 months its now 6 days before my subscription has to be renewed, or not....
- whats going to happen?