Free Webroot Error

  • 25 July 2012
  • 5 replies

I have an HTC Legend phone, and I tried to run a Virus Scan. The following message occurs:
Webroot failed to update its threat definitions. This likely means your device doesn't currently have internet access. You can continue your scan with the current definition set or cancel.
OutOfMemoryError processing def update.
When I try to force definition updates the same error occurs.
Can you help me. I don't want to continue run scans with old definitions, it won't be long before I'm not protected.

Best answer by JimM 25 July 2012, 23:02

View original

5 replies

Userlevel 7
OutOfMemory errors typically have to do with how Java is cleaning up after itself.  It might be as simple as just restarting your device to get around this issue.  If that doesn't help, I'd like to get a log of what's going on in the Webroot app when this occurs.  Please reply back letting us know if the restart helps or not.  If it doesn't, I'll send along instructions for getting the log file.
I tried the restart and am still having the same issue.
Userlevel 7
How is the device connected to the internet? Wi-fi or cellular data? I'd switch from the one you're on to the other one to see if that makes a difference. I'm private messaging you how to collect the logs as well.
Cell data, I don't have access to a WiFi network yet.
Userlevel 7
This was tentatively resolved by uninstalling and reinstalling Webroot. If the issue crops up again, I've suggested killing some non-critical services on the Android to free up some memory.

If the issue comes back, please let me know.