Incorrect Email or Password

  • 9 May 2012
  • 7 replies

Userlevel 1
I've logged in before and in fact have it set up on another phone, but when I try to log in to my new galaxy nexus with the correct email, password, and keycode its giving me an error saying "Login failed. The email or password you entered is incorrect." I have a rooted device and when I restore the app from my old device it's logged in and everything in the app is working, except the site doesn't show my current device. So I uninstalled it and am trying to install it and login, when it's giving me this error. Any help would be greatly appreciated. 

Best answer by Kit 9 May 2012, 20:34

View original

7 replies

Userlevel 7
Hey hslsurfer,
Welcome to the Community. I have some bad news here :(
Unfortunately, we cannot support a rooted device and I recommend contacting your service provider or phone manufacturer to perform a factory reset. Our software cannot always work properly in a rooted environment and a factory reset, along with a fresh installation of the SecureAnywhere Complete app would most likely resolve this problem. I apologize for the trouble, please let me know if you have other questions.
We do appreciate your input here in the Community and I wish you the best of luck with the reset. 😃
Userlevel 1
Well then how cone its working properly on my rooted tablet and on another rooted phone but my third device it isn't accepting the password. Its kind of hard to believe that because the device is rooted that its not letting me login.
Userlevel 7
I did not say that this was definitely the cause. I said we do not provide technical support for rooted devices and that a reset along with a fresh install of the app would probably solve the problem.
As a side-note, you may want to check if the device is auto-filling a different Gmail account than your other devices.
Userlevel 1
Well just so you know a reset doesn't remove root and since you don't provide technical support for root then I will not be paying next year to keep my subscription. All I can say is I'm glad that because I'm an employee of Best Buy I got this for free for a year and I would be pissed if I found this out after paying. Thanks for all of your help (sarcastically) and I'll be giving my money back to eset antivirus whose app actually gives better security if your phone is rooted.
Userlevel 7
I think I am going to jump in to clarify here.
The official short-item is "We cannot provide support for rooted devices".  That does not mean that we can't -work- on a rooted device.  What it means is that the very nature of a rooted device prevents us from being able to anticipate issues and troubleshoot them accurately.
Android itself is already very fragmented, however on stock devices we have a general expectation of how the OS will operate, what APIs will be available, and what we are allowed to do within our sandbox combined with what other programs can do within theirs.  As soon as the device is rooted, all bets are off.  I've installed ROMs on mine that completely removed some APIs from working properly, for example, and banged my head against a wall for days trying to figure out what was wrong with an app before I realized the ROM didn't even have support for that specific standard API.  Root apps can also gain abilities that can't be anticipated by support or the app.  These abilities can break things in really cool and obscure ways too.
Just as a good example, (and no offense to the wonderful folks at ESET), I guarantee that on my rooted phone, I can break the ESET app by simply using rooted apps in the way they were meant to be used and not intentionally attacking the ESET app.  Moreso, in the event I contact their support about it, their support will be able to do absolutely nothing to solve it unless I volunteer the specific information about how I broke it.  (Keep in mind that I say this because I have done so as part of our testing.)
What ends up happening with Rooted devices is that we can really only give the user the information about what needs to be able to happen, and allow them to make their own diagnostic decision based on their personal knowledge of their rooted device configuration, apps, etc.  Thus, we can't really provide technical support for root, but rather only technical information.  We are having an internal discussion regarding this issue right now, by the way.
Now, addressing the issue itself...
"Incorrect email or Password"
The number one cause for this is that the OS pre-fills the Google Account email address, but the user's email is a different one.  For example, on the phone, I might be logged in as, but my Webroot account is  On the login screen, the device will pre-fill as the email, which I would need to change to in order for it to work.
The number two cause for this error (and honestly the number one cause on Rooted devices, but also happens on non-rooted devices with some custom keyboards) is, generalized, the group of stuff defined as "Password Entry Issues". 
The first of these is caused by the keyboard defaulting to an initial capital letter or caps-lock.  Since the password is case-sensitive, this will usually cause the password to be wrong.  When trying to enter something like (Bad example): "password123", an initial caps will cause it to be "Password123" or caps lock will make it "PASSWORD123", neither of which will work.
The second is a bit weirder, and is a small subgroup of the group.  Simply anything that causes the password to be entered incorrectly.  Stuff like a keypad that is registering the wrong key, especially near the edge of the screen for example.  I had a consistent problem with a ROM I tried where hitting a "1" was nearly impossible, as it almost always became a "2".
Other things that can interfere with the process also exist. 
- Network firewall apps that block the request can cause an issue. 
- A few AdBlock-style programs that modify the hosts file have been known to blanket-block certain IP ranges that include our authentication servers. 
- Apps that affect the permissions of other apps or ROMs that affect the permissions of other apps can cause issues. 
- Apps that monitor system logging and take action based on visible URLs have been known to cause issues. 
- We have also seen root ROMs and apps that are actually malware and if they get in first, they can hide pretty effectively, even from root-access security software.  At that point they intercept entry of data into any password field and cause it to intentionally fail to get the user to "confirm" the password (often multiple times). 
- Custom kernels that exclude certain cryptography functions can cause our hashing to fail.
- Local proxy apps off various types with root can cause the request to get mangled and no reach us accurately, so it gets denied.
And for all that list, there are invariably completely new things that can be hidden in rooted devices or custom ROMs that can break the functionality.  Without root, the list of things that can cause problems for us is very small by comparison.
Now, interestingly enough, you mentioned that you have a snapshot backup of the app.  When you restored this to the other device, it worked, but it did not show up as a different device.  That makes complete sense, since the app's generated device ID is stored in the data files and not regenerated.  I will check on a few things, as there might be a way to update the ID after the fact, but I don't have a good feeling that it will work.  I'll check with devs regardless.  However the fact that it did work with known-good stored information means that the servers on our side are working properly, so something is causing the wrong data to reach our servers and thus be declined. :(
Perhaps you can see where, with a rooted device, there are literally dozens of known and unknown things alike that can interfere with the data reaching our systems.  With that large a group of possibilities, and potentially with the specific cause existing only on your phone alone, there is no way for us to reliably troubleshoot.  The only thing we can do, as I have done above, is give you information that can help you to possibly diagnose where the problem may be occurring, but digging through the unique configuration on the device is something that you will need to do yourself.
Hopefully the information above will allow you to figure out what is going on there.  Unfortunately, when the device is rooted, we're more blind to potential problems than the device's user, so we can literally only canvas with general possibilities and hopefully enable the user to diagnose.
Userlevel 1
Thank you for your response. I am on stock rom and kernal as well as the stock keyboard. I disabled my adblocker and don't have any firewall apps and still no go. I also tried it over wifi and cellular data connection. I understand your response as far as there's endless amount of things that could cause an app to not work properly if a device is rooted, it's just puzzling that it works no problem on my rooted Asus Transformer and my rooted Photon.
Userlevel 7
It also works just fine on my rooted Evo 3D.  Like I said, it's probably not the app, and it usually isn't specifically the rooted-status' fault.
Step 1 is always to double-check the email address you put in.
The password step I like to take is to type the password into anywhere else at all (Notepad, whatever), then long-press, select all, copy, and then paste it into the password field.  That way there's no way for the password to be entered incorrectly.
That at the very least will cover the entry issue problem and help narrow down where the failure is occurring.
You might want to also snag LogCat and record the system logs while you test it.  Sometimes those can provide us with some hints as to what might be occurring.