Knowledge Base

Mobile - "Login Failed. The email or password you entered is incorrect."

  • 8 June 2012
  • 4 replies
Mobile - "Login Failed. The email or password you entered is incorrect."
Userlevel 7
  • Retired Webrooter
  • 1581 replies


When I try to log in with my email address, password, and keycode its giving me an error saying "Login failed. The email or password you entered is incorrect."  What do I do now?


Is the Device Online?

If Webroot cannot connect to the internet at all when entering your username and password, it may misinterpret the lack of connectivity as an indication that your username or password is incorrect.  Please open a browser and go to a new page to see if you have internet connectivity.  If not, please troubleshoot your device's internet connectivity issue first.  Webroot cannot reach out to our servers if your device cannot connect to the internet.


Pre-Filled Email Address

The number one cause for this issue is that the OS pre-fills the Google Account email address, but the user's email is a different email address.  For example, on the phone, I might be logged in as, but my Webroot account is under  On the login screen, the device will pre-fill as the email, which I would need to change to in order for it to work.


The second most common cause of this issue is caused by the keyboard defaulting to an initial capital letter or caps-lock.  Since the password is case-sensitive, this will usually cause the password to be wrong.  When trying to enter something like "password123" (intentionally bad example / don't use a password this easy to guess), an initial caps will cause it to be "Password123" or the caps lock will make it "PASSWORD123", neither of which will work.

Keypad Miscalibrated

The third most common cause is that it could also be something like a keypad that is registering the wrong key, especially near the edge of the screen for example.  On some phones on which the touch-pad is poorly calibrated, it will register a 1 as a 2 for instance.

Issues with it Being a Rooted Device if it's Rooted

It could also be that your phone is rooted and is running something at the root level that is causing this problem.  If you have intentionally rooted your phone, unfortunately we cannot support that device.

That does not mean that we cannot work at all on a rooted device.  What it means is that the very nature of a rooted device prevents us from being able to anticipate issues and troubleshoot them accurately.  Thus, it is unsupportable.
On a stock Android device we have a general expectation of how the OS will operate, what APIs will be available, and what we are allowed to do within our sandbox combined with what other programs can do within theirs.  As soon as the device is rooted, all bets are off.  Some ROMs will cause certain APIs on the phone to stop working properly. Root apps can also gain abilities that can break installed apps that can't be anticipated by support or the app itself.
What ends up happening with Rooted devices is that we can really only give the user the information about what needs to be able to happen, and allow them to make their own diagnostic decision based on their personal knowledge of their rooted device configuration, apps, etc.  Thus, we can't really provide technical support for root, but rather only technical information.
That said, if your device is rooted and you are running into this problem, other things that can interfere with the process also exist:
- Network firewall apps that block the request can cause an issue. 
- A few AdBlock-style programs that modify the hosts file have been known to blanket-block certain IP ranges that include our authentication servers. 
- Apps that affect the permissions of other apps, or ROMs that affect the permissions of other apps can cause issues. 
- Apps that monitor system logging and take action based on visible URLs have been known to cause issues. 
- We have also seen root ROMs and apps that are actually malware and if they get in first, they can hide pretty effectively, even from root-access security software.  At that point they intercept entry of data into any password field and cause it to intentionally fail to get the user to "confirm" the password (often multiple times). 
- Custom kernels that exclude certain cryptography functions can cause our hashing to fail.
- Local proxy apps of various types with root access can cause the request to get mangled and not reach us accurately, so it gets denied.

Kindle Fire-Specific Issues

We have noticed that on some Kindle Fire devices that when changing between number and letter keyboard interfaces, the last character entered into the keycode field is sometimes deleted. You should check to be sure the last character is still there after entering a new one to avoid this. Another option is that instead of switching between keyboard interface, you customer can press and hold letter keys on the top row of the keyboard to see number and punctuation options. Also, it can help to disable spell-check. Finally, copying and pasting the keycode from another app, such as an email app, where you should have your keycode in an email, will avoid all issues.

Still can't get in?  Try resetting your password.

- Go to
- If you can sign in without any trouble, go ahead and sign in, click your username at the top right side of the screen, go to Account Settings, and click "Change" next to "Password." 
- If you can't sign in to the online console at all, use the "can't log in" link to reset the password instead.
- Wait a few minutes and try signing in on the mobile device again with the new password.


"I tried all of these suggestions, but I still get the error message."

- Support may need to take a look at the account for you.  Please open a support case, and we'll be happy to help.

This topic has been closed for comments

4 replies

<div class="lia-message-template-content-zone"><p>If the Login failed after you downloaded the Mobile App to set it up on your Mobile Device, try going on the web with your Mobile device, login to your Webroot account online. Once you are logged in, go back to logging in on the app set up. worked great for me.</p></div>
Userlevel 1
<div class="lia-message-template-content-zone"><div class="lia-message-template-content-zone"><div class="lia-message-template-content-zone"><p>I had problems with login for both mobile and backup. I got a few hours of help over the telephone from support, but they were not able to find out what caused this. We ended up with creating a brand new account (keycode) for me.</p><p> </p><p>When I changed my password later, the problems were back.</p><p> </p><p><u>This is what I found out:</u></p><p> </p><p>When creating a password with the online console, some special characters looks like they are beeing registered by the usual dot. <strong>But they are not.</strong></p><p>When trying to login on mobile or backup with these characters, the login fails. I you enter your password <strong>without</strong> these special characters - it works!</p><p>On the online console, you are able to log in with these special characters - or without - since they are not recognised by the online console when entering them.</p><p>That makes this confusing - you think your password is correct (and so did customer support).</p><p> </p><p><span style="line-height: 15px;">Another issue was that I was able to use the numeric keypad when creating a password online, but I could not enter numbers by using the numeric keypad when logging in to the backup feature. They were not entered.</span></p><p> </p><p>I hope I got this correct, and that it might be helpful to someone.</p></div></div></div>
by SuezieQue77 ?08-16-2013 11:01 PM - edited ?08-17-2013 12:41 AMhttps:///t5/Webroot-SecureAnywhere-for/Mobile-quot-Login-Failed-The-email-or-password-you-entered-is/tac-p/54046/highlight/true If the Login failed after you downloaded the Mobile App to set it up on your Mobile Device, try going on the web with your Mobile device, login to your Webroot account online. Once you are logged in, go back to logging in on the app set up. worked great for me.
Does one have to go through this process every time?
Just wasted hour and a half on this mess.  Not impressed with tool...might be cancelling it.
Userlevel 7
Badge +62
Hello dw999,
Welcome to the Webroot Community,
Please make sure you have the right version downloaded for your license of WSA.  Please refer to this KB Article for help.
You can also submit that Trouble Ticket for further help if needed as well. Or call:
Mon-Fri 7:00 AM to 6:30 PM (MST)
Sat-Sun 7:00 AM to 6:00 PM (MST)
Support is free of charge with a subscription.
Hope this helps,