Remove Webroot

  • 27 February 2013
  • 26 replies

I have installed Webroot on my Galaxy Note 10.1 and it is not performing correctly.   I want to uninstall it and can't.
I have gone to my applications manager and selected Webroot, and where I should have the option to (UnInstall) the button is NOT active.  Therefore I can't complete the task that route.
Any suggestions would be greatly appreciated...........   Thanks!   Ben

Best answer by shorTcircuiT 27 February 2013, 03:15

View original

26 replies

Userlevel 7
Hello Ben, and welcome to the forum!
Have you tried the steps outlined in https:///t5/Webroot-SecureAnywhere-for/Uninstalling-SecureAnywhere-Mobile-for-Android/ta-p/4711?
Hopefully this helps, but if not let us know, and maybe someone else will have additional ideas, or you can also Submit a Trouble Ticket
Of course there may be a fix for whatever is not working correctly as well.
Thanks a million........   The steps in the knowledge base did the trick.
You're Awesome!   Have a great day!
Userlevel 7
Glad that it worked.  If you reinstall and continue to have problems, let us know!
I'm trying to remove we root from my Nexus 10. I have followed all the steps in the referenced article with no luck. When I try to disable Web root was a device administrator a Web root dialog appears and I select deactivate but the box won't un check so I can't Uninstall. Please advise. Thanks, Larry 
Userlevel 7
Hi Larry.  Welcome to the Community!
Please take a look at this other knowledgebase article.
Have you tried uninstalling through the option in Webroot itself?  If so, what happens?
Thanks for the reply. When I try to uninstall from Web root it says Web root is a device administrator and must be deactivated. Then back to the previous description. Regardless of using settings or Web root I can't disable Web root as a device administrator. 
Userlevel 7
Larry, what should be happening when you try to uninstall Webroot is that it asks for your password.  Are you saying that's not the case?

The message you're referring to is one you can get when attempting to deactivate from Google Play, but that is only one way of uninstalling Webroot.

As noted in the referenced article, "The first (and easiest way) is to uninstall directly from the app itself. To do this, open the Webroot app, tap your Android menu button (varies device to device), and then tap the "Uninstall" icon. The app will then prompt you to enter your "My Webroot" account password. Enter it and tap "OK."

If you do it that way, you would not be receiving the message you're reporting you received - rather you will be asked for your password.  If the issue is that you forgot your password, please reset it from this link.
My first attempt was from within the app. It did prompt for my password the first time. I've never tried to uninstall from from Play only from settings:apps. When I try from within the app now it does not prompt for a password. It only asks if I want to proceed. Then loops into the deactivate device administrator described above. 
Userlevel 7
Larry, when you attempt to uncheck the box, are you taken to this screen?

When you tap Deactivate do you get this screen?

In either case, if not, restart your device and try again, and please let us know what screen you do get if not these.
Please also let us know whether or not the device is rooted and what version of the Android OS it's running.
Nexus 10. Not rooted. Can't upload pix to the forum. No flash in Android Chrome. Here are some in Dropbox.
Userlevel 7
Oh, it's 4.2.  That helps to explain this situation a bit. 
So, there is a known issue regarding multiple users that is likely coming into play in your situation.  4.2 supports multiple users, and the way the tablet treats device admin across that multiple user set is interesting and needs to be addressed in a future build. 
I believe what you're going to need to do here is disable device admin in all of your user accounts - particularly the one into which Webroot was originally installed.  Once you've done this, try to uninstall from the account into which Webroot was originally installed, and let's see if that helps you.  Please let us know if that works to address the issue.
By the way, you can upload pictures to the forum when doing a regular Reply instead of Quick Reply.  There is a little tree icon you can click to get the upload dialog.
I don't have multiple accounts. I didn't use quick reply. The picture up load dialog is flash. Android Chrome no longer supports flash. 
Userlevel 7
Another option would be to see if the reported behavior is any different when booting your device into Safe Mode.  Third party apps are disabled in that mode, so there should be no issue uninstalling from there.  On a Nexus 10, press the power button for seven seconds until your tablet reboots. Then press and hold both the volume up and down keys until you see the words ‘Safe Mode’ appear in the lower left-hand corner of the screen.  Let's give that a try.  🙂
I booted into safe mode. No device administrators appear in settings. Web root is not running and is not in the app drawer so I can't uninstall.
Userlevel 7
If it's still on your device, it should be in Settings > Applications > Manage Applications. Please check there while in Safe Mode.

It's normal for device admin to not be active in Safe Mode.

When not in Safe Mode, If you go to Settings > Applications > Running Services, is SecureAnywhere listed there?
Well yes, it shows up in manage applications but Unistall is not lit.  It's not in the app drawer so I can't launch it to uninstall from inside the app.
Article on the Flash issue:  I'm not interested in side loading it.
Userlevel 7
Alright, that's helpful to know.  Is the service running though?  You'll want to check that when not in Safe Mode.

In your sixth screenshot, the app has been made to open.  There is a "Fix It Now" option there, and I'm curious to know what it's asking you to fix.  If both the service is running, and you can get back to that screen, please tap Fix It Now to see what it informs you needs fixing.

Thanks for your patience on this.  I don't think we've ever run into an uninstallation issue quite this perplexing.  We may end up getting some logs for further troubleshooting depending on the answers to the questions we've just asked.
The images in posts issue is something I think we can probably rectify, but we'll have to take a look at it.  Thanks for mentioning it.
Yes, the service is running when not in safe mode.
The "Fix It Now" is showing because I had turned off the Lost Device Protection and Password Protection features in an attempt to uninstall.
I'd be happy to provide logs, etc.  Just let me know.
BTW, Steve R (my son) says hello. 🙂
Userlevel 7
Let's use "Fix It Now" and turn those back on to see if that jogs anything.  This could be related to Password Protection, and as long as you know your password, we're better off having that on while we troubleshoot further.  With it turned on and the app no longer requesting you to Fix It Now, does your device allow you to either Uninstall or disable Device Admin?  And is the behavior in Safe Mode changed at all in relation to Uninstall being greyed out?

Tell Steve we really miss him here.  :)

To be honest, as a mobile developer, he's probably in a better position to answer this question than I am.  I poke at the things he wrote, whereas he actually wrote them.  I'd be curious to get his take on this issue, but if he referred you to support, we'll keep working at this until we get to the bottom of it.
I'm going to follow up via private message with log gathering instructions shortly.
Turned Password Protection and Lost Device Protection back on.  Still can't uninstall from the app.  The results are the same.  Can't uncheck Device Admin in Settings.  Can't uninstall from Settings::Apps
Userlevel 3
He tried Jim I sent him to you guys.  Issue is the Uninstall from within the app isn't disabling Device Admin on 4.2.  It also apparently is re-enabling it if you disable it from within settings. 
At least that's all I can tell without code 😞
Userlevel 7
I just sent the log gathering instructions. When we get them back, I'll take a look at them to see what I can see, but probably we'll run them by Q.A. on Monday. I believe we have a 4.2 device in Q.A. to do some testing on, but I don't have one handy myself. If we can reproduce this on another device, that would be handy in locating and resolving the issue. If I don't get back to you later on today, we'll probably have a response Monday at the soonest.
Steve, I don't suppose you tried removal via ADB already have you?  That's a pretty complex process for an end-user, but you're a special case obviously.  🙂
Userlevel 7
Hi Larry,
First of all, I am really sorry for the delay in getting back to you regarding your issue (I did get your PM so thanks for sending that over). I watched the video you provided in the support ticket again a few times over and here is what I am seeing...
Oddly, out of the numerous times you go into Device Admin, you are greeted by the option to "Activate" rather than "Deactivate". That said, at 1:18, you finally are presented the screen you're looking for and the system asks if you would like to "Deactivate" (which you choose). It is at this point that you should have proceeded to uninstall the app instead of reactivating Device Admin so if you can replicate this again and try to uninstall with Device Admin actually deactivated, I think that may just do the trick.
The video also leads me to two other points, one being an issue due to Android itself and the other something I haven't seen before with the WSA app.
1. The checkbox next to Device Admin isn't automatically refreshing and stays checked even when you do deactivate it. This is potentially confusing, but unfortunately it is a limitation of Android. However, manually refreshing and going back to Device Admin after it is deactivated should see the checkbox no longer be checked.
2. When Device Admin is "On" and you attempt to uninstall WSA from within the app itself, it seems that something is working properly and the "off" command isn't triggering as it should. We can investigate the issue further.
Still, as the video shows, you are eventually able to disable Device Admin, but you enabled it instead of proceeding to uninstall. Please follow the same steps you did before 1:18 and turn off Device Admin. Afterwards, please proceed to go into the WSA app again and uninstall.
Let me know if that solution works for you!
I believe that was in the video I sent. Regardless, if I turn off Device Administrator via settings, which I indicated by opening again and showing that is says Activate (implying it is Deactivated), I then go immediately to the app and when I go through the uninstall process I come to the WR dialog that says Activate Device Administrator and the button at the lower right says Activate, indicating that it is deactivated.