Scan freezes - apparently draining battery!

  • 19 December 2012
  • 21 replies

I have Webroot SecureAnywhere Mobile Complete on my HTC Incredible 2 (Android).  My battery has been draining so rapidly lately that I ordered a new one, and that one is doing the same thing.  My investigations led me to the battery usage on my phone, which showed that SecureAnywhere is using 43%.
When I went into SecureAnywhere, I attempted to go the Antivirus Scan screen, but the scan was frozen and would not cancel.  I restarted the device, and now the scanning always freezes on this package: "Scanning SD card: com.cinemark.mobile_12.apk."
Please advise.

Best answer by mervinw01 29 December 2012, 09:37

View original

21 replies

Userlevel 7
It could be corruption on the SD Card, so we'll want to check that first. Please remove the SD Card, insert it into your computer (you may need an adapter for this), right-click the SD Card, and go to Properties -> Tools -> Error Checking -> Check Now. Then check both boxes and press Start. When it finishes, replace the SD card, restart the phone, and allow the initial scan to commence. Does it then complete?
It completed the SD card scan, with no errors found.  I put the sd card back into the device and started the scan.  This time it froze on "Scanning Maps".
Question: Does scanning freeze when the screen turns off?
Userlevel 7
No, scanning will not freeze from turning off the screen.  It is not like entering sleep mode on a computer where everything goes into suspended animation.

How long have you let the scan continue before concluding it's stuck?  It can look like it's stuck sometimes if there is a substantial number of files on the SD Card.  What is the sixe of this SD Card, and how much of it is in use in terms of megabytes/gigabytes?

Although we can rule out corruption of the file structure and the SD Card itself now, it's possible some of the files are still in an unreadable state.  As Kit mentions in a related thread here, " A good way to check is to get a file manager app and then do a system-wide search for something you know is not there.  The search will very often fail if the file or file system has corruption." 

His subsequent suggestion to copy off the contents, reformat, and copy them back is also still relevant, even in light of the CheckDisk results.

This issue has also been shown to be resolvable in the past by a simple uninstall/reinstall of the Webroot app, though that was on a much earlier version of the app.  It would be worth trying.
Okay.  I just uninstalled and re-installed, and now it will not accept my login credentials.  And "Yes", I have verified and used my login credentials successfully on the Webroot website with no problems.  I do not want to reset either my password or security code, as they work perfectly.  This is ridiculous!
Please advise.
Userlevel 7
Badge +35
Hello mervinw01,
I am very sorry to hear about the issues you are experiencing. I recommend that you open a support case so that one of our global support agents can help you further, as our Community support staff is limited during the holidays. Please let us know if you need further assistance and we will reply as soon as possible next week. 
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Anna . Webroot Advocate Programs Manager
Userlevel 7
Hi Mervin,

I don't see that you created a support case under the same email address you used to sign up to the Webroot Community.  Did you perhaps contact support under a different email address or end up solving the password entry issue on your own? 
I would suggest resetting your password.
If you're still having issues after the password reset, could you private message me the keycode you're attempting to use on the device?
I just realized that I was entering my security code where the login was requesting my decode. My apologies. So, I am still?

Nevertheless, I am still unable to complete a scan. Again, it fails at com.cinemark.mobile_12.apk.

Mervin Williams
I uninstalled the Cinemark app and afterwards manually deleted all remaining files that included the word "cinemark", and then re-installed it. Webroot finally completed a scan and reports that all is working well. Nonetheless, over the next few days I will keep an eye on my battery usage to ensure that there are no further problems.
I am having very similar issues, what is the .apk file for? I don't have cinemark but have seen that come across as the file that hung it up...
Userlevel 7
Hello adowdell and welcome to the Webroot Community!
I am replying to all 3 of your posts here, as I don't usually reply to issues on the Knowledge Base articles.
.apk files are the actual App downloaded intaller files.  I think most users have no need of these once the app is installed, but if you have an app on your phone that backs up all downloaded .apk files like I do they will remain on the device.  If it is an .apk file that is getting stuck on scan, it is PROBABLY safe to delete that file, but I would feel more comfortable if we had another opinion on that first.
As for you other posts, even if you cannot uninstall Maps, you probably can go into the settings of Maps and clear all saved data.  Maps on my device tends to use huge amounts of room as it downloads data to display the map info for where I am or where I am scrolling the map to.  All that data on my device can be cleared in the settings.  If Map data is causing an issue on the scan, you might clear the Map data and then rescan.  NOTE: the next time you use Maps it wont be quite as fast as it no longer has that cache of previously used data and will have to download all data as you use it.  That is the reason for that huge cache of data: so that areas you have already viewed are already locally stored and will display faster.
If you tried an overnight scan and it never finished, needless to say that is a problem.  My experience on my OLD and slow device is that the Mobile app takes longer to run a scan than on my PC, but not all that much longer.  It should still be finished within just a couple minutes or so.  If clearing the cache of Maps, your browser, removing un-needed .apk files, etc etc does not help the scan run correctly, you might consider simply uninstalling the WSA app and re-installing it.  While rare, bad installs can happen and reinstalling may fix the problem as well.
If none of the above helps, you might want to Submit a Trouble Ticket and get more expert help direclty from Webroot Support.
It won't let me uninstall webroot, even if I go to manage apps and look at the actual app. The "normal" uninstall by hitting the options key while looking at apps, then it brings up the little red minus signs doesn't work on webroot either. It won't let me uninstall from "my accounts" either (it just warns that when the device logs in it will be added back to the list) I'm using Samsung Galaxy S3, not the fastest in the world anymore, but I would guess not *slow* either...
Maps shouldn't cause webroot to bolo out right? Seems like a fairly common thing to have *maps* loaded on your phone for local areas. Seems kinda sucky if the antivirus can't scan it and verify that it isn't a virus...
Userlevel 7
The Maps app itself is not a problem: if some of that cached data is corrupt, that wuld be. That is why I suggested if Maps seems to be the issue you want to clear the data cache.

To try to remove the App, I assume you are going to the normal Manage Applications in Settings? If so and it will not remove, you may want to submit that trouble ticket for more advanced help from Webroot Support.
wow... 45 minute wait time...
wondering if I should have even purchased webroot... I went all in too... I went with 5 devices for 2 years... This is borderline crazy...
Userlevel 7
Please be patient: I see on a couple other current threads that Support has been having an unusually busy day with longer than normal wait times.
It wouldn't be a super huge deal if it didn't drain the battery so bad... I could be a lot more patient if I didn't have to worry about phone going dead and not having communication if the car broke down or what ever (or if the wife goes into labor)...   It seriously uses battery so fast that the car charger can't even keep up with it.  The wall charger takes like 4-5 hours to charge it like this.  This might even be damaging to the battery and/or processor for working so hard all the time... 

Maybe the software needs to be designed in such that if it hangs up in the scanning processes that it somehow realizes its ina loop and kicks itself out.  Since you can't manually stop it from hanging up, AND you can't uninstall it... The user is literally dead in the water until someone can get around to answering the phone.  
Your scan on an android phone is horrible now.  It seems to take forever and drains my battery in minutes.  I'm about to delete your product because frankly, it's become less than worthless.
Userlevel 7
Hello Matin61 and welcome to the Webroot Community!
There are a couple of KB Articles that might be of help, check them out.
Frozen Scan
Frozen CD Card Scan
Battery Usage
I am not currently using the Andriod app, only due to my Andoid being too old (2.1)  There are a few tips above in this thread that seem to help with some users or in the KB Articles above.
I also urge you to submit a Trouble Ticket if these do not help. Obviously being Christmas Eve, reply may be a little slow, but the ticketing system is open and running.
There may be a simple fix for the issue you are having, but also any and all additional information that Webroot recieves such as specifically what device you have, what exact version of Android, what other apps may be running in the background, etc etc would be helpful in identifying and fixing it if it is a problem with the current Android version.
"A good way to check for file corruption is to get a file manager app and then do a system-wide search for something you know is not there."
You first link has this wonderful piece of advice.  Look for something you know isn't there.  Tooth fairy?  Santa Claus?  If I knew something wasn't there, I probably would have worked on fixing that already.  Looking for stuff that isn't there is not a common human capability.
Your third link doesn't work.
I'm just going to delete your application.  I'm sorry.  I can't have your application constantly screwing up my phone and draining my battery.  Your application has been screwing this up for the last couple of weeks.  I don't know why.  I really don't want to know why.  I would rather this simply worked.
Userlevel 7
The third link is fixed, thank you for pointing that out.
Obviously, the application does work without this issue for a majority of users, but just as obviously there are occasional issues due to the specific environment of specific devices.  I would urge you to submit that Trouble Ticket and allow Webroot Support to gather additional information so that the issue can be resolved on your specific device.