Can't unistall SecureAnywhere from Mac OSX

  • 20 January 2013
  • 64 replies

I've been trying for hours to uninstall an expired trial of SecureAnywhere that keeps annoyingly prompting me to register.
Every time I drag to the Trash or try a tool like AppZapper, it says I can't uninstall because SecureAnywhere is running.
So then I go to Activity Monitor to kill the process. That seems to work for a moment, but then SecureAnywhere is running again.
Please help.

Best answer by akim 24 January 2014, 18:54

View original

64 replies

Userlevel 7
Welcome to the forums jtemplin!
Hopefully you will find an answer quickly, but I would also suggest that you also Submit a Trouble Ticket
Userlevel 7
Please try shutting down SecureAnywhere before dragging it to the Trash.
Uninstalling SecureAnywhere from a Mac
1.   Shut down SecureAnywhere by clicking the Webroot icon (green W) in the menu bar and selecting Shut Down SecureAnywhere.
2.   If prompted, confirm that you want to shut down SecureAnywhere.     
3.   Open the Finder by clicking the Finder icon in the dock.     
4.   Open the Applications directory.
5.   Click and drag the Webroot SecureAnywhere program icon into the Trash in the dock.
6.   A confirming window appears.  Click Uninstall.
7.   Webroot SecureAnywhere is now uninstalled.  There is no need to restart your computer.
Hi Mike,
Webroot isn't appearing on my menu bar.
As I mentioned above, I've tried multiple ways to shut it down before throwing it in the trash.
Please advise.
BTW, I'm on Mountain Lion if that makes any difference.
Userlevel 7
Have you rebooted the machine since uninstalling SecureAnywhere?
We have Engineers that specialize in the Mac OS that will be back in the office tomorrow. One of them may need to take a closer look to see if remnants of the software are not uninstalling properly. If you Open a Support Ticket they will be able to help you further.
Unconventional solution
Hey, I had the same problem. After mucking around for a while, I tried adding ".jpg" to the end of the file name in applications (which changes the file type), which of course it didn't like, and it immediately opened an uninstall prompt that worked. Yay!
Hi all-this is driving me absolutely nuts as well. The window to install is popping up every 50 seconds and I can enter the key and then am told it cang get the update-after the keycode has been verified. No drag and drop unistall to teh .jpg solution-it wont let me change the extension. I submitted a ticket but am getting really frustrated. tia
Userlevel 7
Hi mmelkers
Sorry to hear about your frustration.  May I suggest that you 'bump' your Support Ticket, i.e., add further information to it? 
Have to say that in my experience a lack of response from the Support Team is very atypical...but as MikeR has said previously in this OSX specialist is most likely required.    
@ @  is there any way that we can get some focus on this issue for mmelkers...just in case the ticket has slipped through the cracks?  Thanks in advance. ;)
I as well can not uninstall, trash, modify, etc the WebRoot SA file in the applications folder, anything I attempt to do says "You do not have permission to the item "Webroot SecureAnywhere"  I've even tried terminal's rm command which produced the same restricted access error.
Rebooted numours times, and tried changing the permissions of the app in Get Info... thus far, it's stuck popping up every minute.
Userlevel 7
Hi rcleland
Welcome to the Community Forums...:D
What you are reporting sounds very much like previous posts regarding some issue with WSA running under OSX.  Given you are unable to uninstall WSA by the prescribed method (there is no separate removal tool) I am afraid that I can suggest at this point is that you too If you Open a Support Ticket and bring this to the Support Team's attention.
I will check out some previous thread to see if they reveal any other options but for the moment, as far as I recall from previous threads, the consensus that such issues would be best handled through the Support system, as most likely remote sessions will be needed and the Community is not equipped for that. 
I suggest that this is the best course of action. 
If however you are more technical then you could take a look at this post from another thread, where another Community member suggests a course of action that resolved, for him, what sounds like the same issue...but I would stress that you should not attempt this unless you have carefully read & understood the actions described AND feel confident of being able to undertake them safely.
Post back to keep us updated of the position of your issue, and hopefully what is done to eventually resolve it...such information is useful to have in the Community, to help other users in the future that may have the same issue.
Userlevel 7
Badge +35
Hi mmelkers and rcleland,
I checked on your tickets, and it looks like our support team responded but you have not yet read the response. Please check your ticket by entering your email address here: Let us know if you have any trouble accessing it.
So no info about what the solution is when you cannot uninstall an expired version? Why not post the solution and avoid more support calls?
I am running Mavericks on my iMac (10.9.1) and found a very simple way to uninstall it. I first shut it down completely. If you are not sure if it is shutdown to be certain:
  1. Open the program
  2. Click on the Apple on the top left of your screen
  3. Select "Force Quit" on the menu, select Webroot from the choices provided, and force quit. You may be prompted by the program to confirm you really meant to shut it down and just confirm.
After doing that I tried (unsuccessfully) to drag and drop the program from the Applications menu to the trash. Didn't work. So instead I did the following:
  1. Select "Go" in the Finder menu (its the default menu that appears at the top left of your Mac when you first log in).
  2. Click on "Applications"
  3. Scroll the list until you find Webroot
  4. Right click over Webroot and a drop-down menu will appear.
  5. Select  "Move to Trash"
  6. The program will confirm that you want to uninstall and voila it's gone!
Userlevel 7
Hi DivaFixIt
Welcome to the Community Forums...:D
Many thanks for posting such a valuable method...and so clearly done too.  This is exactly what the Community Forums are here for and how we hope that users will use them help fellow users and to learn also.
I shall bookmark this post for potential use as and when other users come here suffering from the same or similar issues.
Hope that you stay around and join in we you see the opportunity...or just drop by for a bit of fun.;)
Have a great weekend.
I just had this problem, but none of the methods mentioned so far worked. I had the pop up window telling me that an installation failed and I needed to re-enter the code. After about 15 minuits of interupted PC use, I thought I would find the code to vanquish this beast. After searching 10 minutes through old e-mails - I found it! But it did not satisfy the hunger. It wanted to interupt me more! 
Stopping the process of Webroot would not let me delete it. Even with SU priveleges I could not delete it. 
Now tell me - what app has higher priveleges than root?  Webroot somehow does! Probably because it is always running, even when you think it is not. I tried the 'force quit' method in activity monitor. Even then the app would not die. 
If it was not for the pop up screen that kept coming up - I would not have been so keen to get rid of it, but it would not leave me alone!
I resorted to a command window to attack this monster.
typing 'ps -A'   lists all the processes. In my case the process was 1177. The install directory was layed out, bare to see. 
Typing 'kill 1177' would get rid of it for a while. But it would come back like a hungry zombie. How? I don't know.  
I went to the install directory listed in the ps list. 
Performing a longlist (ls -ll) showed the offending executing file had full privaleges, including execution (obviously). 
I swiftly typed 'chmod -x Webroot SecureAnywhere'
That annoying window could no longer execute itself. Whahahahah!
But I did not stop there. I went in for the kill. 
I deleted the webroot app from my Applications and wam! That sucker was gone. 
I just hope there is not a sequal to this drama. Web Rot 2 - The return of Web Rot!
I do not mean any disrespect here, but hey - let us have a little talk about respect. Since when does a security program act like the malware programs or viruses I installed it to prevent? To be honest I only installed it because it was free with my iPad. 
I feel like a victim here. I just wasted an hour trying to get rid of this! An hour I will never see again. I can only hope this message will help others that are victims to this interupting annoying window pop-up thing. 
Userlevel 7
Badge +3
Hi. Well thanks for such a dramatic account of an attempt to uninstall an app! :D
I'd say if the usual ways of install/uninstall are not working for you, then you should contact support: the official Webroot support system
Userlevel 7
Hi Web_Rot
Welcome to the Community Fora...
I have to agree with Dermot on this one...and say well done for your patience...and do make sure that you either replciate the above in your Support Ticket Submission or better still (and to save you time) include a url link to your post so they can pick up on what you have outlined to us.
Keep us posted on how things go re. this issue as feedback, either way, is helpful to us in helping users in the future with the same or similar issues.
Many thanks in anticipation.
Glad to be here!
I fully agree, this program (Malware?) is a nightmare to remove. I have a full (non-trial) version given to me by a bank and it keeps on opening shutting and reopening over and over. Thus I decided to remove it and it seems impossible to get rid off. Deleting it leaves a plist file in trash that can not be removed.

I've tried everything suggested and really am pretty annoyed that I need to spend so much time removing something that has hijacked my system.
Userlevel 7
Hi Web_Rot2
Welcome to the Community Forums...:):)
From what you are saying it seems to me that your best course of action would be, as suggested to previous posters to this thread, that you Open a Support Ticket as soon as possible and allow the Support Team to look into this for you.  They are the experts in this area and should be able to assist.
This Works!!!
My wife's Mac was unusable becasue of this problem, and I could not even kill this S.O.B. from a command line.
So I resorted to a tried and true method that could not fail.  
Target Disk Mode.
You need another Mac (both of them Firewire equipped) to do it. Connect the two Macs using a firewire cable and reboot the infected Mac while holding down the T key.  It will come up as a firewire hard drive on the uninfected Mac (might even work with a PC as the other computer, but I have never tried that).  
Then you just navigate to the Webroot application container int he Applications folder, drag it to the trash, and then empty the trash.
When you reboot again, voila!  Webroot is dead and gone. Finito. Kaput. Good riddance.
And another thing. Any legitimate self-respecting company that had any respect for its customer base (paying customer, in my case), would simply post a solution to the forum and not require the trouble ticket BS and keep the fix a secret from their users. I could have dug the activation code out of my files and re-entered it, or re-upped online, but tolerating this behavior in an application was against my principles.
Userlevel 7
Badge +56
@ wrote:
And another thing. Any legitimate self-respecting company that had any respect for its customer base (paying customer, in my case), would simply post a solution to the forum and not require the trouble ticket BS and keep the fix a secret from their users. I could have dug the activation code out of my files and re-entered it, or re-upped online, but tolerating this behavior in an application was against my principles.
Support is usually more on top of all the technical ins and outs than anyone else - we do make an effort to document all known solutions in our knowledge base but there are some that get missed.  I think in this case we can apply Hanlon's Razor 🙂
Userlevel 7
Hi Nic
I think that you are spot on with your comment here...and for those who don't know it, and to stop them overloading the search engines...en masse...;)
It states "Never attribute to malice that which is adequately explained by stupidity"
Think about it...think about it!
"Never attribute to malice that which is adequately explained by stupidity."
That's Hanlon's Razor?  I like that.
Userlevel 7
Badge +56
@ wrote:
"Never attribute to malice that which is adequately explained by stupidity."
That's Hanlon's Razor?  I like that.
Yeah, I try to remember that one frequently.  It helps stop me from getting so mad when things go wrong 🙂