Clipboard copy blocked by Webroot when web browser is running

  • 30 January 2013
  • 13 replies

Userlevel 1
I've spent several frustrating hours tracking down a problem with an application not functioning correctly. Eventually I tried disabling Webroot, which solved the problem. The problem is similar to the clipboard issue described in https:///t5/Webroot-SecureAnywhere-Complete/Loss-of-access-to-Windows-Clipboard-traced-to-Deny-status/td-p/5754.
I'm using an application (Linn Kinsky) that has a button to copy text to the clipboard. The copy operation was failing when any web browser was running, but was succeeding when no browser was running. As I nearly always have a browser open, the failure was occurring at least 99.9% of the time.
After a very protracted and painful debugging process, I discovered that the Kinsky application had been marked as "Deny" in the Webroot Protected Applications section, with no notification to me that this had happened. This meant that my attempts to use this application to copy to the clipboard were failing, with no indication why this was happening.
My debugging steps have included contacting the authors of the Kinsky application to ask for their help, spending hours doing Google searches to try to find any relevant information, updating the .NET framework, upgrading Firefox (my main browser), disabling and deleting a number of Firefox plugins, starting Firefox in safe mode, starting Windows in diagnostic mode (which apparently doesn't prevent Webroot from starting), uninstalling and reinstalling Firefox, and downloading and installing a selection of clipboard manager programs to try to figure out what was going on.
All this work and a large amount of frustration could have been avoided if Webroot had displayed a pop-up telling me that the attempts to access the clipboard were being blocked because of my Protected Applications settings. It would surely not be difficult for the Webroot developers to add this.

I hope this post will help other people who are experiencing a similar problem, and I hope the Webroot developers will add a suitable warning pop-up in a future release of the software.

Best answer by MikeR 30 January 2013, 22:10

View original

13 replies

Userlevel 7
We actually have a Knowledge Base Article that explains how to allow your application. Simply open SecureAnywhere>click Identity & Privacy>click View/Edit Protected Applications>find your application and set it to Allow.
How to Allow a Trusted Screen Capture Program
Userlevel 7
Hello simoncn, Welcome to the Webroot Community Forum. 😃
Userlevel 1
Thanks for this quick response. I'd actually figured that out already.
Discovering that Webroot was the cause of the problem took many long and frustrating hours. Fixing the problem when I had eventually got to that point took a couple of minutes, and was very clear and straightforward.
Please give some thought to making it as easy to find the problem (for the benefit of future users) as it is to fix it.
Userlevel 7
Badge +6
Thanks for sharing your knowledge on this application Simon. I'm sorry to hear about the troubles you've had.
I agree with you, Webroot has some work to do when it comes to showing the end user what it's doing to protect them. There's a lot to said for their silent protection, which normally works perfectly, but the lack of information can cause issues. Eventually the WSA cloud will learn and fix these issues itself so their approach isn't without merit.
I'm not sure how to go about exposing this information to users without confusing them or giving a million popups. But it's something they should think about. Identity Shield is (one of) the best features of their product but it's not very sexy and thus hard to explain and market. 
As a power user, active control and alerts over Identity Shield and "Monitored" or "Denied" applications is definitely one of my top wishes for WSA. I think Webroot is too hesitant to stick their toes in the water of adding HIPS functionality sometimes. We'll see what the future brings. :D
Userlevel 1
I'm interested by your comment about the WSA cloud learning how to fix this. Is the WSA cloud automatically notified that I have manually changed the permission for Kinsky from Deny to Allow?
Userlevel 7
Badge +6
Hey Simon,
Let me put up the Webroot employee bat signal to get a definitive answer to that question.

The WSA cloud gathers data and recategorizes applications as it learns more and sees them in use across the install base over time. I don't know the specifics about the data it gathers for user overrides and what it takes to flip an application from Deny to Allow.
Hey everyone,
The Webroot cloud does not currently track the applications that are manually configured to 'Allow' on the Identity Shield Protected Applications list. At present, these choices are saved only on the client side.
Userlevel 1
Thanks for confirming this. I think it means that any legitimate application that behaves in a way that causes it to be marked as Deny will cause problems for every user of that application until the user eventually discovers that these problems are caused by Identity Shield Protected Applications. Would it be possible to add a pop-up to warn the user that this is happening?
Userlevel 7
That is a great suggestion.  It would be best to place it in the Ideas Exchange for better trackability of popularity and so it can be best communicated that the feature exists once it's been implemented.
Userlevel 1
I've added a supporting comment to the Ideas Exchange thread that explanoit has started about this.
Userlevel 1
I don't see this thread in Ideas Exchange any more. Was it deleted? If so, why?
Userlevel 7
Explanoit is a Business customer, and his idea was moved to the Business side of the Community.
There is a very similar idea here as well, which I would suggest kudoing.  This one will remain on the Individuals & Families side.
Userlevel 1
Thanks for the quick reply. I've added a comment and a kudo to the referenced Individuals & Families thread.