IE 8 keeps hanging up and freezing on Windows XP SP3

  • 15 October 2012
  • 33 replies

  • New Voice
  • 10 replies
Have had webroot secureanywhere running with mcaffe security center v11 for months w/o problems.  I let them update when the need arises.  I have had both scan the system including other independent products and no virus or trojans id'd.  Some pups but of the general nature ones.
Nothing worse when you are in the middle of something and the screen starts freezing.  Updated the video drivers and it seemed to eliminate the issue but returned aparadically.  Stated IE without addons but didn't solve the freeze.  Then decided to shutdown SecureAnyWhere and have not yet had the type of freeze (other than perhaps some impatience) previously experienced..
Don't like the idea of having the product shutdown since i'm a paid subscriber but something is going on that is causing a significant conflict and eventual screen freeze and it appears related to secureanywhere.

Best answer by Kit 13 November 2012, 00:31

View original

33 replies

Userlevel 7
Hey DB,
Welcome tot he forums! ;)
This sounds like the type of issue where it is best that I collect logs from your system to investigate any potential conflicts. I have opened a support ticket for you and send log gathering instructions. Please check the email you used to register here on the forums with to access your support ticket. You will need to enter your email and the password provided into the Support Ticket System.
Please let me know when you have sent the logs!
logs have run and been updated.   when I restarted WSA it ran a scan and I presume there were no issues as no prompts were noted.  WSA was up and running while the logs were being created.  I presumed that would be required.
an interesting note however was the following error was received (and in turn sent to MSoft).  It didn't seem to cancel or abort the WSA Log utility as it completed.
I have the image of the Registry Console Tool problem but not sure of what to type in the uniform resource locator entry on your image load above....  Needs to simply have a browse to item so you can click on it -vs- having to type in a URL.
Userlevel 7
Hey DB,
I am investigating the logs and think it may have more to do with the error you are describing. Can you please try to reset IE?
Resetting Internet Explorer:
1. Click on the "gear" and select Internet Options
2. Navigate to the Advanced tab and select Reset
3. Confirm the Reset and close the browser
Please provide me with an update if this changes any of the issues.
Mike R - unless I know more ramifications on resetting IE choose not to try it out.  Did however acquire REgWorks which Microsoft suggested in case their were registry issues.  ran it & it identified several items that it then automatically corrected.  Talk about not knowing more reamifications....   but aftewards evertyhing played together nicely in the sandbox.
a DL updt from Microsoft with it's typical "fixes".   Still ok but shortly thereafter when the PC was left alone (static) and unattended  then "resumed" the problems of freezes started up again.  Had to use task manager to kill apps and processes (sound familiar).   Then I stopped WSA and it has been 3 days and have had not one freeze since.
Seems WSA is having a conflict and causing a freeze as there can't be many other examples.  What's causing the freeze is another question that would be nice to know as just running McAffee imo w/o WSA leaves an opening (+ a subscription cost).
Can we get an update on this? I have the same issue with ie 8 in XP SP3. No Mcafee or other security.
IE freezes for some users, I disable WSA and then everything works. Come on guys, I want to like this solution but it can't gum up our internet!
Userlevel 7
Have you experienced any issues DB?
Userlevel 7
Welcome to the forum scraft!
Please Open a Support Ticket so we can investigate through logs or try my instructions for resetting IE and let me know the results.
Edit: Typo. - Kit
only when I restart wbs it seems to begin all over again.  stop wbs and it seems to go away.  I wonder if there is something going on with all the WBS shields that are running causing an eventual conflict with IE.
Userlevel 7
I am interested in the results of an Internet Explorer reset.
If you are worried about losing personal settings you can uncheck the "Delete personal settings" check box (see image below).
Userlevel 7
This is not a universal issue.  For example, it doesn't happen on any system that I have tried it on here.
This indicates that there is likely an addon or injected DLL that is being monitored by Webroot and doesn't deal properly with being watched.  In a perfect world, code is written in such a way that it handles pico-delays.  In reality, much of it is pretty badly-written. 
A quick contact with support will allow us to check your logs and see if anything like that is the case, or what is going on if not. 
Edit: One of the main ideas behind a reset of IE is that it unloads and re-configures all addons and extra stuff that the browser could be loading, so it has a potential to fix things that a lot of other programs can really badly mess up.  If you have a lot of custom configuration in the Internet settings, then you may not want to perform a reset.  If you didn' go poking at the guts of IE's advanced settings, then it should be fine and safe.  It wipes all stuff that has been there over the use of IE and takes it back to a state as if you just ran IE for the very first time.
mike r - I didn't see an image.
kit, if you took the time to read this, I had submitted all the logs.  I had also indicated initially that I started IE w/o any addons.  Before commenting, please read the entire thread.
Userlevel 7
@ wrote:
kit, if you took the time to read this, I had submitted all the logs.  I had also indicated initially that I started IE w/o any addons.  Before commenting, please read the entire thread.
Quite sorry.  I am currently in QA, so any work I do on the forums is extracurricular.  :)
The information I posted is partially generic and generalized information. 
Injected DLLs are also not always in addons, mind you.  As a good example, there is an HP WebHelper.dll being injected into IE that is technically comprised of incomplete code (TODO:<File Description>).   
Regardless, I found the logs from October 18th.  Didn't look too deeply into them, but on cursory inspection, some stuff jumped out at me.
Things that caught my eye:
- There was a threat detected on the initial install of WSA.   This means there could be damage to the system that could not be rolled back by Webroot because it wa preexisting.  Could also be a non-issue, since I research what the items were.
- The copy of McAfee installed on the system has been updating since 2006 or so.  You might find it beneficial to either or both: 1: Clear McAfee off and do a clean install of it (make sure you have your license information for them prior to doing so). 2: Tell McAfee to ignore Webroot files, especially c:windowssystem32wruser.dll.  If the second of those works, definitely let us know, as it means that we will want to check on what McAfee is doing and we are doing in response that is causing the issue. (I don't think this is the issue personally, but it's a possibility.)
- The logs are incomplete.  Specifically, the Windows Scripting Engine is normally used to gather a set of information using a VB Script in the log-gathering utility, but this information is utterly missing.  The script ran, as the framework is there, but the data is not filled.  Something interfered with a normal Windows function.  This could be any number of things from a limited user account to a security program to damage caused by numerous other things from data degradation to malware to badly-applied patches (never seen that be the user's fault).  The account is not a limited account, so that can't be the issue.  That leaves a question about what blocked the data gathering.
The thing that I think might be worth trying that won't take a huge amount of effort though is to try turning off the Identity and Privacy shield in Webroot temporarily, or going into Protected Applications under that section and looking to see if anything interesting (or at all) is set to blocked.  Record or remember the state of the protected applications and set everything to "Allow" with nothing in "Protect" or "Block".
I am going to try to encourage escalation of the ticket if possible, since just the quick glance shows me quite a few things that -could- cause the problem, but no clear indication as to what actually is doing so.
Kit, thanks... let me digest what you have indicated.  incidently, there is no such thing as extracurricular activity when in Q/A.
I can rerun the logs if need be to see if there is a comparison since I ran  MSoft's suggested RegWorks to address any registry issues if that will be of assistance for any comparison.  McAfee Total Protection is v11.6 build 11.6.435 affid 101 and last updated 10/26/2012 while the Scan is version 15.6 build 15.6 .dat vers 6882 build 15.6.231.
best regards
former  SQA & ISO9000 sr. director (now thankfully ret!)
Userlevel 7
I'm web QA so there isn't time for anything else really.

A rerun of the logs might be a good idea to see if the OS functionality used by the script is working now. I am aware that McAfee is up to date, I was saying that it has been on a relatively long update chain with no clean installs and appears to have a good bit of old stuff sticking around that it should no longer be trying to use, but it is still loading several outdated libraries if I recall correctly. Sometimes cleaning up the old stuff can be helpful.

I still primarily recommend checking stuff in the Identity Shield based on what I'm seeing and the troubleshooting that it will allow us to focus on or rule out.
Edit: Corrected some "smart"-phone-based typos.
Thanks for the updates Mike and DB. I actually tried resetting IE 8 as directed (SOP for stuff like this). I also ran MBam and Superantispyware scans and no virus. This is affecting several machines, all XP SP3 with IE 8. Disabling all shields seems to resolve the issue.
Also, other browsers seem immune, as I have directed users to use Chrtome or Firefox as a temp workaround.
I will open a support ticket, update upon results.
@ wrote:
Thanks for the updates Mike and DB. I actually tried resetting IE 8 as directed (SOP for stuff like this). I also ran MBam and Superantispyware scans and no virus. This is affecting several machines, all XP SP3 with IE 8. Disabling all shields seems to resolve the issue.
Also, other browsers seem immune, as I have directed users to use Chrtome or Firefox as a temp workaround.
steve - thanis for the added input.  getting users off with a workaround  is a good thing.
However, disabling all shields seems to me to defeat the purpose of WBS.  But, it does appear to confirm the thought that one (or more) of the shields is causing an incomatability with IE.
Yeah, the disabling of our shields/SWA was not a solution but a verification that WSA is the culprit. I will post when I receive a response from support. Thanks for all the info!
Userlevel 7
Again, it's not a common issue.  The vast majority of customers on XP and IE8 are not encountering it. Therefore it will require some troubleshooting.
Narrowing down which shield function is causing the issue is still the best idea, which is why I requested that you start by disabling the Identity Shield functionality either by turning of the Identity shield or looking into the Protected Applications for anything standing out as blocked and setting everything in there temporarily to Allow.
These are all great suggestions, and I will definitely be following them after hours today. We work 8-5 and I am going to let my users enjoy their Friday. I really appreciate the responsiveness of this discussion board. Thanks!
Userlevel 7
Please update the thread if you try Kit's suggestions and narrow it down to a specific shield. 😃
reset IE based on Kit's suggestion and like the other user indicated it did not solve the freeze.
brought WBS online after reboot and went thru the IE8 auto dialogue again....    within short period of time FREEZE.
Get rid of WBS by shutting it down - NO Problem experienced.
Not sure what exact steps to take with the Shields as there are way too many to try and understand and too vague of instructions to an end item customer especially if i am reading it correctly I need to keep track of what's being manipulated nothwithstanding whatever exposure there is from there not being active.. 

I had a similar proble with Windows XP service pack 3. Only happened when I was using my browser. Total lockup for about 90 secocnds and then system released. According to Webroot a file named plugin-container.exe was maxing out my memory resources and the firewall tried to stop it. Thereby locking up the machine. I found the Webroot firewall was the problem. Disabled the Webroot firewall and run the Windows firewall and so far all is well. Pretty weird as this ony started happening the last month or so.
Userlevel 7
Badge +56
Hi Bernie just to let you know that the Webroot firewall is only outbound and Windows firewall is inbound and is recommended that you run both and plugin-container.exe is part of Firefox can I ask which version of Firefox you are using as I have v16.0.2 and don't see plugin-container.exe in my firewall list?
I actually run Seamonkey which is Firefox and Thunderbird combined in one suite. Designed by the Mozilla team. That is why you see plugin-container.exe  I understand what you are telliig me here. I can only tell you shutting off the Webroot firewall stopped the crashing on my machine. As I posted, Webroot would post the warning about plugin-container eating all the resources and caused the crash. I do not get a blue screen. The machine locks up, the computer beeps, and then after about 90 sconds beeps again and the warning message comes up. I can then go forward. I am using Seamonkey 2.13.2 which is built on Firefox 16.0