Safari Web Extension error when installing (OSX)

Hi, when installing Webroot trial on my 10.8.3 ML I´m not able to install the Safari threat shield extention due to an error (error msg translated to english: not able to install due to an error). Have uninstalled WR and reinstalled - same result.
In the market for a security sw and WR was promising, but if not solved I have to move on to another solution.
PS. Is Safari the only supported browser on a Mac? Running Chrome and there is no shield icon in the browser.
Pls advice.

Best answer by JimM 22 April 2013, 20:03

View original

11 replies

Userlevel 7
In spite of the error message, following installation, did the icon appear in Safari? If so, what happens when you click on it?

If not, please try doing the following:
Close Safari. Then open the SecureAnywhere interface. From the main window, click Mac Security. Click the Shields tab. Click the button next to the Web Threat Shield to turn it off. Then turn it back on. Close Webroot's interface and open Safari.  Did that trigger the icon to show up?

It could also be that there is something going on in Safari prohibiting the Web Threat Shield from installing. If you haven't restarted between uninstalling and reinstalling, please try that as well.

Do you have any other toolbars in Safari?

You noted that you're running a localized Mac OS. Could you specify the language? A screenshot of the error could also prove to be useful if you are able to provide one.

Safari is currently the only supported browser for the Web Threat Shield feature in Mac versions of WSA Antivirus.
1. The icon did not appear in Safari
2. Have restarted
Attached is screen shot of error msg. Language is Norwegian.


Userlevel 7
When you are installing, could you try choosing the Norwegian language option?
Norwegian is not an option in the drop down box...
Userlevel 7
Are you using the most current installer?
Userlevel 7

I see it on the most current version of the installer. ^
That´s Netherland - not Norway... 
Userlevel 7
Ah, my mistake.  How embarrassing that I misread that.  :$ 
I will do some research to see what else can be done, but if it's not in the supported languages list, sadly it may not work on an unsupported localized build.
Userlevel 7
Based on my research so far, it seems unlikely that this issue is occurring due to the localization, though it could still be possible.

Let's check for a bad extension. To do this, close Safari and then uninstall WSA. Then navigate to /library/Safari/Extensions. Look for 'safebrowser.safariextz.' If it exists, delete it. Reboot, and reinstall. If it doesn't exist, that rules out one possible issue of a corrupt extension that isn't being properly uninstalled. Please reply with the result.
The safebrowser.safariextz file does not exist in library/extentions when WR is running, nor when uninstalled.
Userlevel 7
My hunch is that the extension is trying to open a language file for an unsupported language, but I'm not going to be able to firmly draw that conclusion without some supporting log data.  At this point, I think it's best to turn this investigation over to our official support system so we can get a more in-depth technical look at what's going on here.
Please include a link to this conversation in the case when you open a support issue.
I wish I could be of more assistance personally on this case, but to get the best response possible, it would be best to go through Support on this one.  We'll be interested to hear the results of the investigation.  Thank you for your patience on this issue.