uninstallation issue

  • 10 March 2012
  • 74 replies

Hi!  I hope you can help me.  After scanning the internet I cannot seem to find any help for my problem.  Here goes.  I installed Webroot many months ago and had a six month antivirus protection after buying my computer from Best Buy,  About a month ago it stopped working.  I could no longer open the program.  I thought it had expired, so I renewed it, tried installing again and it wouldn't work.  I can't remember exactly what it was doing, but if I remember correctly, it wouldn't accept my new key code.  After being frusrated and trying many things, I returned my renewal and uninstalled what I could from my computer of Webroot.  However, when I restarted my computer recently, a box came up and asked if I wanted Webroot to make changes to my hard drive.  Obviously something is still there.  I went looking and found WRSA in my programs files.  It does not show up in programs where I can uninstall it.  If I try to delete the program, it tells me that it cannot delete the file because it is open in system.  Help.  I want to remove Webroot from my computer but can't seem to figure out how to do it.  Obviously I cannot install it, but I also cannot uninstall it.  Any thoughts?  
(edit for searchable subject line - Jim)

Best answer by Kit 12 March 2012, 04:42

View original

74 replies

Userlevel 7
You can use the cleanup utility located here to remove any remnants.  I'm curious, when you had trouble, did you contact us?  We are generally very quick to assist.  Be aware that if thee utility does not work, chances are the installation was damaged by an aggressive infection, so may require attention directly from the support team for assistance or, if the infection is still present, the assistance of your current AV provider.
I didn't come for support, because I didn't find you until I had already cancelled my renewal and was searching for a way to remove the wrsa.exe file.  I am impressed with your support system, and if I can find a solution, may return to webroot.  Thank you for the prompt help, but unfortunately, the utility did not remove the wrsa.exe file.  After running the utility, I restarted the computer and once again, on start up I was asked for permission.  I went to the file location, tried to open it, but am unable to even open the file.  When you say the installation was damaged by an aggressive infection, what are you referring to?  I haven't had any viruses or other problems.  Thank you again for your help!
Userlevel 3
I would recommend creating a support ticket and we will be able to gather some logs and help you remove the program from your computer.
Contacting Webroot Support
Userlevel 7
My bad on that one.  For some reason I was thinking you were talking about the older installation.  The removal utility will NOT remove SecureAnywhere (WRSA.exe).  Aggressive infections (TDL4, ZeroAccess) have been known to damage security software installations and prevent their proper operation.  Doesn't sound to be the case in this situation though.
I was previously inquiring whether you asked us for support with your original problem prior to cancelling the renewal, and it sounds like you didn't.  Please do always be encouraged to get help from us with any problems before cancelling service, since the cancellation of an active account can remove some data that can otherwise be used to assist you.  Though of course if the account is still active and just the renewal is cancelled, that's a non-issue.
If wrsa.exe is prompting for UAC permissions when you start the computer, it's potentially set to run as administrator (a setting on the file itself for Compatibility Mode, but this should not be set), however it still sounds like the installation was damaged.  For example, if the service was disabled or deleted by something, but the Run key is left behind and the settings data is damaged or corrupted, you will experience the symptoms you've described.
Your best bet in that case is to restart the computer into Safe Mode (Not "with networking", just regular Safe Mode).  It should NOT prompt you or trry to run int hat case. Then remove:
The entire C:ProgramDataWRData folder
The entire C:Program FilesWebroot folder
The C:Program Files (x86)Webroot folder if it exists
This will remove all the code, but not the registry entries.  You have the option to remove registry entries by hand, or to use a valid keycode (even a trial) to reinstall WRSA temporarily (takes a few seconds) and then uninstall it via normal methods thereafter, at which point it will clean up its stuff.
These are GENERIC directions, while the support contact opens a custom ticket for you and allows the collection of system-specific data via wsalogs.exe which allows for a tailored solution for your specific situation.
Thank you.  I will run that and I am in contact with support.  I appreciate the help and wish I had found it before cancelling the renewal.  Thanks again for your help.
Click on webroot icon on computer task bar  and select exit  .

Then go to control panel clic on add or remove programs, search the webroot file  and click on this and click on uninstall after this you can restart your computer and click on start and click on programs and select the webroot folder and select delete.

Userlevel 7
Hi pollostar!
In this case, he was having trouble because Webroot is not in Add or Remove Programs (Which only exists on XP, mind you.   Vista and Windows 7 use Programs and Features).  Also, notably, when removed successfully via the control panel as you indicate, there should not ever be any Webroot folder to delete.
Welcome to the Forums!
I'm having the same exact issues....
I don't have any of the original information. I believe the program was installed when I bought the computer, and it was for a 6 month free trial. 
How would I go about having this exact same problem resolved? I tried running the program which was listed, but that didn't work. As far as restarting the computer in safe mode and deleting the files listed... I've never done anything like that before.
Userlevel 7
While there are some useful suggestions provided in this topic, you may wish to contact support to receive instructions for manual removal or to have a support agent take care of it for you.
Frankly I think this is a marketing ploy. I have only the one original installation. My subscription expired, and so I turned webroot off. Didn't even try to uninstall it because I know they design these things to make it almost impossible. They hide pieces of it all over the place. No ID, they shove them into alredy existing folders. 
Now. every time I start up my laptop I get that wrsa.exe popup that warns me "wrsa.exe is trying to make change to your hard drive". EVERY time. 
Can anyone convince me this is not a marketing gimmick?
Thanks for your time and any responses. 
Userlevel 7
Hello webrooted, welcome to the Community!
No, this is absolutely NOT a marketing gimmick.  Webroot components are set into the startup for the purpose of updating the associated browser protection add-ons.
If you are no longer using Webroot, you should uninstal it.  While many AV's are indeed nearly impossible to remove, WSA is not usually so and generally removes cleanly in my experience.  In the event that it does leave any traces, this should not be a problem.  I am not aware of any major issues caused by any fragments left as one can see from other AV solutions, such as the inability to connect to the internet, etc etc etc.
The startup components are an essential part of keeping ALL protection modules fully up to date and working correctly.
Userlevel 7
Hey webrooted!  I'll ditto what David said, definitely "uninstall" it if you no longer plan on using it.  I've had to uninstall/reinstall on occassion and never experienced a problem.
- Jeff
btw - Nice user name :D
Userlevel 7
I will throw in that on ONE occasion, when uninstalling/reinstalling to test certain things, the uninstall did leave the browser add-ons intact instead of removing them.  Every other uninstall they seem to have been correctly removed.
IF you find that after uninstalling the browser add-ons are still present, simply go into browser settings and manually disable/remove them.  
Again, that is a rather rare condition when they do NOT remove during the uninstall, but I have noted it on one occasion so it it may be worth noting.
Userlevel 7
I completely agree and support what David & Jeff have said above.  Uninstallation is only occassionally an issue and even if it is (which it is rarely) even that can be resolved relatively easily.
Hmmmm . . .  You've pretty much reassured me that I can uninstall this without terrible repercussions. Hopefully none at all. My motto is usually "if it ain't broke, don't fix it", and this kinda falls into the inbetween category of 'it ain't really broke, just kinda wobbly, but I'd prefer to be rid of it' category. It is a fairly large category, but that's another story. 
Ok, I'll let you folks know how it goes when I do the deed. 
Thanks again, and enjoy the weekend.
Userlevel 7
No problem, webrooted.
Look forward to hearing that all is well uninstalled.
Have a great weekend yourself.
Ok, so far . . . Today, when my laptop loaded up, and after I closed that 'webroot wants to play' box I brought up control panel and proceeded to uninstall webroot. Almost immediately upon hitting the uninstall link, but before I could confirm the uninstall request, a pop-up window appeared saying "Uninstall was unsuccessful" giving me two options. One was compatibility issues the other uninstall unsuccessful. So I took the not-so-subtle hint and left everything as is. 
I just can't help feeling it will cause me grief (more than the annoying pop-up wrsa.exe thing). And I still believe it is a component of their marketing program to get as many renews as possible by making it difficult to get rid of the darn thing. I will try it eventually, but for now I'll live with what may be the lesser of two evils. 
And since Windows is the widest used OS out there I no longer blame them by default. Certainly webroot designed their program with Windows at the top their 'must-work-with' list. 
So I'll just enjot this beautiful Sunday, Mother's Day, and not get tangled up with this machine today.
See ya, enjoy the day.
Userlevel 7
I am not a Webroot employee, but in my work life I have worked with AV software for the last 15 years.  Webroot has, in my experience, been consistantly the easiest to remove and least intrusive of any AV I have dealt with.
Obviously extenuating circumstances do sometimes happen which can make things more difficult, but that is not the norm and is certainly not done by intent of Webroot.
When you are ready and have the time to troubleshoot the uninstall, let us know.  I am not the best in this area but we do have some members here who excell at this, or you can file a Trouble Ticket with Webroot Support as well. 
The Ticket option would also help Webroot identify what went wrong with the removal so that the issue canpossibly be addressed and fixed to help avoid such problems in the future.
Userlevel 7
Hi webrooted
I have to say that what you are reporting is so alien to me in terms of uninstalling WSA that I am gobsmacked.  David's suggestions are very sound advice and I for one will be very interested to find out what it takes to uninstall WSA for your laptop, as and when you get Support in to have a look/advise.
One question though; what other security-related apps do you run, if any, as I cannot help but feel that there is something conflictiing with the uninstall process, given what I said above about never, ever having heard of this, and certainly never seen the "wrsa.exe is trying to make change to your hard drive" message that you have reported.
Also, have you tried all the advice provided earlier in the thread, to the original OP, i.e., using the Commandline or Run Dialog option: "C:Program FilesWebrootWRSA.exe" –uninstall , making sure that it is run in an elevated Command Prompt/Run as Administrator? (apologies if you have and I have missed it). 
Thanks for the help, but I have not attempted to uninstall the program. Today was the closest I got and before I could continue/confirm the uninstall a window popped up stating -- erroneously, as I hadn't even uninstalled it yet -- uninstall was unsuccessful. I took that as a warning : /
Anywho I am running Windows Defender, maybe that's the problem. I'll shut it down and try again.  Ha, ha, ha. Can't help but laugh about this stuff. Computers . . . Great when they do what you want them to do, but then again, that could get boring.
Keep ya posted, thanks again.
Userlevel 7
Hi webrooted
Well, you can try the commandline command that I noted in my previous post, and in case you have not seen this previous thread on the same subject have a scan as it might give you some further pointers that may help.
With regard to the running of Windows Defender there should be no issue with running both together not that you need to...I have turned it off (Please see this thread for more information on this topic that may be of help to you).
Having said all of that I am wondering if what has happened is that WSA is either not properly installed or has been and then uninstalled as generally WIndows Defender gets disabled when WSA is installed and if you are saying theat Windows Defender is active then....?  Have you checked that you have an option to uninstall WSA under Add/Remove Programs, etc.?
Have to say that something about all of this does not ring true but I cannot at present figure out what it is.  Will keep reviewing a few older threads as there is definitvely something I have come across before re. this.
Userlevel 7
That bit about computers is the most on point and true thing posted today IMHO  :)
Ok, this is really intriguing. Like I said, I pretty much gave up on getting rid of that annoying pop-up window with the "wrsa.exe wants to mess with your hardrive" message. I could live with it so I didn't feel like pushing my luck. One day - I think it was Tuesday  - I was given two choices when I tried to shutdown - update my computer and close, or update and restart. I chose update and close.
Next day when I started my laptop it completed updating and lo and behold that wrsa window never appeared. It hasn't appeared since (although the software-webroot secure-still shows that little see-through window that fades quickly, and still acts like it's working, at least on start-up. It does a quick scan and says no infections found. Ot it makes believe it's doing a scan. 
So I guess it was some kinda Windows 8.1 glitch that was fixed with the update. As for trying to uninstall webroot, I'm leaving well enough alone.
So that's the tale. Weird huh?
Have a great weekend, beautiful weather so far.
And thanks again for the help.
Userlevel 6
Hang in there webrooted! I love your comment:
Can't help but laugh about this stuff. Computers . . . Great when they do what you want them to do, but then again, that could get boring.
Oh I could say something here but I'd get in trouble with my wife and some of our wonderful members! Enjoy your weekend!!;)
Hi all, just wanted to update y'all. It's still installed, but that's ok. It finally stopped working exactly two months after the initial expiration date. No more annoying pop-up warning though, just the little window lower right that shows all red Xs next to the functions that no longer work now and fades quickly away after startup and log in. 
I hope I don't have another problem wiht the AVG software I downloaded. Heh, heh. Ya gets what ya pay for. Take care folks.