Webroot causing software to hang in Windows 7

  • 13 January 2017
  • 74 replies

Userlevel 3
Badge +9
I've recently been having a lot of hassle with Webroot causing my Windows 7 PC to hang/lock-up when I exit my preferred games software (CMx titles from Battlefront.com). 
All of the titles are now allowed in my Webroot settings (which had cured earlier incidences of the problem with a single title), yet the problem now persists with all of them.  When I exit the game the software hangs, Ctrl,Alt & Del allows me to end the task, but the game .exe remains visible in task manager.  Taskkill commands fail as they do not see a running instance of the .exe despite it being visible in Tasklist.
Reliablility and non interference with my gaming was why I switched to Webroot in the first place and as my licenses are due for renewal soon, it's likely to be why I switch again unless someone can point me toward a cure for this irritating issue.
In hope, all the best
Andy S.

74 replies

Userlevel 7
Badge +52
The best thing to do is to Open a Support Ticketand ask Webroot Support to take a look  this for you.  There is no charge for this if you are a WSA license holder, with a current subscription.
And check these settings
Please have a look here at this PC User Guide articles that can help you

Controlling active processes
Blocking/Allowing files
Managing protected applications
Managing active connections
Userlevel 5
Badge +16
I'm in the process of looking into the case internally. Once I've made a determination regarding the issues raised on way or another I'll update this thread.

Userlevel 7
@ wrote:
I'm in a similar position.....Waiting for a reply to my support ticket. 
Not sure how much more I can add unless you want some specific files?  The software in question is all 'allowed' in Webroot's permissions, yet if Webroot is turned on they ALL crash my system on exit.  If Webroot is disabled they work perfectly, just as they always used to.
As I said earlier I switched to Webroot (or PrevX as it was known when it worked properly) precisely because it did not cause these sorts of stupid issues.....Things have been going down hill severely on this front since the merger and frankly I'm losing patience with it.
PS - Your emoticons suck too.
Much appreciated, @.
@, our Team responded to your inquiry yesterday requesting more information from your System. You will need to download and run the log utility they sent you so they can further diagnose this issue further for you.
P.S. — sorry you're not a Fan:catsad:
squarehead666 wrote:I switched to Webroot (or PrevX as it was known when it worked properly) precisely because it did not cause these sorts of stupid issues.....Things have been going down hill severely on this front since the merger and frankly I'm losing patience with it.
Interesting to find someone who has had negative experience of Webroot SecureAnywhere in relation to Prevx (its predecessor).
Whilst it is true that I am not a fan of most of the bells and whistles that come with Webroot SecureAnywhere , and also that in the past I had loads of frustration with the Web Filter Browser Extensions (now thankfully very much a past negative experience), this is really the first time I have ever seen someone complain about Webroot SecureAnywhere as an anti-malware going downhill in relation to its predecessor Prevx. All other comparisons I have seen and heard have been only positive as regards to the evolution from Prevx to Webroot. What is more, I understand that Webroot SecureAnywhere is particularly popular among gamers.
I will therefore be extremely interested to see what Support come up with when they analyse your logs.. What you are experiencing should definitely not be happening! I believe Support should be able to resolve your problems.
EDIT: It may be helpful to add, for information, that I also was a user of Prevx (for about five years) and have been a user of Webroot for just over five years.
Userlevel 7
@ wrote:
Looks like the problem is resolved.....Your tech guys are great once contact is finally established.
I do sincerely apologize for the inconvenience you had getting in contact, but I'm very glad knowing they straightened it out.

@ wrote:
TBH I never had cause to contact PrevX support.....In the entire time I used it, it never played up once.
I didn't get a personalised call at all, I had to chase Webroot round a virtual mulberry-bush to make contact.
Once contact was established Vinnie (not sure I'm spelling that correctly), the fella who dealt with my call, was amazingly patient and helpful.....Apparently Webroot was monitoring some 'new files' and they have now been whitelisted.
I've posted on the Battlefront forum in the hope that other Webroot Users/CMx Gamers can benefit from my experience.....In the process I discovered an essentially identical post from 2014 that my previous searches had failed to find!
All's well that ends well as thay say.
If it's true that they said that they were going to phone you, that's not good. You really should give them feedback on this. No-one should have a Support experience like that.
So now I understand what the problem is and it could happen again. This is because of the way Prevx/Webroot Secure Anywhere is designed. As you may already know, Prevx/Webroot is a bit unique inasmuch as it classifies files not only into good [g] and bad [b] but also unknown [u] when a new file appears and they do not yet have enough information to say whether it is good or bad. The unknown [u] files are monitored and their activity journaled (so that if they are subsequently found to be malicious all malicious actions can be rolled back). This is one of the things that makes Prevx/Webroot unique.
It seems that a new version of Battlefront had unknown [u] files and that the journaling of those files was messing up your computer when you closed down Battlefront. This may happen with subsequent new versions of Battlefront games. If it does, you need to contact Support and ask for those files to be whitelisted.
How do you know which Battlefront files are unknown [u] and therefore being journaled? Right-click on the Webroot icon in the taskbar and select Save a scan log. The last scan log will then open and at the top of the log will be a list of all unknown files. You will be able to detect which are Battlefront files by examining their location.
To get these files whitelisted you need to do a copy and paste of these files to a Support message and ask Webroot to whitelist them.
Having said that, this behaviour (your computer crashing) should not be happening in the first place!!!  Did Vinnie deal with that problem as well or did s/he just whitelist your unknown files? If you write to Support to give them feedback, you should query whether this second problem (computer crashing when Battlefront is closed down due to new unknown [u] Battlefront files that are being monitored by Webroot) has been fixed and if not ask that they deal with it pronto (as you say they promised to previously by saying they would phone you)! As I said, this should NOT happen!!!
Hope that helps!!
Keep us posted ;)
@ wrote:
Cheers Keith,
That's by far the most comprehensive and helpful information on this subject I've received to date.....I'll take your advice onboard and follow up.  I'd already advised tech support that I thought we'd be doing this again in a month or so as another major update is imminent for one of the titles.
All the best
Andy S.
Glad to hear my advice helped. Thanks!
By the way, you can also check which files are at any particular moment being journaled by double-clicking on the Webroot icon in the taskbar to open up the Webroot GUI window, then clicking the cog icon to the right of the "Utilities" tab, then clicking the "System Control" tab and finally clicking the "Start" button underneath "Control Active Processes". You will now be able to see which Active Processes are being "Monitored" at that particular moment (as well as those that are being Allowed and those -- if any -- that are being Blocked).
Hope that also helps.
Userlevel 2
Andy, Robert, thank you for suggestion.

If I don't get an answer in the next 2 days I will call back following your suggestion (I'm in Italy).
Userlevel 7
@, I do sincerely apologize for all of the inconvenience you've had.

I've re-opened the support ticket on your behalf to help expedite the process. In the future, sending our Team a support ticket is the most sure way to get the Support you need in a timely manner.
Userlevel 7
I've brought this to the attention of our Threat Research Team.

I'll do everything I can to keep facilitating this communication.
Userlevel 7
While I understand the frustration this is causing you, it doesn't really help the process to post publicly the response that our Support Team shared. There has been confusion and miscommunication, I will continue to be apologetic about that.

As stated in my prior post, I'm having our Threat Team look into this and I would sincerely your patience before sharing their findings.
Userlevel 7
Hi squarehead666
Thanks for the reply.
Well, whilst I appreciate your position I think that it is best that you await a reply to your support ticket (please do not update it to ask where things are with a reply...any update just pushes it to the back of the queue). I will ping @ to see if he can investigate where yo are in the queue and when you should expect a response.
Having said that this issue must be solely related to Windows 7 as I started with PrevX (in fact an alpha & beta tester back in the day for PrevX 4 which was never released as Webroot bought the company) and then naturally moved to WSA...and have never looked back with WSA being streets ahead of PrevX 3 (naturally enough) in terms of protection, etc. & I have never suffered these issues under Windows 7, nor in Windows 10, but then again WSA has moved on since then.
Best approach is to await the Support perspective on this...but do come back here if that continues to take time to happen, and we can see if there is anything we can do to help.
Regards, Baldrick
PS. Emoticons are not in the province of Webroot to change unless they change what powers the Community at present. ;)
Userlevel 7
@ wrote:
There have been comments about 'odd interactions' between Webroot and the Battlefront games on their forum.....It's a comparatively recent development (last twelve months AFAIK), but it's damned infuriating as it totally locks my system up and requires a power off every time it happens (which is every time I use the games unless I shut Webroot down).
This is only an issue with the Battlefront games, it's fine with Steam, Origin etc.
Please bring this to the attention of our Technical Support Team so they can address the issue for all Battlefront users:
Support Number: 1-866-612-4227 M-F 7am?6pm MT
Send us a Support Ticket: https://detail.webrootanywhere.com/servicewelcome.asp
@ wrote:
Looks like the problem is resolved.....Your tech guys are great once contact is finally established.
Glad to hear that the problem has been resolved!
Yes, I'm afraid that Webroot Support are not as superlative as Prevx used to be but that was always going to be an extremely difficult target to equal/excel as (at least from my experience) Prevx Support was the most amazing Support I have ever encountered from any company in my entire 66-year life. Period. Having said that, it is not good that you were kept waiting so long nor, as you put it, that their right hand didn't know what their left hand was doing. I can understand your frustration!
But also as you say, once they get down to business, they do a bl**dy good job!
Maybe you should get back to them to point out: 1. how happy you were with the way they resolved your problem. 2. your frustration and disappointment regarding the communication problems you have described to us in this thread. It is a pity this happened to you and if you give them feedback, maybe it will help them to improve in the future.
Also, can you let us know, for future reference, what the underlying problem was that was causing your computer to crash when closing your Battlefront game? Whether it has been resolved for all Battlefront games users and not just for you? And whether you did get a personalised phone call to resolve the issue, as promised? And out of sheer curiosity (if you know), who was the engineer who addressed your issue?
Hi lucam...Not sure where you are located but last week I placed a call to them a minute after they opened for business. Its only an hour time difference between Colorado and California. The early bird catches the worm so if its convenient,
call them early to avoid the wait time. They answered after the third ring.8)
Please see my comment here.
And please, please DON'T phone. Use the email Support link I refer to above.
@ wrote:
Why exactly does Webroot lock my system up?
It shouldn't, ever, to my knowledge (To reassure you, I regularly experience Webroot journaling, i.e. monitoring, new files on my three computers, indeed I have one being currently journaled on the computer on which I am writing this message, but I've never ever [yet] had the same behaviour you're currently encountering. And I've been using Prevx->WSA since 2006). As I said, this issue should be escalated.
@ wrote:
The issue with my new game seems to have gone away all of it's own too, which is rather odd, but I'm calling it a result.....I've got a Support Ticket ongoing so we'll see what develops.
Moved my response to your above comment to this thread as that comment was in the inappropriate thread.
The issue has probably gone away as the new files have been whitelisted by Webroot. (You can check this in UtilitiesSystem ControlControl Active Processes and verify if the files, when your game is open, are being "Monitored" -not whitelisted- or "Allowed" -whitelisted-) If that is the reason why, the problem has not yet been resolved as next time a new version is introduced, you risk having the same problem recur. So make sure Support actually gets to the bottom of why the "Monitoring" of new Battlefront files was causing your computer to crash.
@ wrote:
Totally agree that wall to wall whitelisting is not a solution.....It's a cop out.
Whitelisting = good because it is the Webroot malware database signalling to the local Webroot AV engine on your device that the Battlefront files are now trusted not to be malware. So the fact that the files have been whitelisted shows that Webroot is doing the job it's designed to do. That in itself is good NOT bad.
Whitelisting ? enough in your case as, for some reason, there is some kind of conflict going on between Webroot and your Battlefront game software (I presume) when Webroot is monitoring Battlefront files. Webroot needs to get to the bottom of this.
Userlevel 7
@, this is the response our Team most recently sent:

We have reviewed the Webroot logs, that are automatically uploaded to us by this ticketing system and there were quite a few files running on your computer that had not yet been classified in our determination database.

When Webroot detects unclassified files and processes it will monitor these files for malicious behavior.
It will also journal any changes made by the files so that when the files are eventually classified and if they are classified as bad the changes can be rolled back.
This is the information that fills up the folder.

After analyzing your logs, we have white-listed (classified as good) the unknown processes which SecureAnywhere had been monitoring on your system.

You can go ahead and run a new scan of your computer now to update. (click "Scan My Computer" in the Overview window of SecureAnywhere).

This should resolve the issue.
Userlevel 7
Hi squarehead666
You know the drill...to get files whitelisted in the Webroot Cloud you need to open a support ticket to advise the Support Team of your requirement.
Regards, Baldrick
Userlevel 3
Badge +9
I think your definition of 'solved' is a bit looser than mine mate.
Userlevel 3
Badge +9
Having communication issues with tech support at the moment.....I don't think they have quite grasped that I'm in the UK.
For some reason your UK tech-support call centre is closed at 11:35am GMT.....I thought I was a late starter in the morning!
@ wrote:
There have been comments about 'odd interactions' between Webroot and the Battlefront games on their forum.....It's a comparatively recent development (last twelve months AFAIK), but it's damned infuriating as it totally locks my system up and requires a power off every time it happens (which is every time I use the games unless I shut Webroot down).
This is only an issue with the Battlefront games, it's fine with Steam, Origin etc.
Thanks for this further information. Clearly it is something that must be fixed.
Have you sent them your logs? Obviously, this will be important to allow Webroot to resolve the problem for you and for other Battlefront games users.
Keep us posted 😃
@ wrote:
Logs were sent yesterday, I was advised that tech support want to deal with it over the phone.....Been attempting to make contact with them ever since.
They claim to have called me, but my phone did not ring.  I called them (the UK number) and was connected to a very nice and very American robot which politely informed me that the tech support centre was closed.
Quality stuff.
True, that's not the same as Prevx used to be. Then again, almost every time I had dealings with Prevx Support it would be an understatement even to say I was completely blown away by the incredible quality and sheer bullet-speed of their response. I repeat, almost every time I had dealings with Support, I literally couldn't believe what I was seeing, it was so superlative. That said, on the whole I find Webroot Support to be very good.
By the way, I presume you converted your phone number to international format, i.e. +44 for the UK (Note: from the US, the international code is not "00" as it is throughout Europe and indeed most of the world 😠, which is why you should put "+" and not "00") and then dropped the zero at the beginning of your number?