WSA Uninstall / Reinstall Issues on Windows 10 Desktop

  • 14 January 2021
  • 3 replies

On Windows 10 Home machine running in Normal mode (old Dell desktop that had had WSA running well for years) , having difficulties even while logged on as Administrator in (1) uninstalling WSA or, then, (2) installing latest version; also cannot Turn On WSA as a Security Provider (Windows Defender on and ); 3 machine license still good, now only 2 of the 3 in use (the 3rd having been the Dell).

Seems Windows 10 is not recognizing the (local account) user as an Administrator, even though the user is an Administrator; also, when Windows 10 pops up a window asking “Do you want to allow this app to make changes to your device? “, nothing happens if “Yes” is answered; also, tried Control Panel → Programs → Programs and Features to uninstall but message pops up to say “it is necessary to log in as an administrator to use this feature” - again, user is a (local account) administrator.

Any suggestions? Is this perhaps a Windows 10 Home issue?  (latest update 2020-12)


Best answer by TripleHelix 15 January 2021, 00:55

View original

3 replies

Userlevel 7
Badge +63

Hello @George652 


Try again in Safe Mode with Networking to see if that helps.



Followed your advice (though still needed to manually start WiFi, there being no physical cable connection to the WiFi access point / "router" to the Internet).

Ran the earlier downloaded executable although all installation work evidently occurred in the background - BUT none of those pesky messages appeared saying the user needed to be an administrator (which he was) .

Popup window came to give hope things were going well (and then vanished).

A persistent popup window stated "WEBROOT Web Threat Shield Settings" along with the keycode (I was prompted to supply a few minutes earlier) as well as the number of days left in the subscription - very encouraging!

Interestingly, while in Safe (with Networking) mode, could not display any of the Settings -> Update and Security -> Windows Security information, i.e., none of the "Protection areas" appeared on the screen under "Windows Security".

Then restarted in "Normal" mode.

Then, the "Windows Security" "Protection Areas" appeared and in particular noted - this was the goal - that "Microsoft Defender Antivirus is turned off" and "Webroot SecureAnywhere is turned on", but (of course!?) both were done in the background without any intervention on my part.

Performed a WSA Full Scan of the Dell desktop (that took 45 minutes to scan over 100,000 files). Then did a WSA Scan logged in as a different (administrator type) of user - quicker this time (as I believe it was meant to be).

So all seems well (and this problem being solved can go on to fix something else, a Windows 10 issue)!

Thank you for your advice. I am grateful and just regret not keeping a meticulous log of all I did and all that the Dell desktop responded with.

Thank you again.

Userlevel 7
Badge +63

Well good to hear it’s sorted and if you continue to see issues please Submit a Support Ticket and they will look into it closer for you.