6 hours with Microsoft support to find out Webroot blocks Excel registry changes

  • 5 August 2018
  • 5 replies

Userlevel 1
This is probably the last place someone with this problem will look, but I've just gone through Hell trying to install Microsoft Office 2016.  I turns out that even when responding Yes to allow the install to make changes to the computer, Webroot prevents any changes to Excel's registry entries and doesn't inform you that it blocked the changes needed in the install.  This prevents Excel being set up as an app associated with .xls and .xlsx file extensions so, while calling Excel directly, you can open spreadsheets and save new ones, but you cannot open those files directly and have Windows 10 recogise it is associated to Excel--you get an error saying there is no default program for that type of file.  Six hours of Microsoft support (no exageration) later, reinstalling Office, repairing Windows, etc., etc. we finally disabled Webroot and voila, Excel can now be assigned as the app for these file types.  It would be nice if Webroot informed you when it blocks a registry or associated app change from taking place.  It even blocked changing the registry directly through regedit!.  So what does "Allow xxx to make changes to your computer" Yes actually do?

5 replies

Userlevel 7
Badge +63
Hello and Welcome to the Webroot Community!
I have never seen that issue with Office 2016 Pro Plus installed on 3 of my systems and all fully updated so could you please Submit a Support Ticket and ask them to look into it.
Userlevel 7
Badge +62
Hello @,
Welcome to the Webroot Community.
Sorry to hear of these issues.
But I am running Microsoft Office on 3 systems. Which one is on a Mac. I also have not or ever had any issues running this program (Microsoft Office) with Webroot on all of my systems.
Userlevel 1
This was a very obscure problem.  Office Home and Student 2016 appeared to install correctly (about 6 or 7 times during various attempts after a number of uninstalls, repairs, incense burning and animal sacrifices) and Word had no problems at all.  Excel also worked just fine, as long as you called it directly.  If you just tried to open any .xls or .xlsx type files however you would get the "...no default application..." error message. No method of assigning Excel as an app to those file types worked or even appeared to remain in force following the attempted assignment.  This was true even trying direct registry modifications (regedit)!  I have 35 years experience in IT myself and was working directly with levels 1, 2, and 3 Microsoft technical support both over the phone and with webshare over a five day period.   
Given the history of malware attacks through Excel and other macros, among other methods, I can see blocking changes to Excel registration could possibly be a viable method to block those types of infections.  I wouldn't think that would apply to the initial install of the program, however.  Anyway, enough information; the problems immediately and permanently disappeared when Webroot was temporarily disabled.  Once the default app was successfully assigned to spreadsheet type files, enabling Webroot did not prevent successfully opening any of those file types into Excel.  Given I was on the verge of backing up and reimaging the entire machine from scratch, this is a great outcome.
In my experience Webroot is a very good product which has a number of advantages (like a small footprint, reliability, reasonable cost...), this is just an obscure "feature" of the software which I would not be surprised will not be replicatable by technicians.   If it weren't for things like this, the world would be overrun with unemployed tech support analysts.
Badge +3
I'm having this exact issue on Windows Server. If I disable webroot and run a repair on Office, the files are re associated. Any fix for this?
Badge +1

I am having a similar issue, excel was working normally now when a user double clicks on an xls file excel opens but the file is not.  This is with excel 2007