Can't uninstall Webroot (WRSVC gives access denied)

  • 19 June 2021
  • 4 replies

Today, Webroot CPU usage and memory spiked to 75 and 90 percent making my PC unusable. I rebooted and it got worse. I can only have 1 tab open in my browser at a time now or 1 app open. I tried everything to get rid of it and it’s only taking up more CPU and memory. Please help. 

Things I’ve tried:

Uninstalling via Control Panel : this launches the uninstaller, but doesn't actually do anything.

Running "C:\Program Files (x86)\Webroot\WRSA.exe" –uninstall: Same behavior as above.

Running "C:\Program Files (x86)\Webroot\WRSA.exe" –uninstall in safe modeThis actually launched the install process asking for a valid key?

Deleting "C:\Program Files (x86)\Webroot\" : says WRSA.exe is in use so it won't delete. Tried this in Safe Mode also.

Killing WRSA.exe with Process Explorer AS ADMINaccess denied error.

Terminating WRSA.exe with Process Hacker

Running a Webroot uninstall script


Best answer by TripleHelix 20 June 2021, 18:25

View original

4 replies

Memory goes between 50% to 90%

I have 16 GB of RAM and an i7 Intel Processor 

Userlevel 7
Badge +63

Hello @Overpowered 


Webroot’s Processes are protected so malware can shut it down or delete it.


For the Consumers version the use this one:


"C:\Program Files\Webroot\WRSA.exe" -uninstall





If it doesn’t work in normal mode try in Safe Mode with Networking!


And if you need to do a clean reinstall?


Please follow the steps closely!

  • Make sure you have a copy of your 20 Character Alphanumeric Keycode! Example: SA69-AAAA-A783-DE78-XXXX
  • Be sure you add your Keycode to your Online Console: Webroot SecureAnywhere Online Console
  • KEEP the computer online for Uninstall and Reinstall to make sure it works correctly
  • Download a Copy Here (Best Buy Geek Squad Subscription PC users click HERE) Let us know if it is the Mac version you need
  • Uninstall WSA and Reboot
  • Go into Safe Mode and Delete these Folders if they are there!
  • C:\Program Files\Webroot Folder
  • C:\ProgramData\WRData Folder (Hidden Folder)
  • C:\ProgramData\WRCore Folder (Hidden Folder)
  • Boot back into normal mode
  • Install with the new installer, enter your Keycode
  • Let it finish it's install scan
  • Reboot once again
  • DO NOT import any old settings as you can set it up as you like once it's done

Info in case you don’t know how to go into Safe Mode:


Please let us know if that resolves your issue?


I did that and it said it uninstalled but the background process is still running...

Userlevel 7
Badge +63

I did that and it said it uninstalled but the background process is still running...

At this time it’s best to Contact Webroot Support because they have other tools to help you that we don’t have access to.


Webroot Support:

Submit a ticket

To call: Mon - Fri 7 AM to 5:30 PM (MDT)

Call 1-866-612-4227