Cannot get Support to respond to my requests

I have tried for over a week to get Webroot Support to respond to my problem. Its been about a a year since using the web console, and I am unable to recall the security code. Our owner has decided that if Webroot will not respond, we need to cancel our subscription and remove the software. 


However, it appears you need to get to the web console to remove the Webroot software from each PC. Anyone know how to a) get Support to respond to tickets submitted (5 times in the last week), and b) delete Webroot account if you can’t log into the web console?


Best answer by khumphrey 11 May 2020, 22:06

View original

6 replies

Evidently, Webroot Support either is shut down due to the COVID-19 pandemic, or they don’t value helping their customers. Very disappointing.

Userlevel 7
Badge +63

Hello @fgswaterloo 


We Mods are just Volunteers so I will ping a couple of Webroot Community Staff but you might not get a reply until tomorrow sometime @khumphrey  @freydrew 



Thank you for trying to help.. I have been waiting over a week to my direct replies to Webroot Tech Support, and have not received anything. So I thought I’d try seeking out help here. 


Appreciate it!

Userlevel 7
Badge +20

@fgswaterloo ,

It sounds like you submitted a ticket 5 times in a week which is why it’s taken so long for you to hear anything. Every time you send a new ticket from the same e-mail, it pushes you to the end of the queue again. In the future, please refrain from sending in multiple tickets as it only extends the time it takes to respond.


Can you please Private Message (do not post here) me with the e-mail you used to send the ticket so I can check on it for you? thanks!



if you only submit one ticket about how long does it take to get a response. it seems my webroot wont uninstall and i need sudo commands to get it fixed . already went to best buy and geek squad. i have been at this since i woke up this morning.  what happened ill explain yet again just so your up to speed. i looked onto my computer this morning. and to my surprise i couldnt find webroot any where on my mac. so thinkiing my subscription ran out. i went on the webroot website and purchased a new one for 59.99. so i can have my wife have it too on her mac since her is gone as well. so i went to go and install it and got it to save. i clicked on it  to open it up but couldnt do anything else after tht. not one prompt came up to type in the new subscription key. so i called best buy and geek squad. they were really nice and tried to help me out for over 4 hours. but unfortunately  they couldnt do anything for me. they said they would need the proper sudo commands to help me out for which you will not give them. why not they sell your product but you wont let them help you fix the obvious issues you are having with the software? that puts you in a very bad light in my opinion that all you care about is money plain and simple. right now as i am typing this i have been on hold with your tech support for about 20 mins now and the automated system said it would be an avg wait time of over 55 mins.  this to me is not acceptable. this tells me that this is system wide as far as incompatibility. i did put a ticket in just one and the ticket is under the email address. if you would like to speed up the ticket 

Userlevel 7
Badge +20

@dfsbrat ,

I’m sorry that you’re having so much trouble right now! If you’re already on hold, then there’s really no point in having me go to support to ask about your ticket. Generally the wait time on tickets is 24-48 hours so if you only submitted it today, then you will normally not have a response this quick. Please give us an update once you get ahold of them on the phone!