I'm here...and unhappy!

  • 20 January 2013
  • 24 replies

Userlevel 2
Frankly, after terribad experiences at Microsoft Answers and T-Mobile's community forums, both of which were "kudos forums", I promised myself I would never, ever actively join another "kudos forum" again. I told TH this. Well...the fact that I'm here shows you how desperate I am for a solution.
I am aware, thanks to TH (very appreciative for that generous man), that some of the mods/admins on here know of my situation. I'm the guy that decided to use Backup & Sync two weeks ago, and still can't, courtesy of some weird database issue.
I finally got in touch with an Escalation Engineer, and now it's the weekend. So apparently he's off. Joe, who normally is "the problem solver", is traveling. He's a busy guy now. I get that.
Unfortunately, I'm about out of patience. I'm sick of this.
If I have to bite the bullet and uninstall Windows Live Mesh and move on to SkyDrive, I will. But good lord just tell me now. As much as I don't want to use another trendy new, Windows 8-pushy product on my Windows 7 machine that will likely take 3x as much RAM as Webroot does (and all it does is sync files), at least Microsoft can get me logged in and running.
So, if there is anything that anyone here can do for me this weekend, I'd appreciate it. Maybe a temporary license key that I can use to sync files until the E.E. gets back? I don't know. Because I'm about ready to ask for my 3 licenses to be burned and turned into AV only licenses.

Best answer by STV0726 27 January 2013, 22:11

View original

24 replies

Userlevel 7
Badge +56
Hello STV0726 and Welcome to the Webroot Community Forums.
I glad that you have joined, this community is fantastic and very helpful if you have any Ideas you can add them to the https:///t5/Ideas-Exchange/idb-p/Ideasand even check some of out and Kudo them if you like any as there are many Webroot Staff members here and they keep an eye on all suggestions!
Good to have here from Wilders Cheers Buddy,
Daniel 😉
Userlevel 2
Thank you, sir!
I do sincerely wish I could be here on a happier note.
FYI, I tried making another user within my console and that doesn't seem to help.
I will also add that despite reinstalling completely with the special step of ensuring the program data was deleted, the WSA on my desktop still is confused. Whenever I hit Access My Web Console, it takes me to a registration screen instead of logging in.
Very frustrating. I just want to sync some files! T_T
Userlevel 7
Regarding the Console: Instead of Access My Web Console, click the My Account tab at the top, and then the "Manage My Account Online" link.  The Access My Web Console does the same to me that it does to you.
Welcome to the Forums!  I hope your situation is resolved!
Userlevel 7
Badge +56
As https:///t5/user/viewprofilepage/user-id/140 said via PM it's in the Escalation Engineers hands now and they will get you sorted during the week. Also https:///t5/user/viewprofilepage/user-id/1016should be online tomorrow around 1:00pm EST.
Userlevel 7
Hello STV0726, Welcome to the Webroot Community Forum. 😃
Userlevel 2
Thanks ProTruckDriver...
 @TH: Is MikeR an admin with capabilities to do escalation tasks? And I am almost positive the Escalation Engineers also have this Monday off for Martin Luther King day right?
Userlevel 7
Badge +56
@ wrote:
Thanks ProTruckDriver...
@: Is MikeR an admin with capabilities to do escalation tasks? And I am almost positive the Escalation Engineers also have this Monday off for Martin Luther King day right?
All I know as you said it's in the Escalation Engineers hands and Kit said it will stay there but Mike will be able to look at your ticket but the Holiday I'm not sure as I live in Canada so look in around 1:00pm EST today to see if Mike is online. Maybe someone from the US can comment on the Holiday?
Userlevel 7
@ wrote:
@ wrote:
Thanks ProTruckDriver...
@: Is MikeR an admin with capabilities to do escalation tasks? And I am almost positive the Escalation Engineers also have this Monday off for Martin Luther King day right?
All I know as you said it's in the Escalation Engineers hands and Kit said it will stay there but Mike will be able to look at your ticket but the Holiday I'm not sure as I live in Canada so look in around 1:00pm EST today to see if Mike is online. Maybe someone from the US can comment on the Holiday?
I asked a question a week or so ago about holiday hours https:///t5/Community-Guidelines-please-read/Holiday-Hours/m-p/21408#M34. Based on this, I know the forums will be staffed and I can only assume that webroot will be operating as normal.
Userlevel 7
We will be staffed tomorrow and the Escalation Engineer will be able to continue working with you.
Userlevel 2
Hello Mike,
Can you do me a HUGE favor and take a look at my Support Tickets?
In a frantic/panic state after hearing some negative words about Backup & Sync, I asked Support to downgrade my licenses as well as do a couple other things (which those other things can still be done), but I now have immediately changed my mind.
I sent them another ticket saying to please "CANCEL AND DISREGARD" my last ticket. I hope this does NOT cause any confusion/mix-up. I apologize for this back and forth.
Essentially what happened is, I have reached the pinacle of frustration with waiting for this to work, so I decided to forget it and use the successor of Windows Live Mesh (a relatively good product that Microsoft is killing), SkyDrive (a very stupid product). Now that I know SkyDrive is a joke and would change my conventions and how I sync files on my PCs, I realize Webroot Backup & Sync is my only hope.
Thank you.
Userlevel 7
Your licenses will not be "downgraded" and I will speak to Lucas tomorrow to see what we can do about the merger of the other two. Do not worry, he will still take a look at your ticket tomorrow and will not take any action until he knows the entirety of your requests.
Userlevel 2
Thank you!
Ok he started working with me today at about 10:00 Central Time and I responded an hour and half later and now it's 2 PM and he hasn't responded again. Last time I communicated with him he stopped responding at about 3:30 PM Central Time.
How early work days do these Escalation Engineers have? If he can only respond once at that time that's going to be when I'm in class most of the time.
Anyway, his last response said that he wants to investigate if it is something specific to my computer blocking network traffic. I told him that I use almost identical configuration across all my Windows 7 PCs and my netbook's WSA is working fine.
I cannot think of anything else on my desktop that would block traffic. I use Windows Firewall of course but that's the same for my netbook PC.
Also, he wants me to download and install WireShark which I have never heard of before and frankly sounds quite complex. He wanted to setup a time and date to do a remote session. I told him if we could do it today that would be excellent, and if not, then if he could tell me how to use this bloomin' thing that would be awesome because as tech-saavy as I am, he wasn't real specific about what he wanted me to do with this thing.
And I'm not certain I like the idea of having a tool listen to network traffic as I send my user name and password through Webroot.
Very frustrated.
Userlevel 7
The Engineer wants to troubleshoot whether or not it is an issue where another process/program is interfering with the authentication which would cause the "Invalid username or password" message. You can continue to communicate through the support system and update the thread once you have had the remote session and once the Engineer has been able to use Wireshark to test the network traffic on your system.
Thank you for your patience. :D
Userlevel 2
Well here's the last thing I heard from Mr. Joe Jaroch today, ESE VP. He doesn't seem to be too on board with this line of troubleshooting.
"I'd write into the inbox clarifying what you're experiencing and that you shouldn't have to run a tool... I don't know what they'd try to run, but it should definitely just be something on the backend."
I mean, I'll do it, but my only complaint is that the Escalation Engineer (I'll just say EE from now on) told me to either try it myself and wasn't specific, and then he said or we could set up a remote session, and when I replied, he yielded no further responses. From observation, it seems the EEs have VERY short hours. 2 hour work day today? Or are there not enough EEs for the complaints they are dealing with?
I must say, that before I install any tool (i actually DID install this tool in a virtual environment and boy is it convoluted), especially a complex one that requires a para-program to be installed with it, I would like an EE or whomever to take a look at "the backend" and verify that nothing is corrupt with my account/license, because that seems to be equally or more likely to be the cause.
On my end, both my 2 PCs have identical configuration.
The ONLY thing that is plausible to have an impact here that filters inbound traffic is Windows Firewall, and come on, WSA is branded to be compatible with that. And, I have it set up the exact same way on both PCs, so how can it be that?
I think WireShark is a bit of an overkill. Nothing on my end filters traffic other than Windows Firewall and Webroot's Firewall.
So I would say to expedite this and solve this for me as quick as possible, an audit (is that the right word) of the backend is probably a good place to start.
Userlevel 7
He has checked the back end and so have other technicians. It is your choice if you would like to continue working with the engineer and I will take a fresh look at your ticket in the morning.
Userlevel 2
Okay then yes, I think we need to try something else if it s not the backend.
I'm still very skeptical that anything on my end is blocking the connection. I do make use of Software Restriction Policies and Authenticode (Trusted Publisher) settings on my desktop only but to test if that was the problem I logged on to my admin account, ran Webroot SecureAnywhere from the start menu as a UAC admin, and the issue still happened.
So I'm really skeptical about that.
Userlevel 7
The Escalation Engineer did not suspect an account issue or an issue on the back end because the credentials were working on one machine and not the other. This led him to believe that there were machine specific faults.
Feel free to update the thread once the logs are interpreted by the engineer and more conslucsive results are found.
Userlevel 2
Hi, I grow increasingly frustrated. Mr. Moore was unable to gather anything from the WireShark logs. I sent him more logs using that software. He still couldn't tell anything from those. I reluctantly agreed to do a remote session. After about an hour, he could not figure out the problem on my computer. He left with a SysInternals log which he is deciphering through and he said he would probably have to get back to me on Monday. He also left me with a Beta .98 to fresh install with since he said it removes some legacy SugarSync code. Well I did, and it solved the least I thought. It worked momentarily. Then, long story short, when I changed my preferences again (for like the 3rd bloomin' time these past two weeks) to the way I like them to be, it stopped working again. How can it be the way I configure Webroot that is causing this? I am just changing a few settings. Is your product incompatible with your own product? Again, my netbook, configured the same, works fine. I can't wait until Monday. I am sick of this back and forth. I want to sync my files now. Mr. Moore essentially said he is the only person doing this in the U.S. There's your problem. Hire more people.
Userlevel 2
Also, I forgot to mention that I hope he didn't close out my support ticket or mark it as resolved because I originally said it was finally working before I realized it was only to break again momentarily.
Userlevel 7
STV0726, I saw on Wilders that you were able to get the problem fixed. I am going to post the solution in case anybody else is following this issue and/or any future case similar to this:

Software Restriction Policy was blocking WRData DLLs needed for sync from being called on.

Workaround: Add exemption for ProgramData/WRData.
Userlevel 7
Thank you cohbraz for updating the thread, the support ticket has not been closed.
The issue was resolved with a clean install but recurred once STV0726 imported the old settings. The engineer will continue working with STV0726 tomorrow.
Userlevel 2
Nope, Cohbraz speaks the truth! Thank you for updating with what you saw on Wilders!
The issue is now official resolved and I have been using sync for over 12 hours now.
Mike, what you are referring to was the last time I posted thinking I found a solution, but then the issue came back (which ended up having nothing to do with importing configuration at all).
The resolution Cohbraz quoted was what I said at Wilders but I was very vague.
Essentially, I asked multiple times to verify WSA was compatible with Software Restriction Policies, which it is, and definitely ought to be, but there is a catch. WSA does something different than most programs. It needs to reference DLLs (executable code) from C:ProgramDataWRData. I actually don't think I've EVER experienced this before. Most programs that I install and whitelist into my computing environment are exempt from my restriction policies because they are installed in either Program Files or Program Files (x86) and that is where they reference their DLLs and execute their code from. WSA, however, has the main application there, but needs to call upon DLLs in a subfolder of the path I just described above called "PKG" for the Backup & Sync functionality specifically.
I was working with the very generous, extremely helpful, miracle man, Mr. Joe Jaroch, and on Saturday, we both discovered that when I was installing WSA fresh, it would work, but then as soon as I logged out and back in, regardless of account type, it would "break". Turns out, it wasn't breaking at all. It was working after install only because when you install something with typical UAC settings on Windows Vista/7, when a program runs immediately after install you are still elevated as an admin. WSA runs the core system processes as admin always of course, but the GUI runs as a standard user. Well, it would be most correct to say it runs with privileges of the current  user, but because of UAC's Admin Approval Mode, that pretty much means it is running as a standard user except WSA does have built-in code to check if you are an administrator account to grant you access if you use Access Control settings. I'm not entirely sure how they do that, but with all that aside, the GUI runs essentially as a standard user except when you first install it since you are pre-elevated then until you log out and back in. So once Joe and I discovered that, Joe had to go somewhere, but I figured I would try and exempt the WRData from my SRP after I saw DLLs in there. Surely, it immediately worked. That was the solution.
So, if you are experiencing this problem, well, you will have had to know how to set Software Restriction Policies because you'd only experience this if you used that. Using Windows 7 Parental Controls for whitelisting will not cause this issue because it does not block DLLs and other non-exe "but still executable code" like SRPs do. Furthermore, I shall make the assumption in these instructions that you know how to access Microsoft Management Console / Group Policy Editor / Local Security Policy / Computer Configuration / Windows Settings / Security Settings / Software Restriction Policy…
1. Expand "Software Restriction Policy"
2. Select "Additional Rules"
3. Context menu
4. Select "New Path Rule"
5. Browse to C:ProgramDataWRData (If you want to narrow it down even further for security purposes, you may be able to get away with: C:ProgramDataWRDataPKG but I have not tried that!)
6. Make sure it is set to "Unrestricted"
7. Type a description if you so choose
8. Hit "OK" and close out of Microsoft Management Console
That should solve the problem. Joe told me in his last e-mail that he is going to possibly look into making another dialogue box that indicates the program is being prevented from logging into the account by Software Restriction Policies, or at least find a more indicative way to communicate the error rather than just providing an invalid credentials box, since it doesn't matter what the dickens you type in there...if SRP is blocking the DLLs needed for Backup & Sync, you are not logging on to anything!
Thank you everyone for the support, and special thanks to TripleHelix, MikeR, and of course Joe! This issue is officially resolved.
Userlevel 7
Glad it was resolved. I was watching this closely here and on Wilders to see that the problem was. It was a very interesting issue.

Once again, I am glad it was resolved!
Userlevel 7
Thank you both for updating the thread and being patient.
This information will be useful for other readers. :D
This part is very interesting: "The GUI runs essentially as a standard user except when you first install it since you are pre-elevated then until you log out and back in."