password manager in firefox 40

pas word manager does not load in firefox 40

14 replies

Userlevel 7
Hello there, welcome to the Webroot Community!
You are not per chance using Firefox 40 as your browser?  If so then I am afraid that there are known issues related to the WSA extension & its use with the Mozilla browser. These are recent and Webroot Support is aware/is looking into resolving them as soon as is possible.  For more information the thread with most of it in can be found here.
Until the issue has been resolved by Webroot and Mozilla, keep in mind that both IE and Chrome browsers are still using the browser extensions for both the Web Filter and Password Manager without problem.
Webroot has submitted the required information to Mozilla to have this fixed, so the problem should be resolved very soon.
Some people have found that uninstalling WSA and re-installing it has helped, but not everyone.  Likewise, some have seemed to get it working, at least until the next computer reboot, but running the toolbarfix.exe utility.
Userlevel 7
Badge +56
The Webroot Password Manager is now posted on the Firefox Add-on site:
Daniel 😉
3.1.1. has been on that page since August 20th and when installed is still broken.
2.5.0 does work on current FF 40.0.2, albeit my account is still "deactivated" for some reason unknown even after my issue was resolved via phone support.
I idiotically then decided to update from 2.5.0 to 3.1.1 (does not work) then uninstalling and reinstalling using toolbarfix.exe. My initial problem returned to haunt me once again when trying to log into WPM 2.5.0 (toolbarfix.exe installs this version) with the dreaded red bar of death message, "your account has been deactivated".
/Facepalm self
Moral of story, DO NOT INSTALL/UPDATE to latest Webroot Password Manager 3.1.1. Stay on 2.5.0 until everything becomes ironed out and officially supported.
Userlevel 3
I think you are right! Unfortunately I have set automatic update (should I switch it to manual?!) and since the last update three days ago the password manager stopped working.

Yesterday I asked to the support desk too, but no answer yet.

BTW, also the Webroot filtering is giving problems that I didn't experience before: there is a video from a trusted site (a financial newspaper) that is flagged as dangerous and is thus blocked, but unblocking it's useless, I have to turn the filtering off in order to see the video!
Do you also have this problems?
Userlevel 7
I think we are all seeing the problems with both the Web Filter and the Password Manager in Firefox, though in IE and Chrome things are still working just fine.
Personally, I would keep the automatic update turned on, unless you are very proactive in checking for updates frequently.  It is just too easy to forget.  Yes, it is quite annoying at best if/when something like this happens, but we do have workarounds and issues like this are really quite rare.  If one was to set ALL programs to manual update ALL the time, (Which I used to do) it becomes impossible to really keep up with it all, and security software is the one thing that I think really should be automatic. 
As for the block of the video, which even unblocking fails to work, you might submit a Trouble Ticket on that one for Support to take a look at.  A couple of things they can do:
1) If the video is blocked incorrectly, they can reclassify it to remove that block
2) if there is a problem in which you unblocking should have worked, they can report that and work to get that fixed
3) give you more information about the why it is blocked.
Have patience on the Support getting back to you.  Normally I get a reply within just a couple of hours when I need to ask them something (About twice a year), but with the current FireFox add-on issue they are probably being hit a LOT harder than normal.  They will get back to you, but given the current situation I am not surprised the process is taking a bit longer.
I hope all this helps!
Userlevel 3
Thanks for your help David. I do agree with you.
In fact the reply from the support team arrived shortly after my previous post.
I am reporting the main part for the benefit of others:

Thank you for contacting Webroot. In order to address the issue you are having with your Webroot SecureAnywhere Toolbar add-on, we would like to have you uninstall the toolbar and then reinstall it.
To uninstall and reinstall the Webroot toolbar, follow the instructions below.
**Part 1: Use a utility to uninstall the Webroot SecureAnywhere Toolbar**
1. Download and save the Webroot Toolbar utility to your Desktop using this link:
2. Double-click the "toolbarfix.exe" file to launch the installer.
3. Select "Uninstall the Webroot Toolbar," and then click "Start."
4. Follow the prompts until the following message appears: "Process Completed. Click Finish to exit."
5. Click Finish.
The toolbar should now be removed from Firefox, Internet Explorer, and Google Chrome. Keep in mind: you may need to restart your browser to see the change.
** Part 2: Use a utility to install the Webroot SecureAnywhere Toolbar **
1. Navigate back to your Desktop.
2. Double-click the "toolbarfix.exe" file to launch the installer.
3. Select "Repair/Install the Webroot Toolbar," and then click "Start."
4. Follow the prompts until the following message appears: "Installation was successful. Please open your Internet Browser(s) and be sure to Enable/Allow the Webroot Toolbar if prompted."
5. Click "OK," then click "Finish."
The toolbar should now be installed in Firefox, Internet Explorer, and Google Chrome. (These are the only browsers supported at this time.) Keep in mind: you may need to restart your browser to begin using the toolbar. The toolbar is represented by a small gray W icon next to your search bar. Click on the gray W to log in to the toolbar. Once you log into your account, the W icon will turn green.

I have to say that this procedure didn't work exactly as described.
The tool completed correctly, but for some reasons, upon reopening Firefox, the bugged toolbar 3.1.1 was still there!
Therefore I removed it manually from FF (via the manage additional components tab), then re-executed toolbarfix. The remove part worked, but the install part failed to download the required files (?!). I tried rebooting and finally toolbarfix worked correctly and reopening the browser I find the old reliable 2.5.0 version of the toolbar :)

As for the other problem (the blocked video) I am going to submit the problem to the support team as you suggest.

--- Glauco
Userlevel 7
Badge +56
We've got an updated procedure to fix this now:
Userlevel 7
Badge +56
Thanks ? I suppose I should remove the one that is there before installing this one right?
Daniel 😉
Userlevel 7
Badge +56
yeah, remove the existing one to be safe.
Userlevel 7
Badge +56
Got it! ;)



Userlevel 7
Badge +56
Awesome - glad the new procedure is working.
Userlevel 3
Hello. I come back here because I noticed that no correction has come yet with the automatic updates. I have one machine, where I use the password manager, where I applied this repair, but the other two ones are still with the faulty version, after one month and a half, how comes it takes so long for correcting this thing?
Userlevel 7
I am not sure on this, but I THINK the fix for the issue needs changes in both Webroot AND Firefox.. so it will probably not be seen until a new version of Firefox comes out in which Webroot and Firefox have worked together to resolve it.
Hopefully we will see it soon!
Userlevel 7
Hi David!
The old version of the addon works just fine, as you've pointed out, and the new version does not work at all.
This means that it is what we fondly call a full failure defect in the newer version of the addon, rendering the new version completely unusable. Thus this is not at all related to Firefox, otherwise the old version would not work either.
However there is a possibility that the fact that LastPass has sold itself to LogMeIn* may be impacting the ability of Webroot to coordinate with LastPass to create a fixed version.
That being said, this is still a bad situation for anybody who relied on Webroot to provide a working password plugin on Firefox as the product markets itself as doing. Users should not have to jump trhough hoops to get the features and functionality they were told they were getting and paid for. Also, can't say that it's a Firefox won't approve the newer version quickly" situation because the newest version is not fully checked either.
Let's hope somebody at Webroot gets their act together and gets this fixed quickly. We'll be nearing a quarter of a year lacking a chunk of paid-for functionality for countless users.
(* )