The Yellow Lock on my WSA icon in the toolbar no longer appears

  • 17 December 2015
  • 21 replies

Userlevel 6
All of a sudden I have to reinstall or 'allow Webroot program to make changes' to my computer after I restart my computer after receiving a red X notice in my Windows Action Center that stated both my Windows and Webroot antivirus protection were turned off.
I have the Windows Firewall enabled but the Webroot Firewall doesn't shwo up in the Action Center Security section.  When I pull up my WSA window, it shows that the Firewall is on so I don't quite know what the problem is, but I am concerned and wondered if anyone else had this problem?
I have contacted Customer Support about it but i haven't heard back, so I was hoping someone might be able to tell me if this is something they have experienced?

21 replies

Userlevel 7
Badge +7
This happened to me this morning..UAC appears and states WSA wants to make changes to your hard disk.  I allowed and subsequently the gold padlock disappeared from all browsers..Edge  IE  Chrome. Firefox.  I opened WSA and Utilities...Anti Malware tools and placed a check mark in "reset system policies to default".  Was prompted to restart.  All is well now.  Knock on wood.  Still leaves me to wonder if the cure was the policies reset or the restart!
Userlevel 6
 I was prompted by Support to uninstall and reinstall, which I did, but after putting my laptop in sleepmode I found that when I powered up this morning the action center once again said that I didn't have any anti virus and firewall activated and my yellow lock is no longer there again.
I don't know if this is a WSA issue or if it is a Windows issue.
I'm glad your fix seems to have worked, BlazeTen, because mine has not.:womansad:
Userlevel 7
Badge +7
Not to worry, one of our Ranking Members will come along shortly and give you advice.  I'm sure  !  
Userlevel 6
Fingers crossed!!!
Userlevel 6
Well, I'm bummed by not panicked.  Once again the yellow padlock has disappeared from my WSA icon as before.  I have submitted yet another tech support ticket to find out if i need to have another remote session with a technician to fix the problem or if i just need to ride this out until that 48 hour until bug resolves itself clock has run out.
i am a bit concerned, however, that when i right click on the WSA icon to force updates that it says that i don't have an internet connection when I absolutely do have one...
Yet i can initiate a scan from there, but i cannot view status.
Is it just me being weird and completely untechnical that i get a twinge when this is happening?
On second thought, maybe you shouldn't answer that...  ;)  😳
Userlevel 7
Hi gr8auntteffie
Hope that you are well?
The Golden Padlock superimposes on the notification tray WSA icon when the Identity Shield is active, and this will only be active when a program that has been lodged/recorded as being protected by the Identity Shield is actually running/in use.
This is one of 3 areas in WSA where a user can override WSA.  This essentially reached, from the main WSA panel, by Identity Protection > Application Protection. Some applicaitons such as installed browsers will get recognised and lodged therein automatically by WSA but other applciation to be protected need to ne lodged by the user, using the 'Add Protection' button and then browsing to the appropriate location of the app to be protected.
I am guessing that for some reason an app or apps that were previously protected or ledged for protection have somehow be 'unlodged' and therefore WSA no longer know to protect them under the Identitiy Shield when they are active.
I woud check under Identity Protection > Application Protection nd make sure that all apps that yo want so protected are recorded there in.
Regards, Baldrick
Userlevel 6
Since that post i have now gone to the big red X over the flag icon on my Windows bar for the action center.  I do not actively turn anything off because I don't know enough to do that, I only respond to the messages that I get from the system, so when it says that Webroot or any other virus protection is not on and i need to turn it on, I try that, but it does NOT currently show that my Webroot product is being acknowledged as running on my system.
However, when I open the status window on my WSA program and I check what is 'turned on' all of my vital stuff is in the green, Realtime Shield, Webshield, Firewall, Identity and Phishing Shields are all showing that they are turned on , however, when I run a scan it only scans 5k files or so, and BEFORE this stuff starts fritzing out, it scans a little over 30k, so...
I am still waiting to hear back from tech support after submitting a ticket earlier in the morning.
Nic advised to give them time to respond and given that I am not the only one having this issue, I figure that people are still worrying that this 'bug' hasn't resolved itself.
But, given these issues, I tend to get nervous when things don't seem to be working 'right'.
I haven't reinstalled those Microsoft security updates that seemed to coincide with the problem starting on 12/16, so I am just kinda waiting to see what's happening.
No reason to panic here, right? 
Userlevel 3
I am having the completely-missing-padlock issue as well, as well as the "do you want to allow changes" dialog box occasionally. I have submitted a ticket about both.
However, I just discovered an odd thing and would like to know if yours does the same: If instead of shutting down the computer normally (Start button -> Shut Down), you RESTART instead, does the padlock icon reappear? Because that is what's happening with mine.
Normal startup = no padlock button, even though browser (Firefox 43) is listed in Webroot's Protected Applications.
Restart = padlock icon appears and functions normally.
Btw, my product is Webroot Antivirus, so apparantly this issue is not unique to the Plus or Complete versions.
My Webroot started acting weirdly after the December 16th updates.
Did the Restart trick bring back your padlocks?
Userlevel 6
?  I have tried to do the restart trick and it doesn't do me any good.  I still get the Red X over the Windows Action Center icon notifying me that I don't have coverage in place once i try to open up my WSA product status window.
I also have issues between getting a scan run that goes through the original number of files scanned and then a truncated version of about 1/6th the number of files that are scanned.
I do show that all of my protections are in place and when I check the Task Manager I have WSA actively working in the background, which, again, keeps me from panicking.
I have noticed that the UAC window pops up out of the blue asking if i want to allow Webroot to make changes to the computer and I alway click yes, but it doesn't seem to actually do anything to change the issues that appear.
I was sent a diagnostic tool from Support via email during the holiday that runs some sort of scan of the program and what it's doing on my computer to tell the people behind the scenes how the program is behaving/misbehaving and can probably explain the problem far better than I can.  It compressed all the data files it needed and emailed it all back to support so that they could evaluate the information and I received a message stating that they at least acknowledged that the change in the number of files that my product used to scan vs. the truncated number now has been verified, so I hope that means it is helping them to determine just what the problem is between the Windows Security updates and the WSA product, because they need to get it resolved for good, not just a few hours/days.
Hopefully very soon we won't be having these kinds of odd little quirky issues cropping up!!!! :D
Userlevel 7
Badge +6
? that annoying action center message with the red cross pops up the moment WRSA needs to restart for one or another reason while your machine's running ( Support is working on a related issue ). Could you do me a favour and try this instead of restarting or shutting down your machine...
Note that the red cross in the action centre does not dissapear unless you delete those messages but you can check the timestamp of that red cross message and see if that updates to a more recent time
So here we go. Right click on the WRSA icon in the system tray and select the option shut down protection. You may have to enter a password ( if you set one up yourself ) and the CAPTCHA. Then when the WRSA icon dissapears from the system tray you wait a few seconds and then locate the WRSA shortcut (either on your desktop or between the all programs list) and double-click on it . Then wait another few seconds untill the WRSA screen pops up again and then re-open your chrome or firefox or whatever you use to browse like before and then try to go to a website. See if the padlock appears again....If so then it's related to the issue support's working on. Happens to me too.
The scan/analyse tool you talk about is nothing else then a log analyser & dat collector. Support may ask you to run this if you submit a ticket. What the tool does is to collect all sorts of data from your system ( event logs from windows / logs from Secure anywhere & so ) .... In short the data they need to figure out what's going on with your install. Don't worry about that.
It's done in a secure way and not the Ashley Madison way :p
Userlevel 3
? YES! I just tried your suggestion and had exactly the same result -- thank you! You saved me a trip to the ATM because I was reluctant to log into my banking account without the padlock icon. ;-)
So apparantly the WRSVFix that Support is sending in response to tickets actually fixes nothing, because I am getting the "Do you want to allow" popup every time that Webroot launches now.
Good to know they are working on a solution, as I have not heard from them since my followup response to their first fix (the fix tool).
Userlevel 6
? Thank you for the suggestion but after my last remote session something wonderful happened and my bug died!  Now I have a fully functional and working product AND my yellow padlock has appeared in the correct place without my having to Indiana Jones my way through the steps to fix it myself.
? Congratulaions on getting your fix in place and feeling secure on line once more!  I totally understand how you feel about wanting to be absolutely sure that you're safe while doing your on line banking and other sensitive work without having to worry about anyone being able to find a way in which is why we all use WSA!
And, just on an aside, Happy New Year! 😃
Userlevel 7
Hi gr8auntteffie
The reason for the bug 'dying' is that most likely you were silently updated to v9.0.7.46, which was issued very recently with a fi to the issue. ;)
Regards, Baldrick
Userlevel 3
Same here; apparantly the update came through the next morning after Tech sent a message asking me to call them. Thanks, guys and/or gals! 🙂
Userlevel 6
Another thread started up about this, but I thought since I had brought it up in January that I would revisit.
My Webroot Icon has entirely disappeared from the icon tray that automatically loads when I turn on my laptop.  So, while I have it pinned to my toolbar, the icons on the bottom right that automatically load has mysteriously dropped the Webroot icon altogether, let alone NOT showing me that reassuring little yellow lock that tells me I am protected.
Is this a bug from a new update or is this something that needs to be addressed with Tech Support?
I just want to make sure that if this is something I need to handle that I do so, because I want to do whatever I need to to keep my Webroot performing at its optiumum efficiency.
Thanks all!
Userlevel 7
Hi gr8auntteffie
Hope that you are well?
Unfortunately this does sometimes occur, and as it seems to be very sporadic it is also very difficult to diagnose.
What you can try is to go into Advanced Setting > Install Settings and check the status of the 'Show a system tray icon'. If unchecked then tick it and press 'Save' (enter the CAPTCHA characters required, etc.) and then see if it is now displayed in the notification tray area.
If already checked then UNtick the option, press 'Save' (enter the CAPTCHA characters required, etc.) and then immediately TICK the option and press 'Save' again (there should be no requirement for the CAPTCHA-related element this time), and see if the icon is now displayed in the notification tray.
I have periodically to do this but it seems to sort the issue out for me.
Post back either way to let us know how you have got on.
Regards, Baldrick
Userlevel 6
?  Thanks for the suggestion!  I went into the Webroot Advanced Settings and found that the Icon had been ticked to appear so I did the process you suggested to remove it, save, then went back in to tick it on and then saved it again. 
I also went into my control panel where the icon tray can be customized to show the icons on the lower right at start up, it shows that it was still selected to show the icon and notifications. 
The WEIRD thing about that is while it lists the Webroot product as one of the programs that can be selected to show the Icon, there IS NO ICON visible beside it as all of the other options have icons beside them, like the CoolSense icon, the Notifications, Power, etc.
Why it isn't showing up there either is beyond me, but perhaps you know?
I am thinking that perhaps if I now do a restart to the system it might show up and I will let you know if that works, otherwise, I wil assume that the program is still running properly, it's just that the icon just sorta went on vacation?
Thanks again!
Userlevel 7
Hi gr8auntteffie
Thanks for the feedback. If the restart does not resolve the issue then I would Open a Support Ticket to let the Support Team that you are having the issue, as they may have some alternative suggestions, and should be able to investigate the issue more deepl than we can do here in the Community.
In terms of whether WSA is running, it is a bit of a pain in the backside but you can check manually that you can see the following, using the Task Manager:

If BOTH of the highlighted processes are running then you can be sure that WSA is active and functioning properly in germs of protection.
Hope that helps? And do let us know what the Support Team back with as and when you open the ticket.
Rrgards, Baldrick
Userlevel 6
? I went into the Task Manager and saw the two Webroots there, though neither of them were 'doing' anything at the time I checked them, but that they are there is the primary point and they were both there, so that's good!
If I don't see a resolution on the restart then I'll be sure to open a ticket and get someone who can really tinker with this to look at it and get me back on the proper footing!
Thanks again for your help and input!
Userlevel 6
@ - A quick update to let you know that the restart of my system took care of the issue quite handily and I now have my little green W icon back where it belongs AND the little yellow lock appears exactly where it should when I am on line, reassuring me that I am very well protected! Yahoo! I am doing my happy dance! Thanks again for the helpful tips, they sure worked!
Userlevel 7
Hi gr8auntteffie
I was wondering if it was a case of needing a reboot...I have not found there to be a need, personally, but it is good to know and I will make sure that I suggest this in future.
Thanks for the feedback...and glad that you are a happy camper. Hope that you have a great holiday.
Regards, Baldrick