webroot & firefox 40

Show first post

71 replies

Userlevel 4
Badge +12
Thanks Nic
Just adding that I've tried all the fixes, I have the lastpass version of the PassWord Manager (MAYBE because I think I once had lastpass, but I'm sure I never specifically installed that version). Uninstalling the lastpass Password Manager and running the toolbarfix results in getting the lastpass version of the Password Manager back.
Nobody else I have seen has mentioned this, so I might as well... I THINK that after updating to Firefox 40 it was working FOR A WHILE, but strangely... instead of the icon functioning as it normally did (offering me to autofill or autologin), I would have to right click it and it would list an option for that on the website I was on. Then it stopped working altogeher at some point and hasn't worked since.
Userlevel 4
Badge +12
Your absolutely right... It was working for awhile. 40 updated a few days ago and i had no issues then all of the sudden it wasn't working.  Thats what was so odd.  Never mentioned it as i thought i was losing my mind, but you are absolutely correct. i hope this gets fixed fast as i do web programming and FF is my top browser for all my work. 
Userlevel 1
I got password manager back yesterday, logged on again today and it's gone again!
Userlevel 7
Hello Gibbo, I have heard of a few others that have had that happen as well.
What steps did you take yesterday to get it back to working?  
Userlevel 1
Yesterday,  after doing all that i could in FF to disable and remove the toolbar, I exited gracefully (File>Exit) from FF.
I found an old toolbarfix.exe hanging around and used that to first uninstall it.
I looked in FF to see that it was indeed gone. It was - Good.
I again ran that old toolbarfix.exe to repair/install it.
Ran FF and everything went smoothly after that, except that I noticed that the toolbar seemed to be an earlier version 2.5? - Not sure now, because I don't see a version number anymore.
The toolbar now works - hope it works tomorrow...
oops, after comparing the old and newer toolbarfix.exe properties, I see that they are identical. I no longer know what I did right to make it work!
I had 'Automatic Update' set to 'Default' and so I believe one morning while running FF, it had updated without me noticing and had caused me the issue of WPM prompting in a red bar saying that, 'you account has been deactivated". I had to call support for them to rectify the issue on their end.
My recommendation, if you are already on version 2.5.0 stick to it and turn off 'Automatic Updates' within FF 4.0.2, and wait until WPM 3.1.1. or whatever is next gets the official green light (no pun intended).
Userlevel 3
Badge +5
I used a third party uninstaller to remove Lastpass, then used the toolbar fix to install the Webroot version 2.5 toolbar, be sure to set toolbar auto update to off. has been working fine for 2 days, no problems
Userlevel 3
Badge +1
Something seems to have changed overnight, either with Firefox or Webroot.
Ever since I managed to get the Webroot Passwod Manager working again (with WPM 2.5.0), the Webroot Sign In screen (the one that pops up every time I launch Firefox) displayed a new second option below "Remember me". The new option read "Disable Insecure Firefox Password Manager". As of this morning, that option has disappeared.
Curious, I went to the Add-ons Manager page and checked what version of WPM was running. That hasn't changed, it's still 2.5.0.
I then found Webroot Password Manager in the list of add-ons and clicked "Options". The "Disable Insecure Firefox Password Manager" option still appears first in the General section, and, to my great surprise, that option was checked again (I'd unchecked it previously to allow WPM to run).
As a test, I kept that option checked, which would have previously disabled WPM. Then I went to several Web sites that require log-ins, and found that WPM is alive and well and filling in passwords for me, in spite of that "Disable" box being checked.
Could this mean that Firefox no longer considers WPM to be insecure?
Same general problem. Four days ago, I renewed and upgraded (v9.0.2.21)Webroot and suddenly no WPM icon on my browser Firefox toolbar. The WPM 3.1.1 extension is listed on my list of active extensions, but no WPM icon appears on my toolbar. What to do?
In the past when this has happened, I've successfully uninstalled and then reinstalled Webroot whichs results in a functioning WPM icon reappearing on my browser tool bar. Unfortunately, when done (uninstall/reinstall) on my recently upgarded Win 10 platform, I get an error message stating that "app does not work on Windows 10".  I then have to execute a "restore" to an earlier date to recover a previously installed Webroo image on my laptop.
I've never had this level of problem installing Webroot. I believe Webroot is an excellent product, but for me, "ease of installation" takes a big hit on the reputation of Webroot. This said, maybe it is something that I am do incorrectly.
Please help.
Userlevel 7
Hello fernor1, welcome to the Community!
There is a problem currently with the 3.1.1 version of the Password Manager, and Webroot is very aware of it, and working to fix it.  It gets complicated in that the Password Manager is licensed from LastPass... so Webroot and LastPass must work together to figure out the issue, and THEN work with Mozilla as well to get the corrected version signed and allowed for FireFox.
I expect it will not be much longer before things are corrected, but until then there are a few options.
IE and Chrome both work just fine.  The issue is ONLY with FireFox.
If you have automatic update of add-ons enabled, you will want this turned OFF.
Some users have been able to go back to the previous version of the Password Manager.  If you have automatic update of add-ons enabled, you will want this turn off.  You can try either use of the toolbarfix.exe utility, or a clean re-install of WSA.  As soon as you do either of these, check the version of the Password Manager.
These methods have not worked for everyone, though most likely due to not disabling automatic updating of add-ons in Firefox is my guess. Here is a reply that details how one user did get back to the working 2.5 version, and it is working fine.
I hope this helps, and it should not be all that much longer before things are fixed and back to normal.
Userlevel 7
I believe that the change is due to the changes Firefox is working on to require that add-ons be 'signed' by them in order to work.  The whole point of signing is to verify that the add-on you download is the exact correct one from the provider, and that the add-on is indeed safe and not malware.
Since Webroot and Firefox are still working on getting a working AND signed Password Manager version 3.1.1, the browser will consider the add-on to be insecure simply by lack of being officially signed by Mozilla.
The Password Manger version 2.5.is quite safe, but since the version 2.5 never was, and never will be, signed by Mozilla, it will show that option.
I hope this helps!
Userlevel 3
Badge +1
Thanks for the explanation, David, that makes perfect sense.
I expect that, for the time being. any changes I see regarding WPM and Firefox will be part of a work in process. 😉.
Thanks for the update. Patience  I have, particualrly when I know what has transpired.
I posted the same problem earlier and after doing a firefox update, did the webroot toolbarfx and everything is now working. Thanks for the explanations given here. I have always liked firefox and would hate to have to drop it as a browser.
Userlevel 4
Badge +12
I assure you update addons automaticaly has been disabled each attempt to fix this. It simply will not work. Im glad some have gotten it to work though.  I on the other hand am not so patient and or understanding as far as this issue goes. Let me state i do not beleive this is a webroot issue,  rather Mozilla who obvisously finds no issues in breaking addons. Im sure this wasn't just some after thought that caused all of this, rather Mozilla not telling anyone prior this would happen and thus bang everyone was blind sided having to go crawl to Mozilla for assistance. Bad business model. Anyways hopefully this gets fixed sooner rather than later. 
Userlevel 7
Badge +56
Ok we've got an update on this issue.  If the toolbarfix doesn't work for you, please contact our support team.  They have a manual workaround that they can do to fix this issue for you:
Edit:  There's now a self-service version of the procedure that you can follow here:
You can also still contact support if you'd like assistance getting that working.
The self-service version listed above is the same thing that tech support provided me that FINALLY fixed this issue for me, except that it fails to mention to remove the existing Password Manager extension FIRST (I'm not sure if that matters or not, but it is worth doing nonetheless...)
Userlevel 7
Badge +56
Thanks, I'll add that to the instructions.
Userlevel 4
Badge +12
That fix did work. I hope this thread will be updated when a permement fix is released so we can turn back on our FF addon auto update feature. Not to keen on leaving that off due to security issues but for now all good with hope a perm fix is in short order.  Have a great weekend all!!
Userlevel 7
Badge +56
Glad to hear the fix worked, and yes, I'll update the thread when we get the extension signed.