External KeyPad Jumps into NumLock Mode since...

I am not saying it was because of upgrading to Webroot SecureAnywhere Essentials but I never noticed it prior. I read about the wireless keyboard issue but not wired. Just figured I would throw this out as a possibility?

OK - I have tried this with two different external Microsoft Keyboards.

1. I will be using my keyboard and bouncing between keys and keypad. I normally just use the DEL key on the KeyPad for the most part. All of a sudden, I will hit the DEL key and a period comes up as if it changed into NumLock mode. As a matter of fact, all the KeyPad keys work as they should as if I had it in NumLock Mode without the NumLock indicator being lit on keyboard. I tried hitting the NumLock key to get it back to normal but nothing changes - it is as though it is stuck in NumLock mode. I might add - when I do hit NumLock - the indicator will come on and when I hit it again - the NumLock indicator light goes out but it seems to still be in NumLock Mode.

2. I thought it was a tired keyboard so bought a new one (Microsoft Natural to Microsoft Keyboard Pro) and after a while - it does the same exact thing.

3. I changed USB ports with the same result after a little use.

4. I found that rebooting corrects the problem for a while. I also found that by putting my laptop into sleep mode and waking it up - clears the problem for a while.

5. I ran a complete virus scan, etc. - nothing found.

Now, if I just ignore it for an hour or so the Keypad will start working properly - could it be Webroot is hitting the server's and updating? I am at a loss.

Best answer by JimM 15 January 2013, 23:29

View original

51 replies

Userlevel 4
Hi vpnavy,

First, I would like to welcome you to the Webroot Community!

As a general response to the issue that you are having with your keyboard(s), the fact that you changed to a different Microsoft keyboard and are still experiencing the same issue, leads me to believe that this may have something to do with the keyboard drivers and the keyboard software. Although SecureAnywhere does use the cloud, the amount of data passed between the cloud and your PC is very minimal and would not normally cause this type of problem.

Although you say that SecureAnywhere has not found any infections, I would ask that you please check the Quarantine folder to make sure that. there are no files that were flagged and then moved into the Quarantine that you may not have noticed.  If there are files in there we would want to check and make sure that none of the files are associated with the keyboard.
You can access the Quarantine by selecting the "PC Security" tab in the main SecureAnywhere UI, then select the "Quarantine" tab at the top of the window. Next, choose "View Quarantine." Please report back to us and let us know if there are any files in there.

I would also suggest that you run Windows Update to ensure you have the latest patches from Microsoft applied, and to also make sure that you are using the latest software for your keyboard.

Thank you,

Userlevel 7
Badge +56
Welcome vpnavy to the Webroot Community Forums!
Userlevel 7
Hello vpnavy, Welcome to the Webroot Forum. 😃
Userlevel 3
Welcome Aboard Mate!  What is the significance of your user name?
Thanks for all the replies.
In the order of replies:
1.  -HowardR-  the keyboards use different drivers - so, don't believe that is the problem.  As far as the Quarantine Folder - only one quarantined and that was located in my temporary internet folder.  I always check for Microsoft Updates as a matter of policy - totally up-to-date.
2.  -TripleHelix and ProTruckDriver- thanks for the Welcome Aboard!
3.  -PatG - thanks for the welcome aboard.  My username (VPNAVY) - I was in the Navy and have a website called:  VPNAVY.ORG
 Again, thanks everyone for your quick replies.
UPDATE! I just noticed something - when my keyboard goes into my "Magical NumLock Mode" - my WebRoot "Foreground WIndow Protected" icon is on.  When it the "Foreground WIndow Protected" icon goes away - my "Magical NumLock Mode" problems go away.  I knew it was something to do with WebRoot! :D
So, how in the world do I disable that puppy?
Userlevel 7
Please search for exe files of your keyboard in Protected applications under Identity shield. If there are any please change their status to Allow. If they are not listed there please try to add them with status Allow.
Please revert with result. 
There were only four applications listed - the keyboard wasn't one of them?
Userlevel 7
Does it make any difference adding & allowing them?
Pegas - aren't keyboard SYS device drivers and not actual EXEcutables?  Geeez, as I type my WebRoot went into protection mode and my "Magical NumLock Mode" is on so my keypad is locked in NumLock.  I just got a phone call and guess what?  When I went back to this message - WebRoot went out of protection mode and my NumLock Mode now works correctly.
Userlevel 7
Sure, you are right that drivers aren't executables but I intentionally asked for exe's of your keyboard application (for instance  IntelliPoint or IntelliType) because I recall that adding an application with status "allow" have cured for me some malfunctioning applications. However with keyboard it might work differently ...
Userlevel 3
Thanks for the explanation of your user name!  I was on the other side (sea) for almost 23 years before retiring.  Thanks again!
Hello Vpnavy,

Welcome to the Community!

Thank you all for suggestion. Since this is happening when you see lock sign in Webroot, we required some logs file from the computer, so please submit the ticket from the link below:
One of the representative should be able to investigate the logs and should resolve this issue for you.

Thank You.


Front line Engeneer
Shreel - I submitted a trouble ticket.
Pega - No software installed - MicrosoftXP instantly recognized the keyboard(s).
PatG - You can run but you can't hide!  I spent two hours aboard a Submarine (cost us a case of San Miguel) and that was the extend of my Sea Duty!  :D
Userlevel 7
The operation of the Identity Shield's keyboard protection currently does cause a force of the Num Lock to a specific status.  At this point, the status is forced to be On.
End result:  When an app is being protected, Num Lock will be forced to an active status.
Currently the workaround is, unfortunately, to disable the ID Shield protection for anything that you do not want Num Lock to be active in.  It primarily protects browsers.  Setting these to Allow instead of Protect will cause them to not be protected and therefore Num Lock will not be forced on.  Alternately, the Protection Level for Secure Sites can be reduced to Medium or lower.  And thirdly, adjusting one's use of the keyboard to accomodate for the Num Lock being on is an option as well.
This is currently being evaluated by several teams here regarding the side effects it causes (if you think typing . instead of Delete is bad, try using the keypad to navigate a screen reader. 😉 ).
Thank you kit for the update.  Wow - I understand why it is being protected but my goodness - the implications for everyone who relies on the keypad.  Heck, it actually cost me money because I thought it was my keyboard and bought another.  Also, you would think that this "feature" would have been documented someplace "easy to find" on WebRoot so other users aren't spending money on keyboards, etc. trying to figure it out.  Anyway, thanks for the update.
Userlevel 7
No problem.  Interestingly enough, the "feature" was not documented for security reasons and because the vast majority of users have Num Lock on by default.  Now the feline is free of the pouch, but anyway, like I said, we're looking into it.
Hey kit - wonder if they could just affect the DEL key.  Anyway - at least I know what is going on.  Thanks!
FWIW - Webroot acknowledged the problem and said they were working on a solution.  It has been weeks and I am about ready to pitch this great product.  It is driving me crazy!
Userlevel 7
The downside is that there's really no good solution for this problem.  The second downside is that the possible manners of fixing it result in serious security holes.  While we work very hard to make an excellent product, we also recognize that we can't make everybody happy 100% of the time.  In any situation, there will be outlying cases that can't be covered, and when the underlying OS doesn't provide the capability to ddo certain things at all, it definitely creates the potential for certain annoyances.
You have the options to deal with it (which it sounds isn't very fun at this point unfortunately) to turn the Identity shield off, or set everything in it to "Allow", or you have the option to stop using the program entirely.  The question is whether the product has zero value to you if the ID Shield is off or things in it are allowed.  On my personal home computer, I don't use the ID shield and I still find the rest of the software tremendously useful. :)  Your specific choice is up to you.  Honestly, I don't know of any security suite that does nott have something tremendously annoying about it, so it becomes a situation sometimes of choosing the least annoying. 😉
I hear ya kitloud and clear.  Honestly, the program is fantastic!  I do a lot of searching (Google) and when I get a bunch of results - I go back to the search box and add, remove, refine the search.  Many times I position my cursor over a letter and just hit the DEL kit on my numeric keypad.   Boom - I get periods.  Sometimes I hit the HOME key - boom the number 7 comes up.  If I wasn't using the feature so much (apparently no one is) - it wouldn't be bad.  I did have to go in and allow programs (i.e., NotePad, Word, etc.) to bypass the ID protection so I wouldn't run into the same problem.  I am at the state that when the little icon pops over the WebRoot icon - I get depressed!:D
However, while it is a pain in the butt and I may threaten to pitch the entire program - when I get to the Uninstall screen - reality hit me in the face and I back out of the screen.:D
Thanks for your input kit - it really is appreciated.
Userlevel 5
Another thing to consider is what level you have set for HTTP websites under Identity Shield. If you have it set to higher than the default, which is at low, it may be worth moving it back to low and see if the issues persist at that level.
Userlevel 7
Even given all this, we're still working on it.  So don't lose all hope! :)
In the meantime, if all else fails, you can go watch any of our wonderful videos on our YouTube page.  (Though the fourth link there might get people looking at you funny if they overhear it.)
In more serious news, if you end up with any odd programs (like Notepad and any other non-browser) added to the list as Protect after today, we would like to know about it. Thanks!
Thanks TonyW for the suggestion.  Actually, everything is set at default via the install process.

Thanks Kit for the information.   Right now  I have 3 programs in the "allow" column right now (NotePad Pro, Microsoft Word and Microsoft Excel).   What I might do - is remove them, wait for the browser to kick in ID Protect, verify that I am having a problem in NotePad Pro, shut down the Browser - verify that the ID Protect is now closed and see if the problem goes away in NotePad Pro.  **bleep**, I got tired just thinking about doing all that!:D
Take care gang and hope you all had a Happy Easter.
Has this issue been fixed yet? I spent hours tracking down this problem to Webroot. I have been using the keypad for years without the num locks on and it is shocking to think Webroot takes over this without permission on purpose.