"Net View" command not working

  • 26 September 2012
  • 9 replies

Userlevel 2
Hello, I was curious if there is any already known issues with the "net view" command within windows and Webroot S.A. software. When I run the "net view" command I receive the following message...
System error 6118
The list of servers for this workgroup is not currently available
I have used this command before with no problems before installing and using webroot software so I thought it may be related. I have tried disabling the webroot firewall, loging out and back in, and retesting command but still get same error message.
Thanks for any info on the issue.

9 replies

Userlevel 7
Hey notmy88,
It is functioning correctly on my machine and test box. Please try shutting down Webroot and running Net View to see if Webroot is conflicting or you can Open a Support Ticket and we can collect logs to investigate further.
If you open a ticket you can Send me a Private Message to let me know and I'll send the log gathering instructions.
Userlevel 5
I can confirm Net View works with WSA on my W7 machine too.
Userlevel 2
Thanks for the replies, I will disable  webroot and test net view command after work.  I'll report back.  Thanks.
Userlevel 2
Shut down webroot. Net view command still didn't work. Scratching my head now. Not sure what the problem could be. My network is fine besides the net view command not outputting any info. I can access network resources with no problem. Weird.
Userlevel 7
We figured out it wasn't Webroot. Here is a helpful Microsoft Support Document that can help you resolve it though. :D
It looks like you have to make your workgroup and domain names the same.
Userlevel 2
Workgroup name is the same on all computers. No domain name needed within network. (unless I'm misunderstanding something about domains)
Userlevel 2
I used the command "nbtstat -a (computer name)" for each known system on the network. And interestingly enough there doesn't seem to be a master browser. Seems odd, how could that happen?
Userlevel 7
Hey notmy88,
I moved your thread to Techie because this is perhaps an issue with Microsoft and we figured out that it was not SecureAnywhere. I am not positive on the Microsoft issue but this article on master browsers explains common issues and you may find your answer here.
This may also prove to be useful: Windows Browser Status Utility
I have Psexec working now. The trick was to enable the Administrator account on the target computer, not just using a User account with Administrator privledges.

C:Usersshufler>net help view
The syntax of this command is:

[\computername [/cache] | [/all] | /DOMAIN[:domainname]]

NET VIEW displays a list of resources being shared on a computer. When used
without options, it displays a list of computers in the current domain or

\computername Is a computer whose shared resources you want
to view.
/DOMAIN:domainname Specifies the domain for which you want to
view the available computers. If domainname is
omitted, displays all domains in the local area
/CACHE Displays the offline client caching settings for
the resources on the specified computer
/ALL Displays all the shares including the $ shares
So let's look at each.

net view returns the computers in the current domain or network. This list will only show computers that have file and printer sharing enabled.
net view /all shows all shares available, including administrative shares like C$ and admin$
net view /domain:contoso.com will list all of the sharing computers in the contoso.com domain
net view /all /domain shows all shares (regular and administrative) in the domain