WEBROOT hangs when installing on a MAC os 10 machine

  • 2 March 2019
  • 6 replies

Userlevel 1
Badge +3
I'm a PC guy, but my son's Girlfriend found a weird take-over web browser virus and I wanted to see if the WEBROOT product worked as well on her system as the 100+ I have running on windows systems...

After downloading the program and (figuring out how to install the bloody thing) we entered the keys, and the splash screen says it's loading but it just sits there after she enters her MAC password, nothing happens. Tried 3 times. It just sits there like nothing is happening...

What did I do wrong????

This topic has been closed for comments

6 replies

Userlevel 7
Hello @davelreynolds

If Webroot is hanging, Please try to uninstall WSA from the Mac and reboot.

Try another install. Make Sure You Drag Webroot into the "Applications Folder" and no other folder

Mac Install KB Article:


Mac Uninstall Article:


If you still have the problem after the fresh install Please submit a Support Ticket or Contact Webroot Support to sort this problem. This service is FREE with a Paid Subscription.
Support Ticket System is Open 24/7

Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue.

Userlevel 1
Badge +3
Protruckdriver: thank you for the fast response, however after following your suggestions and the links provided; no joy.

I did the removal as suggested, however the system never said "Ok to uninstall Webroot". I dropped it into the trash and emptied the trash with no other prompts from the system.

After 5 failed attempts, (And YES I followed the instructions to the letter each time), The end result is, the machine will get to the screen following the serial number activation then prompt for her password to continue, then drops us back to the "Webroot is installing" screen and the progress bar never progresses and I waited ~1 hr once while working on other things here...

Unfortunately after the 5th attempt, NOW the machine does not try to install anymore (even after I removed the app from the applications folder, and verified there are no other occurrences of the app in the app directory), now the icon for WEBROOT goes right to the top of the screen as if it is activated and working, however the WEBROOT account icon is red with an ! and opening it shows no product key and if I try to insert the product key there, the program crashes.

I sent her to the local MAC store to see if they could remove the "WeKnow" redirector malware. Maybe it is preventing WEBROOT from activating properly?

I don't how, where, or what I did wrong the first time to foul it up, but fouled up it is to be sure...
Userlevel 7
Badge +62

May I jump in here..

@ProTruckDriver is there a security permissions in the Preferences folder depending on what Mac version that @davelreynolds is running? Sounds to me that there is something blocking the install of Webroot to install properly.

But contacting Support might be the best option here.
Userlevel 7
If the Mac Computer has the "WeKnow" malware on it, I would contact Support first. They will probably do a "Remote" on the computer to clear the malware first then install WSA. WSA may protect the computer from getting the malware but if the malware is already on the computer before installing WSA Support would have to look at that.
Userlevel 7
Badge +62
That's right @ProTruckDriver,

I forgot that very important part, "if the malware is already on the computer before installing WSA".

Userlevel 1
Badge +3
Thank you all for your input. She should have word back from the apple store when she gets home. Hopefully they removed the malware!