Cannot activate Webroot

  • 2 September 2020
  • 4 replies

I bought Secure Anywhere at Best Buy. I downloaded it, installed it and created an account. Everything seemed to work fine. When Webroot is started it reports that it needs to be activated. When activating I try to login. It tells me that the Login details are incorrect. I tried to reset the password but I received no reply through e-mail. I called Best Buy but they could not help though someone actually talked to me. I sat on the phone for over an hour waiting for Webroot to answer but no one picked up. I sent a message to the Webroot support group but have still not heard from them after two weeks. I tried to resend a message to the support group but it reported that I had already sent a note. This is extremely frustrating!!! Can someone please help me? I work in software support and this is not the way it is supposed to work! If this does not work I’m going to take it back to Best Buy.


Best answer by TripleHelix 2 September 2020, 00:58

View original

This topic has been closed for comments

4 replies

Userlevel 7
Badge +63

Hello @frohnamissouri 


Sorry that your having issues. Please Submit a Support Ticket and I will ping the Community staff and they can help you @khumphrey  @freydrew and one of them will ask you to send them a PM with your email address associated to your account and even your Best Buy account but please don’t post that info here on the open forum.


Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue, it should be 24 to 48 hours but could take a little longer because of COVID 19.


Sorry as most if not all Webroot staff are working from home because of COVID 19.


Thanks for your understanding!

Userlevel 7
Badge +20

Hey there @frohnamissouri ,

Can you please send me a private message with the email associated with your webroot account? I’ll take a look at your support ticket. Thanks!



I sent the email requested above but have not received an answer. If I sent the wrong information could you let me know? I would really like to get this resolved. This has been going on so long.

Userlevel 7
Badge +20

@frohnamissouri  - I never received a private message from you. Please send me a private message and include the e-mail address associated with your webroot account. Thanks!