Account login

I purchased Internet Security Complete on 5/4/2020. The product is registered. However I cannot login to my account. Keeps going back to login screen


7 replies

Experiencing nearly same issue - frustrating and attempting to get assistance.  Not going so well.

Userlevel 7
Badge +63

Hello @GRuss4720  and @TLCtx 


Please Submit a Support Ticket and they will help you sort it out!


Note: When submitting a Support Ticket, Please wait for a response from Support. Putting in another Support Ticket on this problem before Support responses will put your first Support Ticket at the end of the queue and support can take up to 48 hours to reply.



Done that as well as called - not sorted out yet!

Userlevel 7
Badge +63

Maybe one of the Community Staff can help you? @khumphrey  @freydrew 

Userlevel 7
Badge +20

Hey there @TLCtx  and @GRuss4720 ,

Can you please provide some more info?

  1. did you try resetting your password?
  2. When you say it “Keeps going back to login screen” can you be more specific? Are you getting any error message like incorrect password?
  3. Have you tried logging in on different browsers?
  4. Are you connected to a VPN while attempting to login?
  5. @TLCtx you said you contacted support - did you ever hear back from them? Did you call or e-mail?

khumphrey - thank you for your interest in this issue.  

  1. Password wasn’t problem
  2.  My Security Anywhere program installed and opened fine.  Account fully set up.  The WiFi Security program has never opened.  Uninstalled and reinstalled.  I was getting “invalid account” message.
  3.  Tried different browsers and different devices.
  4.  No I don’t have a VPN that is why I am trying to protect my computer and get one set up.
  5.  I sent “help ticket” on the 7th after I purchased and wasn’t able to complete install of WiFi Security.  24 hours later I hadn’t heard anything so I called by phone and tech person was not able to resolve and said he added to my ticket and I should hear from someone by Monday.  Well, I didn’t hear by Monday and today is Wednesday.  
  6.  I did get another call just a while ago from the “escalation dept.” but he was only letting me know that he can’t resolve my problem that it is an account issue - “nothing I did.”
  7.  Another person on this forum that had replied to me and was “looking into the problem”, also a while ago responded and told me that he hadn’t “ever seen an issue like mine before. And there wasn’t anything further that he could do.
  8.  So I am on “hold” for another 24/48 hours for someone to get back to me that they have found a “solution.”

Yep - frustrated - more time than I have ever spent “installing anything” onto my computers.  And definitely scores in as worse installation scenario for a protection program.  Thanks again for asking, but as you can see I don’t think there is much else that can be done.  I’m hopeful for a resolution but hearing from one of your people on here that “they have personally never seen a problem like this” leaves me worried.  

I do keep asking if someone can just void things and a full new installation is tried, but they are saying it is with the account itself?? So…

Fingers crossed and at least at the moment the Virus program is functional.  But it wasn’t the most costly part of the program.  I’ve never paid almost $100 for security on my computers before and maybe I should have just stuck with the free stuff out there.

Any existence of those having TROUBLE TO CONNECT?  Once computer is fully on.  (Hence) a long time for Webroot to make connection to computer, so to begin anti-virus, once left button has been clicked.  I been holding back to speak about this problem  so long.  Problem of delay been going on, ever day, since no later than fall of 2019.  If not for longer time.