Multiple Issues with Login and Support

  • 19 June 2020
  • 3 replies

Started in January 2020, when I tried to login to my account to add new phone, and laptop. I could not login to my account, as it rejected the password. I tried to use the password reset. No email. Put in a customer support request, and got automated answer to rest password though the password rest process. Put in a support ticket, then waited for a response. Forgot about it, for over 4 months since I already took care of phone and laptop using different products., Now the end of May, I started getting renewal notices. I went back to my requests from January, and no results. I did not get a response from my tickets. So waiting 48 hours might not be the solution. I started trying again the first of June 2020, and still nothing. Tried multiple attempts, still no response. Gave a scathing review, with a response to “sign on to my account and contact support, or create a ticket! Now I simply need to figure out how to delete the program, but of course you need to sign in to do that. Tried to call, said wait time 30 minutes; then after 45 minutes call dropped. Please help anyone, but another bot telling me to contact support or create a ticket!

This topic has been closed for comments

3 replies

Userlevel 7
Badge +20

@neverusewbagain ,

I’m really sorry to hear that you’ve had so much difficulty. I’ll do what I can to help you out here. Can you please Private Message me with the e-mail connected to your account? I’ll ping support and take a look at your ticket with them.


Thank you,


Are passwords an issue with Webroot? It didn’t accept the password for the on-line console, and now each time i try to login to the community, it doesn’t accept the password there. Only difference, is that it will allow me to reset the password on the community, and will not allow me to reset the password on the console. I did get a link this weekend to setup an account, but it is for the email I used for the community, while trying to get my account email resolved. I did PM you the proper account email. I also tried to login on that account, and still get the three strikes your out email. 

I got tired of requesting help, and the system has been degrading as we approach the renewal date, an just got rid of it myself. I remember the uninstall process was worse than the password reset process, so I’m keeping my fingers crossed hoping it gets it off my machine. Good luck going forward.