VSA Webroot Plugin is not working after the latest VSA update

Userlevel 2

Hey Folks,


I am in the middle of multiple Webroot issues where VSA plugin stopped working after the latest VSA upgrade. This issue started to happen on On-prem partners and surprisingly, when I asked for support from Webroot, they simply said, we don’t have any solution now. Just leave the ticket open and we will update you whenever we will have an update for you.


Like really, They put us on risk and now no support.


Is there anyone in community who can help me out from here ?


Best answer by kajwani 17 March 2023, 17:57

View original

13 replies

Userlevel 7
Badge +25

I’m asking our team internally, but this looks like this was caused by Kaseya updating without notifying anyone of their changes. We will have an update for you shortly

Userlevel 3

Hi ri1992shi,

We want to let you know that in the latest VSA upgrade, some core dll files have been updated by Kaseya. These files are used heavily by Webroot plugin. As advised by Webroot support, we started working on getting this issue resolved as soon as it came to our notice. We now have a fix.

Can you please let us know the version of your Webroot plugin? If your version is 2.0 and above, please refer to the attached document and follow the steps. If your Webroot version is 1.0, you may need to install the 2.6 version for the plugin to work. 

Hope this helps.

Userlevel 2

Thank You Mr.Kajwani,


I tried to perform the step mentioned in the document on atleast 3 On-Prem partners. The plugin Version is installed 2.6. but when i tried to perform step “2” there are not any files present  as “, Kaseya.Commons.dll and KCryptoKacm.dll” under the location in c:\GI\Services\GICoreServices\bin so unable to perform step 2 where files needs to renamed as old and then copy from Kaseya/Webpage/BIn


However, on all 3 partners, Kaseya.Commons.dll and KCryptoKacm.dll” files are present at c:\GI\Web\giWebroot\bin and we have successfully performed the steps 5,6,7,8


But unfortunately, the issue is not resolved for us. Can you please validate and let me know if am doing something wrong here or help me out on a session.

Userlevel 2

We have restarted the servers as well

Userlevel 3

Thank you for the update. For version 2.6, here are the updated steps:

Patch Webroot v2.6

  1. Open command prompt window on server as administrator. Then run the following command to stop the webroot service -> net stop WrRmmService
  2. Rename old dlls in C:\WR_KPlugin\Web\webroot\bin, Kaseya.Commons.dll and KCryptoKacm.dll to for example: Kaseya.Commons.dll.old and KCryptoKacm.dll.old
  3. Copy the new dlls from the C:\kaseya\webpages\bin to C:\WR_KPlugin\Web\webroot\bin
  4. From command prompt run -> net start WrRmmService
  5. From command prompt run -> net stop "Kaseya Plugin Host Service"
  6. Rename old dlls in C:\Kaseya\WebPages\wrkaseyaapi\bin, Kaseya.Commons.dll and KCryptoKacm.dll to for example: Kaseya.Commons.dll.old and KCryptoKacm.dll.old
  7. Copy the new dlls from the C:\kaseya\webpages\bin to C:\Kaseya\WebPages\wrkaseyaapi\bin
  8. From command prompt run -> net start "Kaseya Plugin Host Service"


Please let me know if this works. Thank you.


Userlevel 2


Hi Kajwani,

Thanks for sharing the steps with us. We have tried to perform on at least 5 clients and surprisingly, it did work for a single client but still, more than 4 clients are affected.

I performed the same steps on the other 4 VSA servers but don’t know why the issue is still present.

Userlevel 2

Hi Kajwani,


Any update on it ?

Userlevel 2

Just following up. Any update?

Userlevel 2

Hi Kajwani,


May I expect an update on this thread ?

Userlevel 3

Hi Rishi,


These steps have worked for most of our customers and have been tested internally as well. At this point, the best approach to troubleshoot the issue with your VSAs would be to have a call with Webroot support. Could you please share your ticket number with me? And also let me know the timeslots that work for you for a call this week? I will set up a call as soon as possible. Thank you for your patience.

Userlevel 2

Thank You Kajwani!!

The Webroot support ticket is - #492776

I am available from Monday to Friday 2 AM EST to 1 PM EST.

I am reachable at [edited out for privacy]

Userlevel 3

Thank you! Our support will be in touch with you soon. 

Userlevel 2

Thanks You Kajwani,


I have managed to fix the issue at our end. It was “Kaseya.Appfoundation.dll “ file which also needs to replace in suggested 2 folders. Our instances are working fine now.


Suggestion - Please add the above mentioned steps in your documentation.


Thanks for support and quick help !