SecureAnywhere Mobile Scan Freezes at SD Card

Running SecureAnywhere Mobile Premier on Droid 2.  Last few days, when I begin a scan, it does fine until it gets to the SD card - then it just ist there and does nothing - except drain the battery!  Just let it run overnight - same thing - it didn't move.
Would reinstall fix or is there a better solution? 

Best answer by Kit 9 October 2012, 17:17

View original

23 replies

Userlevel 7
Hello and welcome arkolski!
Thank you for joining the Community, you have come to the right place :D
Please answer a few questions so that I can better assist you and help resolve this issue.
1. Is your Android rooted? This can cause problems with the functionality of the software. We also do not provide support for rooted devices.
2. Please list any "task killer" apps or other mobile security apps you may have on your device.
3. What version app are you on; Free, Premiere, or Complete? Also, are you on the latest version 2.7?  
*Click the menu button while in the Webroot app and then click "About" to find this information.
If you are not on the latest version an uninstall/reinstall would be effective. You can also update it manually from the Google Play Store.
Thank you!
Mike -
Android NOT rooted.
Uninstalled Advanced Task Killer and Juice Defender this morning and retried - same thing happens.
Version is Premier and is latest version 2.7.
Userlevel 7
I would like to gather more information from your device and also check if there is a problem with your SD card. I am Private Messaging you instructions on how to gather and send these mobile logs now.
Please follow them exactly and replicate the scanning problem before gathering/sending them.
Thank you,
Thanks!  I'll probably have to do it when I get home from work tonight.
Userlevel 7
Sounds good!
Please let me know when you have sent the logs. If you have multiple SD cards that would be a good step you could try while working to see if the scans will complete.
Looking forward to your response!
Mike -
Just emailed logs to { Email removed by moderator }
Not sure if this is relevant, but I tried uninstalling Webroot to try a reinstall and got an Uninstall not Successful message.
Userlevel 7
Thank you for the logs,
This issue can be caused by a corrupted system or files, if this is the problem correcting the corrupted SD card would be the best solution. :(
I have opened a support ticket for you here so that we may research the logs further. You will receive an email notification with this information as well.
I will follow up with you and you will receive feedback through your email as we research further.
Thank you for your patience.
I uninstalled then installed free version.  Then entered key to upgrade to Premier, and now all seems fine.  Scan ran w/o problems!
Userlevel 7
Hey Alan,
Thank you for updating this on the Community and through your support ticket. I am happy to hear that the scan is completing fine and please respond to this ticket if you see any recurrence. I didn't think you were able to uninstall but hopefully that is all that was needed.
Thanks for your patience in this!
Mike -
I wasn't able to install initially, but I found a post in another thread in this forum that mentioned disabling the administrator function in the settings first in order to uninstall.  That did the trick!
Thanks again for the help!
I see that my problem has been addressed but the details don't seem to have remained with the problem thread.  I have Droid Pro which I recently reset to factory settings.  Upon replacing my apps I moved to Webroot Mobile (free version - 2.7) rather than reload Lookout.  All was working fine until two days ago.  Now when I power-cycle my phone in the morning it gets to the scan on the SD card and stays there forever.  Very little else works on the phone during this "scan" and the scan NEVER finishes.  I have killed all the apps and power-cycled the phone again with the same result.  Webroot is currently the only security software on the phone and I'm not using any Task-Killer apps except for Task Manager.
Userlevel 7
Hi RCHenderson,
Glad to see you here on the forums...Welcome to the Webroot Community!
We are aware of this issue and the development team is working on a fix to be implemented in a future release. That being said, each isolated case helps development address the problem and develop this fix more quickly. I have sent you instructions in a Private Message on how to gather and send us mobile logs for your device. Again, this would help expedite the fix and get your mobile app up-and-running correctly!
Just as a reminder: Make sure to replicate the issue right before gathering the logs! :D
Please let me know when you have sent the requested mobile logs (either on the PM or here on the thread).
I purchased the premium mobile upgrade in the app.,but I do not have the product. I put in keycodes, established accounts but no upgrade, and the free one isn't working correctly. Stops @ SD card then says everything is fine. I don't believe it. There is something wrong.
moved to proper forum and thread - admin
Userlevel 7
Hi fit2btied,
Thanks for the post and welcome to the Webroot Community!
First, I would like you to check which version of the Webroot app you currently have installed on your mobile device. To do so, open the app, tap your Android menu button, and then tap "About". The version will be listed towards the top of the page. Please let me know what it says (i.e. "free" or "premier").
Second of all, I have sent you a Private Message regarding how to gather mobile logs from your device. As we are currently working on a fix for the SD card scanning issue (to be implemented in a future version release), each isolated case is very valuable and gets our development team closer to getting to the bottom of the issue.
Second, there is one more thing I'd like to point out. It could be that there is a whole other issue at hand here and some corrupted file inside of your SD card is causing the problem. To check that your SD card is in fact free of disk errors, I suggest running a "check disk". To perform this, plug your mobile device into your computer via USB. Once the device is plugged in and the USB storage is on, go to "Computer" or "My Computer" (depending on what version of Windows you are on), right click the removable storage where your mobile device is located, click "properties", click "tools", check the boxes and  run the "check disk".
Please let me know when you have performed the aforementioned steps and reply back with your findings so we can close the thread or continue to troubleshoot accordingly.
Userlevel 7
Hey steveshayne,
This post will be moved to a similar thread on SD Card Freezes on Scan issues. In other cases, a fresh uninstall of the app and a reinstall from the Google Play Store has fixed this issue. Please try doing this and attempting to recreate the scanning issue and let me know the results.
Also, any information about the Android and app version would be helpful.
1. Is your Android rooted? This can allow users to make changes to the device that may cause problems with the apps functionality.
2. Please list any "task killer" apps or other mobile security apps you may have on your device.
3. What version app are you on; Free, Premiere, or Complete? Also, are you on the latest version 2.7? 
*Click the menu button while in the Webroot app and then click "About" to find this information.
I have installed Webroot SecureAnywhere Mobile (Version on my HTC One X (not-rooted) and during a device scan, it hangs on "Scanning SD Card" and never completes. The HTC One X does not have an SD Card, only internal memory. How do I correct this so that the scan completes and Webroot SecureAnywhere Mobile functions?
Userlevel 7
Hello indianabridges,
I moved your post to a similar thread on SD Card Scanning. In other cases, a fresh uninstall of the app and a reinstall from the Google Play Store has fixed this issue. Please try doing this and attempting to recreate the scanning issue and let me know the results.
If it doesn't resolve the issue we will open a support ticket and gather mobile logs to investigate further.
Userlevel 7
One of the most common causes of hanging on "Scanning SD Card" (which also includes "internal memory", internal hard drives, and other mass-storage outside the device's main flash memory) is file corruption on the storage device.  Thankfully this is not the only cause.  I can also end up -looking- like it's hanging while taking inventory in the event of a substantial number of files in the directory structure on the mass storage device.
The first cause sadly is the more likely and happens far too commonly due to the nature of the Android OS.  Not talking about multiple times to everybody, but more like one in twenty people are likely to encounter file corruption on their Android device.  In most cases, we can work around this, but the OS (Android) on some devices will have a substantial fit in other cases, causing the scan to hang when we request that the OS read the corrupted file.
If there is suspicion of a corrupted file, check whether any other apps have trouble reading some files.  A good way to check is to get a file manager app and then do a system-wide search for something you know is not there.  The search will very often fail if the file or file system has corruption. 
If further evidence of corruption is found, or if you want to Just Make Sure, mount the Android device as a drive on the computer and copy ALL of the data from the extended storage to the computer.  Make sure you tell the computer to show hidden files and copy them as well.  This is another place where corruption may cause a hiccup, but it will usually recover because the computer is partly in charge in this case.  Then use the Settings in the Android to unmount and format the extended storage.  This process differs on different devices, so check your manual or with your tech support for the device for help on this.  Afterward, copy all of the data back.
If you think there are just a LOT of files (You can check this by connecting the device to a computer and copying everything over into a folder, then right-click on the folder and click Properties.  It will count all the files and folders), then all you can do is wait patiently for the scan to be given that list by the Android OS.  In those cases, setting to scan once a week is recommended.  We will still update the definitions daily at least and we will still check everything with realtime shields for you.
I have installed and reinstalled the app from Google Play at least two times with the same result. I would also note that SecureAnywhere keeps turning off the protection shields in addition to hanging when scanning the SD card.
Userlevel 7
Sorry for the delay indianabridges,
If the protection shields are automatically turning off and the scan is still freezing at the SD Card (really your internal memory) after fresh installs, please Open a Support Ticket where we can track the communication and collect mobile logs. This needs further investigation that is better handled through the support system.
You can Send me a Private Message when you have opened the ticket and I will send you the log gathering instructions tomorrow morning.
Mike - A few days ago the scanning started to complete on my HTC ONE and I have had no trouble with the shields being turned off; I assume it was fixed with the upgrade to