Webroot causing software to hang in Windows 7

  • 13 January 2017
  • 74 replies

Show first post

74 replies

@ wrote:
Cheers Keith,
That's by far the most comprehensive and helpful information on this subject I've received to date.....I'll take your advice onboard and follow up.  I'd already advised tech support that I thought we'd be doing this again in a month or so as another major update is imminent for one of the titles.
All the best
Andy S.
Glad to hear my advice helped. Thanks!
By the way, you can also check which files are at any particular moment being journaled by double-clicking on the Webroot icon in the taskbar to open up the Webroot GUI window, then clicking the cog icon to the right of the "Utilities" tab, then clicking the "System Control" tab and finally clicking the "Start" button underneath "Control Active Processes". You will now be able to see which Active Processes are being "Monitored" at that particular moment (as well as those that are being Allowed and those -- if any -- that are being Blocked).
Hope that also helps.
...and please do keep us posted regarding your follow-up with Support, and regarding (hopefully) the resolution of your problem. Even if that means a couple of months delay before getting back to us.
Userlevel 3
Badge +9
Hi Luca,
I'm not sure that the advice I was given will help you, as my problem was quite specifically related to the Battlefront CMx games.....However I'd imagine the general principles for dealing with the issue would be the same (as described by Muddy).
Have you used the Webroot logging tool yet?  If not you need to get in touch with Tech Support (ring your local sales number and then don't make a selection from the menu offered, just wait instead, doing this seems to connect direct to tech support), download the tool and forward the log generated to Webroot.
Once files that are causing the problem on your system are identified it should be a relatively simple process to cure the issue (assuming it is similar to my own).
All the best
Andy S.
Userlevel 2
Hi Andy,
log already recorded and sent some days ago, with the assistance of a tech support person from Webroot. But until now, no solution was back.
Waiting and hoping.
Thank you.
Userlevel 3
Badge +9
I wouldn't wait on them to call you, keep trying their local phone number until you make contact, then ask to be put through to tech support.....My issue was dealt with while I waited, it took an hour or two all told, but AFAIK the call was free (it had better be).
Hi lucam...Not sure where you are located but last week I placed a call to them a minute after they opened for business. Its only an hour time difference between Colorado and California. The early bird catches the worm so if its convenient,
call them early to avoid the wait time. They answered after the third ring.8)
Userlevel 2
Andy, Robert, thank you for suggestion.

If I don't get an answer in the next 2 days I will call back following your suggestion (I'm in Italy).
Oh...you lucky devil you.:D !!! Maybe Webroot has something a wee bit closer:D
Userlevel 3
Badge +9
So, I'm back, new software, same old problem.....Why exactly do Webroot think that totally crashing a system is a satisfactory means of 'monitoring software'?
I'll be phoning tech support again tomorrow, but I just found out that I'll be charged for that 'privelege'.....So, there is going to be quite a big row tomorrow, unless Webroot ring me first.
You have my contact details, they haven't changed.....I know you read these threads, so do the right thing.
PS - Apparently I eaned a new rank on the forum.....I think 'Frequent Victim' would be a more appropriate appellation.
Please see my comment here.
And please, please DON'T phone. Use the email Support link I refer to above.
Userlevel 3
Badge +9
Cheers Muddy, you are a star, but I really don't have time for e-mailing back and forth.....The game in question this time is decades old, the problem appears to be intermittent at present, but I know where that leads. 
Simply put, it just should not be happening.
Why exactly does Webroot lock my system up?  Is that supposed to protect it somehow.....As far as I can tell the only possible consequence is hard-drive damage.
Not happy at all.
Userlevel 7
@, I do sincerely apologize for all of the inconvenience you've had.

I've re-opened the support ticket on your behalf to help expedite the process. In the future, sending our Team a support ticket is the most sure way to get the Support you need in a timely manner.
Userlevel 3
Badge +9
The last time I had a support ticket I still had to phone you, I got through by calling sales and then not selecting a category from the menu, your UK tech-support line was not answered, ever.
And I now understand, you charged me for that call!
So tell you what.....You call me tomorrow, after ten, when I've had a nice cuppa, because right now I'm not feeling terribly inclined to chat about it.
While you are about it you can write a compensatory cheque and send it to my listed address....I've been a customer for over a decade, so I know you have it.
@ wrote:
Why exactly does Webroot lock my system up?
It shouldn't, ever, to my knowledge (To reassure you, I regularly experience Webroot journaling, i.e. monitoring, new files on my three computers, indeed I have one being currently journaled on the computer on which I am writing this message, but I've never ever [yet] had the same behaviour you're currently encountering. And I've been using Prevx->WSA since 2006). As I said, this issue should be escalated.
Userlevel 3
Badge +9

@ wrote:
The issue with my new game seems to have gone away all of it's own too, which is rather odd, but I'm calling it a result.....I've got a Support Ticket ongoing so we'll see what develops.
Moved my response to your above comment to this thread as that comment was in the inappropriate thread.
The issue has probably gone away as the new files have been whitelisted by Webroot. (You can check this in UtilitiesSystem ControlControl Active Processes and verify if the files, when your game is open, are being "Monitored" -not whitelisted- or "Allowed" -whitelisted-) If that is the reason why, the problem has not yet been resolved as next time a new version is introduced, you risk having the same problem recur. So make sure Support actually gets to the bottom of why the "Monitoring" of new Battlefront files was causing your computer to crash.
Userlevel 3
Badge +9
Cheers Muddy, you are quite right, that's exactly what they've done (whitelisted everything marked Battlefront in my previous logs).....Which only goes to show that they don't pay much attention as I quite clearly stated that this problem is with NEWLY INSTALLED SOFTWARE from Battlefront that was NOT INSTALLED at the time those logs were generated.
I'm making some enquiries on the Battlefront forums, it seems I'm not alone in experiencing the issue, there are threads dating back to at least 2014, detailing problems similar to my own.  Battlefront advise disabling Webroot while their products install.
Checked my subscription details, I've been on PrevX/Webroot since 2009, the hassles all started in the last couple of years, so what changed?  Who ruined the best AV software in the world?
PS - Totally agree that wall to wall whitelisting is not a solution.....It's a cop out.
@ wrote:
Totally agree that wall to wall whitelisting is not a solution.....It's a cop out.
Whitelisting = good because it is the Webroot malware database signalling to the local Webroot AV engine on your device that the Battlefront files are now trusted not to be malware. So the fact that the files have been whitelisted shows that Webroot is doing the job it's designed to do. That in itself is good NOT bad.
Whitelisting ? enough in your case as, for some reason, there is some kind of conflict going on between Webroot and your Battlefront game software (I presume) when Webroot is monitoring Battlefront files. Webroot needs to get to the bottom of this.
Userlevel 3
Badge +9
That's kind of what I meant TBH.....Presumably it should at least reduce the number of issues occurring for other users?
Userlevel 3
Badge +9
New Combat Missions update, new (& identical) problem with Webroot.....It never bloody ends!
Support ticket opened and I've asked them to diagnose the problem, not just blanket whitelist the files.....I await a response, but I'm not holding my breath. 
I'm also not going through this hassle every time a game updates.....This idiot company has completely destroyed my confidence in their own product.
Please would you also remove the word 'solved' from the tilte of this thread, you have not even approached solving the problem with your cop-out efforts to date, as my constant need to return to this thread clearly demonstrates!
Userlevel 7
Hi squarehead666
I would suggest that there is nothing to diagnose here...you obviously do not understand how WSA works, i.e., on the basis of a number of technologies including whitelisting of NEW versions of files, and as there are clearly new files related to an update of the game...sometimes those files do not get whitelisted as quickly as they might resulting in your issue..
Hopefully, there will be a solution to your issue in the near future, as and when an Exclusions Folder feature is introduced to the Home version of WSA (it already exists in the Endpoint Security version). I understand that this should be sometime this year...but that is not officially confirmed...yet!
As for Webroot being an "idiot company"...I would disagree. Webroot is dedicated to protecting users of its products and therefore security/protection comes first, so some patience is required in terms of the exclude folders feature...which I am sure will come and will resolve your issue.
Hopefully, you have also let the Support Team know of your frustration, as you have done here? If not then do so as they can also feed this back to the Development Team (but do not do so  until you have had a response from the Support Team as updating your ticket prior to a response will just send it to the back of the queue).
Regards, Baldrick
Battlefront advise disabling Webroot while their products install. 
Hello there
Don't want to intrude but just sharing my experience and also I'm new to Webroot so don't know much about their security suite.
Anyway, never disable your security no matter who advise you to do it.Game forums are full of moderators who advise you to disable your security while games are updating. That is very first sign of FISHY stuff which can mean any of this or a combination:
1.a  OS Registry manipulation,
1.b  windows catalogs and certifactes corruption
2. installation of drivers allong with the prexistent ones which give them a perfect tool for hardware manipulation,
3. installing of hidden devices and use of it, hidden partions
4. manipulation and write on HDD sectors of hidden files which than will load at the right time when you lunch the game).
5. Keeping constant internet connections of this types : Time_Wait and Close_Wait so they can load and revive packets, is  legit to keep'em but note, that can give Packet Loss and an undesired Multiplayer experience(but they don't care believe me, they will use this kind of conections and kep'em alive and the OS is permissive on this matter  unless you instruct it yourself)
6. Just because game files are clean on Virus Total that doesn't mean won't do dirty things once are on your system, it will load legit .dll win 7 files and in conjunction with very powerfull apps on your OS(cmd.exe, powershell, utilman.exe, files with CPL extension or MSC, etc) will do dirty manipulations and than clean the traces when you shut down the game session.
Not sure how much Webroot support win 7(which I use myself) but many .dll files which wasn't on win 7 and had been lunched for win 10 are now present in win 7 pushed trough windows updates. Some of this .dll files was dowloaded by the game itself not all came trough updates (in my case Warthunder) and are legit .dll files if you check the hashes but that doesn't mean much from the security point of view.
I think of 3 examples MMdevapi.dll, devboj.dll and Dwrite.dll
I played Warthunder over 3 years now and many times infected my computer trough game updates and Teredo tunneling protocol, breached my security on port 123 windows time, printer ports and spooler(i'm not having a printer), many times I had to use bkups and fresh installs of windows.
Is Warthunder the worst free game app, no, are others aswell, but certainly are good programers.
About EA, I really don't trust their software since I tried back in time to use Origin platform and i'll say just : "I will stay away from it" despite the fact  I would like to play some of thier titles.
For me Steam is enough headache and are less intrussive and fishy than Origin.(just my 5 cents here)
I don't try to defend Webroot i'm myself on free license atm 14 days and try to decide if will be the right thing for me. I don't believe too much in cloud reputations of files or in trusted vendors but sadly a lot of security will put that first before really analyse the processes of the files.
In the picture bellow you'll see only a small proof and part of my nasty experience with Warthunder

 I hope at least some of my shared info will help you squarehead666 if you have question pls don't hesitate and try to have a good week.
@ wrote:
I would suggest that there is nothing to diagnose here...you obviously do not understand how WSA works, i.e., on the basis of a number of technologies including whitelisting of NEW versions of files, and as there are clearly new files related to an update of the game...sometimes those files do not get whitelisted as quickly as they might resulting in your issue..
Sorry to butt in here, Baldrick, but I think you may have misunderstood squarehead666's problem.
If you go back to his initial posts, you will see that (as he mentions in the title of this thread), for some reason, until the updates to his Battlefront game files are whitelisted by Webroot, his OS hangs/crashes every time he exits the game (here). Unfortunately, when he reported this to Support, instead of their going to the root of the problem, they just whitelisted his files. I warned him at the time that, as Support had not dealt with the underlying problem, he would very likely encounter the same problem next time his Battlefront game files were updated and urged him to insist they get to the bottom of this problem when that happens. It's not clear from his latest post whether this is in fact what has happened this time round, but I wouldn't be surprised if it is.
He also said that there were other Battlefront users reporting similar problems with Webroot on games forums (here). If that is so, that would indicate this is due not to an instability on squarehead666's computer but to some kind of conflict between Webroot AV processes and Battlefront processes.
Now I agree with you that his language when referring to Webroot is somewhat florid, but that does not take away from the fact (as far as I can see) that his underlying problem has not been resolved.
My 2 cents worth...
Userlevel 3
Badge +9
Thank you once again Muddy for summing my position up so accurately, it is just as you describe.
Frankly the only thing I want from Webroot is quality software that does its job WITHOUT interfering with my normal use of my computer.....ie: Gaming. 
PrevX provided me with that for the best part of a decade, Webroot got involved and.....Well here I am, again.
Let me make this 100% clear.....I don't care one whit about the technical particulars of the problem, I just want it to go away, permanently.
I note with some disappointment that the inappropriate 'Solved' remains appended to the title of this thread.....Kindly remove it.
PS - I'm fairly confident that Steve & the lads at Battlefront don't have designs on taking over the world via their games software.
Userlevel 3
Badge +9
In the absence of any reply from officialdom, I thought I'd have a poke about, I started Combat Missions: Fortress Italy (henceforth CM:FI, the latest problem game) and opened the Webroot control panel.
CM:FI.exe was showing as a 'Monitored' process, so I changed the setting to 'Allowed' and closed the control panel.  I then exited CM:FI.  Webroot locked my system up and I had to hit the power switch, again.
I'm using a brand new hard-drive, it's been suffering damage non-stop since it was installed, singly and exclusively because of Webroot, no exceptions, Webroot and Webroot only.
So Webroot defenders, pray tell me.....Which bit of this is good, satisfactory, or even acceptable?
I am advised that Avast offers a service similar to that formerly provided by PrevX, so perhaps I should explore their forums and products instead?