• 17 July 2022
  • 6 replies

When I try to open my new Webroot Mobile Security App I get an error This Site Can’t Provide a Secure Connection ERR-SSL-PROTOCOL-ERROR. It is doing it on only one of my phones that uses Android it is a free Government phone with Assurance Wireless a UMX U693CL.  

This topic has been closed for comments

6 replies

Userlevel 7
Badge +25

Does it do this in both WiFi and cellular data or only on cell data? The largest cause of this type of error is when the time/date is incorrect. Might the phone be set to the wrong date or time? You could also try reinstalling the app to see if that eliminates the problem

But really I  would recommend a call out to Webroot support. They should be able to help you figure this out. There is a link at the very bottom of this page. They are good at these kinds of things. 

I have exactly this problem too.  My Pixel Android phone works but my friend’s LG Android gets this error.  It was on WIFI at the time.

Userlevel 7
Badge +25

It is possible (I do not know how Webroot connects here) that a software update might be needed. You can check versions on each phone and see if there are differences.  

I often see this error in Chrome when cache errors or expired cached exist or the browser needs updating, or expired certificates exist. 

I’m sure support can help you here. 

Thank you Major Havoc I tried turning the Wi-Fi off and going with straight mobile data and the same era started to come up but then all the sudden the pagel loaded and then it said that I needed to create a Webroot account which I have had an account for a while and this problem just started last week my Webroot was working fine but anyway I just put in the same information that I already have with my Webroot account and then the webroot  page came up they got a new app that just shows a scan setting. I still haven't bothered to try it on Wi-Fi again but my other phone isn't having a problem so maybe for some reason it just needed to set up an account on this phone or something I don't know but that at least  I'm making progress .I'm going to try it on Wi-Fi a little later and if it doesn't work then I guess maybe it is some kind of a certificate issue. But just the fact that it's working right now is some progress thanks again From Andy!!

I just turn the Wi-Fi back on and went to the Webroot App it loaded up fine just like usual. I still don't know exactly what the problem was but turning the Wi-Fi off and using regular mobile data I guess got past the problem.The Webroot App asked that I create an Account.I guess entering in my Account Information solved the problem so I'm glad because I've been trying all kinds of stuff for about a week now. I already tried clearing the Chrome browser I tried looking into the SSL certificate issue resetting all the Wi-Fi preferences and all kinds of other things that I have been trying and none of it worked. Now I wish I would have come on to this Webroot community site earlier I could have saved myself a lot of troubleshooting. I had heard about this being a Wi-Fi issue with public Wi-Fi but I have never had this issue at home with my Wi-Fi as I have Xfinity and my other device is working fine. Either way I've learned a whole lot about this error in the process and as it turns out switching over to mobile data was the very last thing that I tried I've already done every single other thing possible. I guess as the saying goes live and learn well I will have to admit I definitely have learned something about this Error!Once again Thanks Major Havoc From Andy!!

Userlevel 7
Badge +25

Thanks for the update Andy. Something cleared out the cache junk I suspect, which can also cause this error.  Glad it at least led you to a solution.