We are seeing issues with Windows 7 desktops connecting to a Citrix session with their printers.

  • 27 January 2016
  • 45 replies

The printers connect successfully, however when they try to print to them the jobs seem to disappear. Attempting to print again, the printer shows offline in the session even though the Windows 7 OS can communicate with the printer fine. We disabled all functionality with Webroot and the issue persists, however when we flat out uninstall it printing from Citrix works as expected. We have added exclusions for the spooler folder and the Citrix installation folder with no luck. Any advice or feedback is appreciated as this is holding up a deployment of 2000 seats.
Edited update: The printers are connected via network using a mixture of both TCP/IP ports and HP Proprietary ports.

This topic has been closed for comments

45 replies

Userlevel 7
Badge +56
I asked one of our support folks if this was an issue they'd dealt with before and they said they hadn't. So there isn't a known quick fix for it. Can I have support follow up with you to get logs and troubleshoot?
Userlevel 7
Badge +56
Ok I submitted a ticket so you should hear from support shortly.
Userlevel 7
Badge +6
Are you using a dedicated printserver outside of the citrix environment? And when you have Secure anywhere installed on the server do you mean on the citrix server and on the dedicated printserver or not?
About the printserver... Are you using the default spool folder or did you customise it on the printserver?
Did install a few way back and never ran into problems with the behavior you mention but then again we don't use a good product like Secure Anywhere :$ unless when we mixed corporate drivers with home drivers or used too many different drivers. Citrix can be picky about it. We had to redo a few printservers because of this. Could be as simple as a driver conflict somewhere.
If the dedicated printserver is not part of the citrix farm do you then see the same behavior outside of a citrix session ( i.e. if you map the printer locally )?
And did you get any allerts in the Secure Anywhere console about weird communications or suspect files.
Lastly what kind of drivers are you using for your printers. Are you using corporate versions of the drivers or home drivers because the corporate drivers have some tools tweaked away which you don't need in a corporate environment.
I have known that home drivers somethimes cause issues on a corporate environment because of those extra tools.
What about bi-directional comms between the server & printer. did you try to disable that for a single printer and see if it occurs again or not.
Feel free to nudge for more info. 
? maybe it's besides the question but i'm jsut talking out of experience and might be able  to render some assist here.
Guess the easiest to test is to take a workstation and temporarely set it up as a test printserver. Install the Secure Anywhere on it and then set it up as a test printserver for a single printer making sure you use only corporate drivers. If that works then add a second printer but please try to keep the amount of drivers installed on it to an absolute minimum as not to get any unexplainable conflicts... 
Hi Edwin,
The printers are all direct network connections on the client workstations (no print server). We didn't do any customization on the location of the spool folder.
We'll look into the bi-directional comm theory, I have seen that before in the past (as well as the "enable advanced printer features" option) causing some issues while waiting for support to reach out. Since it started with the rollout of Secure Anywhere we wanted to start there (low hanging fruit) before looking to change printer configurations, but it's a good idea to look at both sides in tandem.
Userlevel 7
Badge +6
Steve if you have a workstation to spare together with a Secure Anywhere license then no need to wait.. If you mess up a workstation trying it's safer then to mess up a citrix server
Hi SteveDTC,
Are you still having this problem? We are having what sounds like a very similar issue on our multi-tenant Citrix site.
Problem "appears" to have started around the time we began migrating from ESET to Webroot, and it's completely random and intermittent.
Clients connected via WAN with autocreated printers in the Citrix session will ocassionally show as offline when trying to print. The local printer on the device is just fine, it's just the mapped printer in the XenApp session. Also locally installed printers on the XenApp server continue to work fine.
I have a case open with Citrix and they are struggling to see any problem on that front. Configuration looks good.
Did you ever hear anything back from Webroot support? If so do you have a reference as I think I'll also open a case here once I've done some testing of my own.
Thanks in advance,
Hi James,
We are indeed still having the issue more or less exactly as you described, as a result we have disabled real time scanning and opted to do scheduled scans during set intervals every few hours. I had one of my engineers contact support as well as send logs, response times and plans of action have been a bit disappointing. Our case number is 9786 for reference.
The issue is very sporadic for us, so we are not able to reproduce it on demand. The only recommendation we received was to disable one particular setting in real time shield which we are re-evaluating. I know at one point we disabled everything else except "Realtime Shield Enabled" and didn't have much success.
Hope this helps,
I wanted to chime in and say that our users are experiencing the same problem, and this has been going on for months and months. Super frustrating. At one point, it seemed like we had the right policy options, but it appears that the settings were streamlined, and now we are really not sure what we need to adjust to fix this issue. 
It's as James described: We have users connected to Citrix servers over the WAN. The only printers we have seen affected are those connected to the client by USB. The user will try to use the printer from the Citrix session, and it will show as offline. The problem seems to happen every day for affected users. Currently they have to log out and log on again in order to bring the printer back online. 
Hi all thanks for replying,
Just to keep this alive and give an update from my side. At Citrix request we switched one tenant in the farm to use only UPD (Citrix Universal Print Driver) instead of trying to map the correct manufacturers driver. That change was made Monday evening and since then (all yesterday and so far today) no user on that site has experienced the problem.
I'm by no means suggesting this is fixed as it's too soon to tell, but this particular tenant had a number of users that were affected by it on a daily basis.
Citrix comments were that if this works then it is likely to be a printer driver issue, however I find that hard to believe as no drivers have changed since this started happening, and the problem simply didn't exist until what seems like the time we started rolling out Webroot.
I will continue to monitor and update findings here over the coming days.
Thanks for the update, James! I'm interested to see how the driver item pans out. This had been a consideration of ours, since HP tends to use more beefy drivers. However, we were seeing this affect more than just HP printers. As like you, we did not have any of these issues until we rolled out Webroot.
By the way, I am working with Steve on our side here to get this resolved.
Basically what we are doing is using test locations with a deprecated policy in hopes of finding what the culprit is. So far, we have been able to enable settings under the following without having the issue reproduce:
-Basic Configuration
-Scan Schedule / settings
-Self protection
-Core system shield
-System Optimizer
While we still have more to go, we are saving 'Reatime Shield' for last, as we have an inkling that this is causing the problem. The answer from support was to try disabling 'Scan files when written or modified" in the Realtime shield settings. We will be trying this once we get to enabling this feature. If any of you want to try enabling it and letting us know how that works, it may be beneficial. :)
Keep us posted!
I disabled 'Scan files when written or modified.' Will let you know how it goes. 
Hi all,
Ok been practically a week now using UPD for this client and they haven't had the issue once, which is great.
Using UPD is probably an option for many of our clients but not all of them, certainly not graphic design orientated ones.
I look forward to hearing back results from others disabling certain aspects of Webroot. Hopefully that will give us a cause, although for me disabling stuff in a security application is not a solution either!
Be good to keep this thread updated so everyone is in the loop, and then go to Webroot with findings.
How have things been going? Have you guys had any success?
We are just switching on our Realtime shield for testing this week.
I'd also like to see what Webroot has to say about this.
We have a 3rd party hosted citrix that is used in our enviroment and about early january we had this issue start, where we got printers going "offline" while in citrix only (locally the printer worked fine) since it was a 3rd party hosted i didn't have access to the citrix enviroment and had to work with them on getting it fixed, they and never seen this issue and one of the things we did was force these users to use the citrix universal printer driver and this issue has gone away.
I never thought to think of webroot as the cause because at about the same time this 3rd party citrix had us upgrade our "citrix online plugin" to a newer "citrix receiver" version so i assumed the issue was with how the new citrix receiver was handling printing with their server setup.
Eitherway seeing that removing Webroot got rid of this makes me happy i wasn't the only person having this issue.
Just wanted to say that we are having this issue as well.  Did anyone ever find a solution?  We've been struggling with it for a while with a third party vendor who hosts our environment and we connect to them via Citrix.  We've assumed it's an issue with Citrix (either with Receiver or something server-side) but they've not been able to identify anything.  The problem did start for us roughly around the time we switched to Webroot, so given the experiences in this thread, I don't think that's a coincidence.
We've tried using the old Citrix web plugin as well as various versions of Receiver but the problem persists regardless of what client we use.  We were initially using the Citrix Universal Print Driver and have tried switching to the manufacturer specific drivers (ours are Ricoh), but the issue persists regardless of what driver we use.  After reading this thread, we've uninstalled Webroot on one of our user's PCs who prints a lot and thus encounters this problem often.  We should know in a few days if the issue is resolved for that user as a result of the uninstall.  
Quoting a few things from previous replies that explain our experience exactly:
The printers connect successfully, however when they try to print to them the jobs seem to disappear. Attempting to print again, the printer shows offline in the session even though the Windows 7 OS can communicate with the printer fine.
The issue is very sporadic for us, so we are not able to reproduce it on demand.
Hey Twhite,
We are still dealing with this problem on our end. We've narrowed it down to Realtime Shield being the culprit.
We tried turning off all of the settings of Realtime Shield and just leaving the feature itself enabled, but the issue still persisted.
As awful of a solution as it is, disabling Realtime Shield seems to be the only work around to this problem at this time.
We had a trouble ticket opened with Webroot months ago, but it did not seem to go anywhere. We are planning on re-creating a ticket now that we have traced it back to this setting.
I'll keep this thread updated.
Thanks, KurtisDTC.  We were starting to suspect the Realtime Shield and are actually testing disabling it.  Glad to hear that works (not glad that that's necessary, but glad that we're narrowing down the root cause)!

Once we confirm on our end that this solves our problem as well, we'll be opening a ticket with Webroot, too.
Will also update as we learn more.
Just an update:
We seem to have narrowed the issue down to a specific setting within the Realtime Shield policy.  
Scan files when written or modified
We enabled Realtime Shield and tested each setting within it by enabling each setting and then doing some print testing.  We ended up creating a dummy printer so we could spam print jobs and more effectively re-create the issue, which was helpful in narrowing the issue down.
So far, after approximately 1 week, with Realtime Shield ON and "Scan files when written or modified" OFF - we're not seeing the issue occur.  I'm still hesitant to say anything with certainty until more time has passed, due to the seemingly random nature of this problem. We have mistakenly thought it was fixed in the past and been wrong.  But, so far so good.
Will keep this thread updated and once we're more certain of our findings, we will be opening a ticket with Webroot.  I've waited to do that until we feel like we can be as specific as possible when we describe the issue.  
Hopefully this gets some transaction, having to turn that setting off kind of nullifies the purpose of the application 😉
Wanted to check in and see how this has been working with just disabling this setting within the real time sheild? 
We deployed webroot to a client with 50 endpoints about 2 weeks ago. They have been having this exact same issue with their citrix sessions and printers ever since.  Uninstalling webroot totally corrects the issue.  Reading through this thread, I have disabled the real-time sheild as the client needs this working.  If I can just disable one part of the sheild instead of the entire shield, that would be ideal. 
Has anyone heard back from Webroot on a permanent fix for this? 
*EDIT - Just noticed you just posted these findings Tuesday! haha sorry. 
I'd love to know what Webroot Support has seen about this issue also.
I was able to have my third party citrix host change my users to the Universal Citrix Print driver and it has fixed almost everyone, i get the random occasional issue but logging out of that citrix session and disonnecting through the connection center and going back in clears the issue (it was at first affecting every citrix user).
EasyPC do you have the ability to force the universal printer driver and does that fix your issue?
Sadly, the company that hosts the Xenapp server is migrating to a different software solution next year, so they have downsized support to pretty much nothing. So no response from them on enabling the UPD.

Luckily (unluckily??) disabling the real time shield this morning seems to have completely resolved this issue for my users. Really hoping Webroot is working on a fix for this though.
Another update:
We're still good with Realtime Shield ON but "Scan files when written or modified" OFF.  To my knowledge we've had no reportings among our staff of the "offline printer" issue.  We now have a ticket open with Webroot and I'll relay any info we receive.