Folder That wont Delete

  • 3 March 2018
  • 4 replies

Recently, I created a storage folder on my laptop, I cleaned it out, and now it won't delete. The thing that scares me is when I try to remove it says "This file is open in another program." I tried using elevated cmd, but I just got the same message. I checked Task Manager, no suspicious programs were running in the background and I scanned the computer, and it came up clean, so I'm out of ideas. Any help would be appreciated, thanks!

4 replies

Userlevel 7
Hi Creepyolive
There could be a number of reasons for this but often it is done to the vagaries of File Explorer. So you could try this suggested solution from the Microsoft Forums. It may help.
Regards, Baldrick
Sadly, it did not work. The box wasn't checked anyways. Thanks for trying!
Userlevel 7
Ah, well, that was always a distinct possibility.
As I stated previously there could be a number of reasons as to why this is, but mainly it is due to the file being in use by another program, so assuming that you have reboot, and then immediately tried to delete once more, with no success, then what I do in circumstances like this is to use a 3rd party utility  to release the lock on the folder/file.
If that is of interest to you then I would be happy to share the information with you, however, given that it relates to 3rd party software, and this is a Webroot site, please private message me so that we can do so outside the Community as the Community Guideline stipulate.
Finally, though, if you are at all unsure of undertaking/using a 3rd party solution then DO NOT; just leave the folder where it is as most likely it is not causing an issue or impacting your system. That is by far the safest course of action if you have any concerns or worries about this.
Hope that helps further.
Regards, Baldrick